Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

4 Posts

10-02-2021

Japan

5 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎10-02-2021
  • Location: Japan
  • Views: 20
  • Message 1 of 7

P1 not booting while connected to Thunderbolt 3 Dock

2021-10-04, 0:03 AM

Since about 2-3 weeks ago, my Lenovo P1 Gen1 ( has stopped booting if it's connected to my Thunderbolt 3 Dock (40ANY230JP). I have to momentarily unplug the dual-connector (power+Thunderbolt3) to get it to boot. It gets stuck at the pre-boot stage, before any POST messages appear. As soon as you unplug, even for a second, the BIOS-POST messages will start appearing.

 

I have tried with two different discrete Thunderbolt 3 (40Gbps) cable connected to the laptop, both with and without external power to the laptop. I have unplugged the Dock from power for 1hr to make sure it's not any latent setting.

 

Worse yet, while it's stuck at that point, the CPU isn't in full start-up, and is at maximum consumption, meaning that the fans are spinning at full-power and it's getting quite hot. This is bad after an overnight automated reboot after Windows10 installs updates.

 

I'm on the latest firmware for both the dock and the laptop (see below), all drivers are up-to-date.

 

I have tried unplugging everything from the dock to see if it's anything there, and it still happens. I have tried resetting all BIOS settings on the laptop to default too.

 

Reply
Options

3656 Posts

01-08-2021

Philippines

286 Signins

18395 Page Views

  • Posts: 3656
  • Registered: ‎01-08-2021
  • Location: Philippines
  • Views: 18395
  • Message 2 of 7

Re:P1 not booting while connected to Thunderbolt 3 Dock

2021-10-04, 20:53 PM

Hello d__m_o, 

 


Welcome to Lenovo Community

 

 

Kindly disconnect the dock from the ThinkPad P1 Gen1.
Then press the emergency reset hole of the computer.
Unplug the Docking station from the power/wall outlet, then press and hold the power button for 15 seconds.
Reconnect the dock back to the computer and try it again.
Observe and update us how it goes.

 


Regards, 
Lorenzo_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

4 Posts

10-02-2021

Japan

5 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎10-02-2021
  • Location: Japan
  • Views: 20
  • Message 3 of 7

Re:P1 not booting while connected to Thunderbolt 3 Dock

2021-10-04, 23:43 PM

Hi Lorenzo!

 

Thanks for answering. That solution worked, but only once!

 

I unplugged the laptop from the dock connector, held down the emergency reset button on the bottom for 5 seconds. I unplugged the dock from both power supplies, and held down the power button for 15 seconds. I connected things up again, and the laptop booted.

 

I then tried a reboot, and it hung again before boot until I unplugged the dock connector and plugged it in again.

 

I also tried doing a shutdown, waiting 10 seconds, and then pressing the power button on the dock to start the laptop again - it turns on, but again, it hangs before boot.

 

Could this be a problem with the dock?

 

Thanks!

Reply
Options

4360 Posts

12-02-2007

United States of America

9166 Signins

200113 Page Views

  • Posts: 4360
  • Registered: ‎12-02-2007
  • Location: United States of America
  • Views: 200113
  • Message 4 of 7

Re:P1 not booting while connected to Thunderbolt 3 Dock

2021-10-05, 2:54 AM

Hello,


Is there anything plugged into the dock that the ThinkPad P1 Gen 1 could be trying to boot from, such as an external USB hard disk or DVD drive, or even a printer with an SD card reader built into it?

 

Regards,

 

Aryeh Goretsky

 



I am a volunteer and neither a Lenovo nor a Microsoft employee.

L380 YogaP50 (20EN-*)P51sP72 (20MB-*)P43sS230u (3347-4HU)T23 (2648-LU7)T42 (2378-R4U)T43p (2678-H7U)T61p (6459-CTO)W510 (4318-CTO)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)X220 (4286-CTO)X250 (20CM-*)X1e gen3X1 Yoga gen 5X12 gen1X13 gen1Yoga 370

Communities: English Deutsche Español Português Русскоязычное Česká Slovenská Українська Język Polski Moto English


Need an answer, fast? Try using Browser Search to find it in the Lenovo and Moto Community
Reply
Options

4 Posts

10-02-2021

Japan

5 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎10-02-2021
  • Location: Japan
  • Views: 20
  • Message 5 of 7

Re:P1 not booting while connected to Thunderbolt 3 Dock

2021-10-05, 4:28 AM

Hi Aryeh,

 

I have tried with nothing plugged into the dock except for the power to the dock (65W+230W power adaptors) and the dock <-> laptop connector.

 

My typical setup is to have ethernet, 2x DisplayPort, 1x USB3-hub, 1x USB-C-hub and audio out. I have tried with all of them removed and all of them plugged in.

 

In any case, the freeze happens before the POST, that is, before the BIOS screen has up telling you what CPU/Memory/Drives you have. It'll freeze before the POST and stay there until I unplug the dock connector - doesn't matter which end I unplug from, laptop or dock side.

 

In any case, I have the boot options set to boot only from the NVMe drives, though I have tried with full factory default settings.

 

Cheers.

Reply
Options

3656 Posts

01-08-2021

Philippines

286 Signins

18395 Page Views

  • Posts: 3656
  • Registered: ‎01-08-2021
  • Location: Philippines
  • Views: 18395
  • Message 6 of 7

Re:P1 not booting while connected to Thunderbolt 3 Dock

2021-10-13, 19:23 PM

Hi d__m_o,

 


Have you noticed if there's any BIOS, Thunderbolt firmware or docking Station driver/firmware update?
Kindly try to power drain the dock (unplug it from the AC adapter, then press and hold the power button for 15 to 20 seconds)
Then on the machine, go to BIOS, disable the internal battery. Be sure to save before exiting.
Shut down the computer, unplug it from the AC adapter. Press and hold the power button for 15 to 20 seconds.
Reconnect the ThinkPad P1 and Thunderbolt 3 Dock, make sure all cable connections are properly seated.
Turn on the device. Observe and update us how it goes.

 


Regards, 
Lorenzo_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

4 Posts

10-02-2021

Japan

5 Signins

20 Page Views

  • Posts: 4
  • Registered: ‎10-02-2021
  • Location: Japan
  • Views: 20
  • Message 7 of 7

Re:P1 not booting while connected to Thunderbolt 3 Dock

2021-10-14, 0:27 AM

Hi Lorenzo,

 

Yes, I had tried all that. Nothing fixed it. On phone support, they asked me to hold down left-shift while rebooting, and the problem persisted. They are sending me a replacement dock to test. I'll report back when that arrives.

 

Cheers.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All