Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Linux Operating SystemsUbuntu
All Forum Topics
Options

3 Posts

07-05-2021

Italy

3 Signins

10 Page Views

  • Posts: 3
  • Registered: ‎07-05-2021
  • Location: Italy
  • Views: 10
  • Message 1 of 15

P14s Gen 2 - Fan constantly running despite low CPU Usage (max 10%)

2021-07-05, 17:00 PM

I recently bought a new workstation (less than one month) lenovo P14s Gen 2 (intel) and I quickly notice that fans always always run higher than expected, even when no tasks are performed.

Even though fans constantly run, the laptop gets very warm. For instance, right now I have no applications running, but the web browser to write this very post. Yet the fan keeps going.

 

I installed Linux Ubuntu by following the official Lenovo instructions https://download.lenovo.com/pccbbs/mobiles_pdf/tp_p14s_intel_p15s_p15v_ubuntu_20.04_lts_installation_v1.0.pdf

 

The noise is so loud that I'm afraid to annoy people when studying in public libraries.

I am really considering to give the laptop back if this issues can't be solved.

 

Hope for some help.

 

Thanks in advance

Reply
Options

3222 Posts

01-08-2021

Philippines

257 Signins

16295 Page Views

  • Posts: 3222
  • Registered: ‎01-08-2021
  • Location: Philippines
  • Views: 16295
  • Message 2 of 15

Re:P14s Gen 2 - Fan constantly running despite low CPU Usage (max 10%)

2021-07-05, 21:54 PM

Hello CECILIA SARTORI,

 


Welcome to Lenovo Community

 

 

Kindly try loading the BIOS default settings, be sure to save and exit.
Next step is to go to the support site and install the latest version of BIOS, drivers and firmware.
You may also run diagnostics.
Update us how it goes.

 


Regards, 
Lorenzo_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

4 Posts

07-06-2021

Germany

2 Signins

100 Page Views

  • Posts: 4
  • Registered: ‎07-06-2021
  • Location: Germany
  • Views: 100
  • Message 3 of 15

Re:P14s Gen 2 - Fan constantly running despite low CPU Usage (max 10%)

2021-07-06, 0:38 AM

I have the exact same problem. You can use FN + L to set the fan on energy saving mode, this will lower the noise BUT it also throttles your CPU and you lose 70% of the performance. 

 

Unbelievable that we buy a 2000$ Laptop without ANY reliable thermal control. FN + H sets the Cpu to performance mode, but the fans are blowing non stop at 5000 rpm even on idle. I will return my device unfortunately, this is a deal breaker.

Reply
Options

381 Posts

09-04-2019

United States of America

293 Signins

4273 Page Views

  • Posts: 381
  • Registered: ‎09-04-2019
  • Location: United States of America
  • Views: 4273
  • Message 4 of 15

Re:P14s Gen 2 - Fan constantly running despite low CPU Usage (max 10%)

2021-07-06, 2:45 AM

Laptop is really designed for Windows 10.

Reply
Options

4 Posts

07-06-2021

Germany

2 Signins

100 Page Views

  • Posts: 4
  • Registered: ‎07-06-2021
  • Location: Germany
  • Views: 100
  • Message 5 of 15

Re:P14s Gen 2 - Fan constantly running despite low CPU Usage (max 10%)

2021-07-06, 5:43 AM
Same issue with Windows 10 aswell though
Reply
Options

3 Posts

07-05-2021

Italy

3 Signins

10 Page Views

  • Posts: 3
  • Registered: ‎07-05-2021
  • Location: Italy
  • Views: 10
  • Message 6 of 15

Re:P14s Gen 2 - Fan constantly running despite low CPU Usage (max 10%)

2021-07-06, 15:17 PM

No good news till now.

Bios was updated to N34ET37W (1.37) version released on 2021 - 06 - 12 directly by the Lenovo Repair Center I was forced to contact as soon as I received the laptop since a manufacturing defect came out (dark spot on video).

Firmware updates automatically when I turn on the laptop this morning, but fans keep working.

 

I can't believe I paid so much and waste precious time to have still a not reliable machine. You could literally burn your hand touching the back of the laptop after few hours of simple browsing the web. This is my first Lenovo product and I was so sure it would have be a great choice.  I'm rather demoralised instead

Reply
Options

4 Posts

07-06-2021

Germany

2 Signins

100 Page Views

  • Posts: 4
  • Registered: ‎07-06-2021
  • Location: Germany
  • Views: 100
  • Message 7 of 15

Re:P14s Gen 2 - Fan constantly running despite low CPU Usage (max 10%)

2021-07-06, 22:57 PM

Did you try using the power efficient mode in Linux pressing FN + L ?

It helps me to keep the device calm however I also lose alot of my CPU power. I dont understand why there are 3 static power modes, cant they implement proper automatic systems in 2021?

Reply
Options

3 Posts

07-05-2021

Italy

3 Signins

10 Page Views

  • Posts: 3
  • Registered: ‎07-05-2021
  • Location: Italy
  • Views: 10
  • Message 8 of 15

Re:P14s Gen 2 - Fan constantly running despite low CPU Usage (max 10%)

2021-07-07, 7:57 AM

Thanks for your suggestion. Running in balanced power to avoid an heavy performance loss.

I'm afraid I can't select 'Power Saver' mode since I'm working on large data operations and I need efficient and fast processing.

Reply
Options

679 Posts

07-22-2019

Canada

472 Signins

5381 Page Views

  • Posts: 679
  • Registered: ‎07-22-2019
  • Location: Canada
  • Views: 5381
  • Message 9 of 15

Re:P14s Gen 2 - Fan constantly running despite low CPU Usage (max 10%)

2021-07-13, 14:40 PM

Hi - afraid I don't have any experience directly with the P14s G2 as from a Linux point of view we're still doing HW enablement so Linux support is not complete yet - but I'll flag this to the BIOS team as the fans are controlled by the EC firmware. I also saw above that Windows is impacted so this might not be the best forum right now...but let's see what we can do to get some answers (and I will need this solved for Linux soon). The below is for Linux users:

 

Could you attach the output from 'sensors' - showing temps and fan.

If available please also do:

modprobe ec_sys
hexdump -C /sys/kernel/debug/ec/ec0/io

Note - on Fedora the ec_sys module isn't available by default so I usually end up doing a kernel rebuild - but for those on Ubuntu (or derivative) based systems it should be there.

 

Thanks

Mark

Reply
Options

4 Posts

07-08-2021

Austria

5 Signins

65 Page Views

  • Posts: 4
  • Registered: ‎07-08-2021
  • Location: Austria
  • Views: 65
  • Message 10 of 15

Re:P14s Gen 2 - Fan constantly running despite low CPU Usage (max 10%)

2021-07-15, 12:08 PM

Hey, as I have the same model with the exact same issues (and all my colleagues aswell who got the laptop recently), I will

post my sensors output here. I have attached a hexdump log aswell. I hope this

 

ucsi_source_psy_USBC000:002-isa-0000
Adapter: ISA adapter
in0:           5.00 V  (min =  +5.00 V, max = +20.00 V)
curr1:         3.00 A  (max =  +3.25 A)

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +39.0°C  

thinkpad-isa-0000
Adapter: ISA adapter
fan1:        3858 RPM
temp1:        +43.0°C  
temp2:            N/A  
temp3:        +35.0°C  
temp4:         +0.0°C  
temp5:        +36.0°C  
temp6:        +43.0°C  
temp7:        +43.0°C  
temp8:            N/A  

BAT0-acpi-0
Adapter: ACPI interface
in0:          13.05 V  

ucsi_source_psy_USBC000:001-isa-0000
Adapter: ISA adapter
in0:           0.00 V  (min =  +0.00 V, max =  +0.00 V)
curr1:         0.00 A  (max =  +0.00 A)

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +42.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +39.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +39.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +40.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +37.0°C  (high = +100.0°C, crit = +100.0°C)

nvme-pci-0400
Adapter: PCI adapter
Composite:    +44.9°C  (low  = -273.1°C, high = +83.8°C)
                       (crit = +84.8°C)
Sensor 1:     +44.9°C  (low  = -273.1°C, high = +65261.8°C)
Sensor 2:     +42.9°C  (low  = -273.1°C, high = +65261.8°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +43.0°C  (crit = +128.0°C)

 

Hexdump:

 

00000000  e6 05 38 c4 00 86 05 00  00 08 47 00 00 01 80 00  |..8.......G.....|
00000010  00 00 ff ff d0 bd 00 19  7b ff 00 00 ff ff 5f 0f  |........{....._.|
00000020  10 00 00 00 00 00 06 28  00 00 00 00 ff 00 00 80  |.......(........|
00000030  00 40 02 00 70 04 00 00  84 00 60 10 00 5f 00 00  |.@..p.....`.._..|
00000040  00 00 00 00 00 00 50 06  51 1c 00 00 00 00 00 00  |......P.Q.......|
00000050  00 80 02 03 00 00 00 20  2c b1 04 13 01 00 00 00  |....... ,.......|
00000060  45 41 16 00 00 00 00 00  00 00 00 00 00 00 00 00  |EA..............|
00000070  00 00 00 00 04 00 00 00  26 80 23 00 23 26 26 80  |........&.#.#&&.|
00000080  00 00 05 06 19 0d 02 00  40 00 00 00 00 00 2b 00  |........@.....+.|
00000090  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
000000a0  ec 13 ed 13 ff ff 64 00  00 00 fc 32 ff ff e0 00  |......d....2....|
000000b0  00 00 00 00 00 00 00 1f  01 00 2d 05 00 00 00 00  |..........-.....|
000000c0  00 00 42 00 00 80 02 02  00 41 00 03 08 00 00 00  |..B......A......|
000000d0  1a c0 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
000000e0  00 00 00 00 00 00 00 00  13 40 17 24 e4 ae 44 03  |.........@.$..D.|
000000f0  4e 33 34 48 54 33 34 57  2a d2 7c 31 00 00 00 00  |N34HT34W*.|1....|
00000100

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms