Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

7 Posts

11-21-2016

United States of America

13 Signins

99 Page Views

  • Posts: 7
  • Registered: ‎11-21-2016
  • Location: United States of America
  • Views: 99
  • Message 1 of 14

P50 BIOS 1.35 not allowing Legacy boot

2016-11-21, 9:17 AM

After disabling Secure Boot and restarting my P50,  I do not have the option to select a Legacy boot in the BIOS Startup tab.  The UEFI/Legacy Boot option is disabled and shows UEFI Only.

 

Any help is truly appreciated.

 

 Thanks.

Reply
Options

7 Posts

11-21-2016

United States of America

13 Signins

99 Page Views

  • Posts: 7
  • Registered: ‎11-21-2016
  • Location: United States of America
  • Views: 99
  • Message 2 of 14

Re: P50 BIOS 1.35 not allowing Legacy boot

2016-11-21, 9:38 AM

BIOS screenshot

Reply
Options

7 Posts

11-21-2016

United States of America

13 Signins

99 Page Views

  • Posts: 7
  • Registered: ‎11-21-2016
  • Location: United States of America
  • Views: 99
  • Message 3 of 14

Re: P50 BIOS 1.35 not allowing Legacy boot

2016-11-21, 9:39 AM

BIOS screenshot

Reply
Options

8972 Posts

01-13-2008

United States of America

77770 Signins

2226970 Page Views

  • Posts: 8972
  • Registered: ‎01-13-2008
  • Location: United States of America
  • Views: 2226970
  • Message 4 of 14

Re: P50 BIOS 1.35 not allowing Legacy boot

2016-11-21, 14:21 PM

What happens if you arrow down in the Startup tab, highlight "UEFI/Legacy boot" and hit ENTER?

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

7 Posts

11-21-2016

United States of America

13 Signins

99 Page Views

  • Posts: 7
  • Registered: ‎11-21-2016
  • Location: United States of America
  • Views: 99
  • Message 5 of 14

Re: P50 BIOS 1.35 not allowing Legacy boot

2016-11-21, 16:12 PM

I cannot highlith it.  If I try to select the option it skips it.

Reply
Options

64 Posts

03-16-2016

United States of America

1526 Signins

5585 Page Views

  • Posts: 64
  • Registered: ‎03-16-2016
  • Location: United States of America
  • Views: 5585
  • Message 6 of 14

Re: P50 BIOS 1.35 not allowing Legacy boot

2016-11-21, 20:03 PM

Try resetting the BIOS to the default settings, then save and exit.  Go back into the BIOS and see if you can change your settings.

 

Mike

Reply
Options

337 Posts

11-13-2010

United States of America

542 Signins

4968 Page Views

  • Posts: 337
  • Registered: ‎11-13-2010
  • Location: United States of America
  • Views: 4968
  • Message 7 of 14

Re: P50 BIOS 1.35 not allowing Legacy boot

2016-11-24, 22:50 PM

OP, have you solved this problem yet? Please let us know.

I am hesitated to upgrade the BIOS to v1.35 now. Because I have Linux OS installed to use the Legacy boot option and I have to turn off the Secure Booting option.

-----------------------------------------------------------------------------
TPs own: X31 (2003), X61T, X200T, Tablet 2, P50 (2016); Win XP-10, Ubuntu8.04-16.04.
Reply
Options

7 Posts

11-21-2016

United States of America

13 Signins

99 Page Views

  • Posts: 7
  • Registered: ‎11-21-2016
  • Location: United States of America
  • Views: 99
  • Message 8 of 14

Re: P50 BIOS 1.35 not allowing Legacy boot

2016-11-24, 22:58 PM

The problem persists even after resetting to defaults.  The option to select UEFI or lava you is still disabled.  I had to create a UEFI-complaint bootable USB drive to reinstall the  OS.

 

It seems to be a BIOS bug introduced in the latest version.

Reply
Options

337 Posts

11-13-2010

United States of America

542 Signins

4968 Page Views

  • Posts: 337
  • Registered: ‎11-13-2010
  • Location: United States of America
  • Views: 4968
  • Message 9 of 14

Re: P50 BIOS 1.35 not allowing Legacy boot

2016-11-24, 23:02 PM

Thank you for reporting! I hope Lenovo engineers will fix this bug in their next BIOS release.

-----------------------------------------------------------------------------
TPs own: X31 (2003), X61T, X200T, Tablet 2, P50 (2016); Win XP-10, Ubuntu8.04-16.04.
Reply
Options

1609 Posts

09-16-2014

United States of America

3048 Signins

61403 Page Views

  • Posts: 1609
  • Registered: ‎09-16-2014
  • Location: United States of America
  • Views: 61403
  • Message 10 of 14

Re: P50 BIOS 1.35 not allowing Legacy boot

2016-11-29, 0:40 AM

Marcialj,

 

Has the system storage been set up in RAID mode? The symptoms you describe are consistent with the expected behavior when RAID is configured. If not, please let me know so I can notify Think Engineering.

 

Thank you,

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms