Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

184 Posts

01-01-2016

United States of America

1927 Signins

20495 Page Views

  • Posts: 184
  • Registered: ‎01-01-2016
  • Location: United States of America
  • Views: 20495
  • Message 1 of 7

P50 CPU always at max frequency (with no load)

2017-07-24, 16:27 PM

My P50 i7-6820HQ always runs near max turbo speed in Windows 10, even with no load.  I'm not sure when this changed, but I know it behaved properly in the past with low idle speeds and often 0 fan speed.

 

 

I don't see anything unusual in BIOS (1.42).  I temporarily reverted to an earlier BIOS when I noticed the issue, but this had no effect.

 

I don't see any programs or services that look unusual.  Power profiles have no effect.  Same on battery or AC.  I regularly scan for spyware, etc.

 

Any suggestions will be appreciated.

 

Reply
Options

331 Posts

08-28-2013

United States of America

628 Signins

5793 Page Views

  • Posts: 331
  • Registered: ‎08-28-2013
  • Location: United States of America
  • Views: 5793
  • Message 2 of 7

Re: P50 CPU always at max frequency (with no load)

2017-07-25, 21:44 PM

In the bios do you see a setting for speedstep? Also what widget is that that shows that info?

EDIT: Also do you have this issue if you disable virtualization in the bios?

I own a Y510p SLI (retired), Yoga 2 Pro, X220T, P50 4K (sold), X1C5
Reply
Options

184 Posts

01-01-2016

United States of America

1927 Signins

20495 Page Views

  • Posts: 184
  • Registered: ‎01-01-2016
  • Location: United States of America
  • Views: 20495
  • Message 3 of 7

Re: P50 CPU always at max frequency (with no load)

2017-07-25, 22:44 PM

I changed all the pertinent settings in BIOS and then switched them back again, but this had no effect.  Switching between Win 10 power settings (High Performance and Balanced) had no effect.

 

But this seems to have worked: I run on AC 99% of the time.  I unplugged from AC, switched from Balanced to High Perf, then back to Balanced again.  I plugged back into AC and now Speedstep appears to be acting properly.  At least CPU speed often drops vey low.  However, it still goes all the way to max much of the time with no load.  And the fan speed is rarely at zero.  I think I recall that several months ago CPU used to stay lower and fan speed was often at zero.

 

Anyway, this is an improvement.  Fan is quiet, temps are good, and CPU speed does drop part of the time.

 

If I switch to High Perf, then CPU stays near maximum always.  Maybe this is the intended behavior.

 

I did not try disabling virtualization.

 

FYI, the widget above is something I custom made in AIDA64.

 

Reply
Options

331 Posts

08-28-2013

United States of America

628 Signins

5793 Page Views

  • Posts: 331
  • Registered: ‎08-28-2013
  • Location: United States of America
  • Views: 5793
  • Message 4 of 7

Re: P50 CPU always at max frequency (with no load)

2017-07-25, 22:50 PM
Ah, yeah I would try the virtualization off and see if makes any difference also if you want to roll back your bios try 1.38 as your target as it seems to be before many had issues with this and that with things like docks. I use Aida64 but as sensor icons on the system tray.
I own a Y510p SLI (retired), Yoga 2 Pro, X220T, P50 4K (sold), X1C5
Reply
Options

184 Posts

01-01-2016

United States of America

1927 Signins

20495 Page Views

  • Posts: 184
  • Registered: ‎01-01-2016
  • Location: United States of America
  • Views: 20495
  • Message 5 of 7

Re: P50 CPU always at max frequency (with no load)

2017-07-26, 2:14 AM

I tried BIOS 1.38 and turned off virtualization.  No change.  Speedstep is working in Win 10 Balanced power setting, but with CPU often high under no load, and fan speed never goes to zero (as it used to at some point in the past).

 

Does your fan stay at zero most of the time while your P50 is idle?

 

Here's a pic from last December when the P50 was a few weeks old:

 

Note the difference in fan speed.

 

Oh, well.  Not so bad now.  Temps are good.  No fan noise.  I'm just wondering why behavior has changed somewhat from previous experience, and how this will affect component life.

 

Reply
Options

331 Posts

08-28-2013

United States of America

628 Signins

5793 Page Views

  • Posts: 331
  • Registered: ‎08-28-2013
  • Location: United States of America
  • Views: 5793
  • Message 6 of 7

Re: P50 CPU always at max frequency (with no load)

2017-07-26, 2:55 AM

Yeah that does seem odd like perhaps the bios update also gave you a EC update to the fan firmware. Also I can not see any of the fans for my P50 in Aida64 but I also have the xeon system board and a E3-1505M v5 so perhaps it can't read its sensors.

 

EDIT: might also want to take a look at what they say on here perhaps you also got a gpu driver update recently?

https://forums.lenovo.com/t5/ThinkPad-P-and-W-Series-Mobile/Lenovo-p50-fan-running-constantly-at-max-speed-with-NO-load/m-p/3453339/highlight/true#M63292

I own a Y510p SLI (retired), Yoga 2 Pro, X220T, P50 4K (sold), X1C5
Reply
Options

184 Posts

01-01-2016

United States of America

1927 Signins

20495 Page Views

  • Posts: 184
  • Registered: ‎01-01-2016
  • Location: United States of America
  • Views: 20495
  • Message 7 of 7

Re: P50 CPU always at max frequency (with no load)

2017-07-27, 2:48 AM

Yeah, there was a recent GPU driver update.  Not sure if the problem existed before that.  I updated the Thunderbolt driver today in case that had something to do with it.  No real change, but the fan does drop to zero when the machine is completely idle for a few minutes.

 

I think the fan does run more than it used to, but not at overly high speeds, so it's not a big problem now.  Thanks for your input.

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms