Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

134 Posts

06-29-2008

Australia

365 Signins

1652 Page Views

  • Posts: 134
  • Registered: ‎06-29-2008
  • Location: Australia
  • Views: 1652
  • Message 1 of 8

P51 2.5" drive does not power or detect in dedicated 2.5"slot

2019-03-29, 9:37 AM

Hi, have a P51 and been trying to install a 2.5"drive into the dedicated 2.5 slot (red). When I try to boot it shows the 2103 hdd not detected error. As far as I can tell the disk isn't powering on either.

 

On a whim I've tried plugging it into the other non dedicated 2.5 slot  (coloured blue) and it powers up and appears to work fine fine. I'm using the same framing (not sure what the term is - the thing that plugs into the SATA and connects to the red and blue), so to me it then suggests something wrong with the actual red socket.

 

Just wanted to check there wasn't some BIOS setting or something else esoteric that I've missed that could be preventing this from powering on?

 

cheers!

Reply
Options

10583 Posts

09-04-2014

Slovakia

32859 Signins

1222070 Page Views

  • Posts: 10583
  • Registered: ‎09-04-2014
  • Location: Slovakia
  • Views: 1222070
  • Message 2 of 8

Re: P51 2.5" drive does not power or detect in dedicated 2.5"slot

2019-03-29, 10:46 AM
 

Andy

 

English Community Administrator
Lenovo eServices

Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points 
Did you find a post helpfull? You can thank the member by awarding them a Thumbs Up
 

Please don't ask me questions by Personal Message; questions belong in the forums.


Using Browser Search to find your answers in Lenovo and Moto Community
Reply
Options

11862 Posts

01-02-2010

United States of America

40163 Signins

422634 Page Views

  • Posts: 11862
  • Registered: ‎01-02-2010
  • Location: United States of America
  • Views: 422634
  • Message 3 of 8

Re: P51 2.5" drive does not power or detect in dedicated 2.5"slot

2019-03-29, 19:22 PM

I assume you know that the cables for the left bay and right bay are different.  What does it show in the boot order tab in the BIOS?


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Options

134 Posts

06-29-2008

Australia

365 Signins

1652 Page Views

  • Posts: 134
  • Registered: ‎06-29-2008
  • Location: Australia
  • Views: 1652
  • Message 4 of 8

Re: P51 2.5" drive does not power or detect in dedicated 2.5"slot

2019-04-01, 23:49 PM

Hi Rich,

 

Yes I am aware the cables for the bays are different. To clarify: I used the cable for the right bay (the bay under the red socket) in the left bay socket (blue socket) and it worked fine (yes, was quite hard to hold this in place). The reason I did this was to confirm that the cable was working.

 

Regarding boot order - just to clarify again: I am booting off an NVME, and the drive is just for storage. My hope is that the boot order wasn't relevant, but it is: Windows Boot Manager, NVMe0, USB HDD, USB FD, USB CD, NVMe1, and then the SATA hdds (exact order I can't remember). 

 

I can clarify if it is material however.

 

thanks!

 

Reply
Options

11862 Posts

01-02-2010

United States of America

40163 Signins

422634 Page Views

  • Posts: 11862
  • Registered: ‎01-02-2010
  • Location: United States of America
  • Views: 422634
  • Message 5 of 8

Re: P51 2.5" drive does not power or detect in dedicated 2.5"slot

2019-04-02, 0:10 AM

I don't have a P51 to try, but it sounds like a bad socket.  All I can think to try is to make sure you have the latest BIOS and hitting F9 to load BIOS defaults, after making a note of any settings that were changed previously. 


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
Reply
Options

2 Posts

12-11-2019

United States of America

2 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎12-11-2019
  • Location: United States of America
  • Views: 30
  • Message 6 of 8

Re: P51 2.5" drive does not power or detect in dedicated 2.5"slot

2019-12-11, 4:06 AM

Did you ever resolve this issue? I'm having the same problem with my P50 and a new 2.5" SSD—the 2.5" isn't detected (error 2103) when connected to the appropriate 2.5" bay connector, but is detected and works fine when connected to the adjacent NVMe slot connector.

Reply
Options

2 Posts

12-11-2019

United States of America

2 Signins

30 Page Views

  • Posts: 2
  • Registered: ‎12-11-2019
  • Location: United States of America
  • Views: 30
  • Message 7 of 8

Re:P51 2.5" drive does not power or detect in dedicated 2.5"slot

2020-06-27, 1:05 AM

Just following up once more to ask if you've found a solution to this issue.

Reply
Options

134 Posts

06-29-2008

Australia

365 Signins

1652 Page Views

  • Posts: 134
  • Registered: ‎06-29-2008
  • Location: Australia
  • Views: 1652
  • Message 8 of 8

Re:P51 2.5" drive does not power or detect in dedicated 2.5"slot

2020-06-27, 7:13 AM

Sorry hexagon, I'm afraid not.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms