English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

5 Posts

11-28-2020

Germany

4 Signins

10 Page Views

  • Posts: 5
  • Registered: ‎11-28-2020
  • Location: Germany
  • Views: 10
  • Message 1 of 7

P53 + Thunderbolt 3 Workstation Dock Gen 2 External monitor blanks after dock firmware upgrade

2020-11-28, 12:22 PM

After updating the docking station to firmware version 3.1.67 the external monitor connected to the docking station blanks after several hours of work and the monitor shows that there is no signal.

The only way to reactivate the monitor is to disconnect and reconnect the docking station from the laptop.

It happens with 2 different docking stations after the updating the firmware. It also happens with HDMI and Display Port connected external monitors.

The laptop is running hybrid graphics with Intel UHD 630 and NVIDIA Quadro RTX 4000.

Reply
Options

73 Posts

08-14-2018

China

125 Signins

580 Page Views

  • Posts: 73
  • Registered: ‎08-14-2018
  • Location: China
  • Views: 580
  • Message 2 of 7

Re:P53 + Thunderbolt 3 Workstation Dock Gen 2 External monitor blanks after dock firmware upgrade

2020-12-10, 6:27 AM

Dear customer,

thank you for your information. We have successfully duplicated this issue in lab, will forward to engineer to debug.

 

BR,

Sunny

Reply
Options

73 Posts

08-14-2018

China

125 Signins

580 Page Views

  • Posts: 73
  • Registered: ‎08-14-2018
  • Location: China
  • Views: 580
  • Message 3 of 7

Re:P53 + Thunderbolt 3 Workstation Dock Gen 2 External monitor blanks after dock firmware upgrade

2020-12-11, 8:51 AM

Dear customer,

Could you tell us what is the part number of those two different docking ? and what is the external monitor modle and resolution you used ?

We have seen this symptom with one HDMI or one DP monitor attached to dock. But haven't duplicated with two external monitor connected.

 

BR,

Sunny

Reply
Options

5 Posts

11-28-2020

Germany

4 Signins

10 Page Views

  • Posts: 5
  • Registered: ‎11-28-2020
  • Location: Germany
  • Views: 10
  • Message 4 of 7

Re:P53 + Thunderbolt 3 Workstation Dock Gen 2 External monitor blanks after dock firmware upgrade

2020-12-11, 11:04 AM

Hi Sunny,

see the details of my setup below:

 

Docking-Station 1
Model No: DK1841
ASM PN: SD20M70247
FRU PN: 03X7538
Connection: DP
Monitor: ASUS PB278
Resolution: 2560 x 1440

Docking-Station 2
Model No: DK1841
ASM PN: SD20M70247
FRU PN: 03X7538
Connection: HDMI
Monitor: Dell UltraSharp 25 
Resolution: 2560 x 1440

 

Best,

Oliver

Reply
Options

5 Posts

11-28-2020

Germany

4 Signins

10 Page Views

  • Posts: 5
  • Registered: ‎11-28-2020
  • Location: Germany
  • Views: 10
  • Message 5 of 7

Re:P53 + Thunderbolt 3 Workstation Dock Gen 2 External monitor blanks after dock firmware upgrade

2021-01-26, 11:05 AM

Is there any status update? The issue still occurs several times per day.

Reply
Options

7 Posts

09-18-2020

United States of America

6 Signins

45 Page Views

  • Posts: 7
  • Registered: ‎09-18-2020
  • Location: United States of America
  • Views: 45
  • Message 6 of 7

Re:P53 + Thunderbolt 3 Workstation Dock Gen 2 External monitor blanks after dock firmware upgrade

2021-01-27, 9:08 AM

Using a DP or HDMI-DVI adapter somewhere along the cable (either on the dock or on the monitor) fixes this for me.  I think it's an HDMI-CEC issue as I have the same problem with my monitors.  

 

However, when I connect a TV, the TV actually gets turned off instead of blinking/going into standby.

 

Using Microsoft Office or Edge full-screen exacerbates the issue tremendously. 

Reply
Options

5 Posts

11-28-2020

Germany

4 Signins

10 Page Views

  • Posts: 5
  • Registered: ‎11-28-2020
  • Location: Germany
  • Views: 10
  • Message 7 of 7

Re:P53 + Thunderbolt 3 Workstation Dock Gen 2 External monitor blanks after dock firmware upgrade

2021-01-28, 13:43 PM

Thanks for sharing the workaround idea. Before I connected the monitor to the dock via HDMI I used the DP connection and the monitor showed flickering and was blanking as well. Switching to HDMI worked before the mentioned firmware upgrade of the dock happened.

 

I completely see Lenovo in the role to fix the issue instead of applying workarounds and I'm very disappointed about their unresponsiveness even after they have been able to reproduce the mentioned issue. Because the laptop and the dock are only half a year old it is pretty much a warranty case but not treated like one.

I get the feeling that Lenovo stopped being a brand enterprise customer can rely on.

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms