Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

34 Posts

11-28-2017

United States of America

2091 Signins

4707 Page Views

  • Posts: 34
  • Registered: ‎11-28-2017
  • Location: United States of America
  • Views: 4707
  • Message 1 of 44

P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-13, 15:11 PM

Just Updated Thunderbolt Firmware via Lenovo Vantage. Lost audio in HDMI output to Sony TV. Video on HDMI output is OK.

The list of audio devices for Nvidia HD Audio shows No Audio Devices Plugged in. Realtek  Audio to Laptop Speaker is OK. Please Help!

Reply
Answer
Options

34 Posts

11-28-2017

United States of America

2091 Signins

4707 Page Views

  • Posts: 34
  • Registered: ‎11-28-2017
  • Location: United States of America
  • Views: 4707

Re:P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-27, 13:32 PM

The update is available at the following for those who are ready:

 

https://support.lenovo.com/ve/en/downloads/ds121792

 

Edit: Installed and working. Nvidia shows correct HDMI connection. Audio and Video back to normal.

Reply

Replies(43)
Options

2810 Posts

06-13-2013

United States of America

11389 Signins

61996 Page Views

  • Posts: 2810
  • Registered: ‎06-13-2013
  • Location: United States of America
  • Views: 61996
  • Message 2 of 44

Re:P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-13, 19:52 PM

What is your machine??

 

Is your HDMI connection to the TV through the laptop's HDMI port, or via an external dock/dongle connected to a Thunderbolt port?

 

What version do you have for your nVidia driver? From Lenovo/Vantage, or retail version from the nVidia site?

 

Are you running BIOS as "hybrid graphics", or "discrete graphics", if those are available on your specific machine type?

 

What other external connections do you have? Do you have a USB-C/TB3 dock or dongle or something? What devices are connected through it?

 

Reply
Options

34 Posts

11-28-2017

United States of America

2091 Signins

4707 Page Views

  • Posts: 34
  • Registered: ‎11-28-2017
  • Location: United States of America
  • Views: 4707
  • Message 3 of 44

Re:P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-14, 0:17 AM

Machine Type P71 20HK    TV Connection is Laptop HDMI Port.  nVidia driver is Version 27.21.14.6230  Running Hybrid Graphics in BIOS

No other connections. Thunderbolt ports not used. USB ports not used. Never had any problems before. Thunderbolt Firmware Updated today 7/13/21

Via Lenovo Vantage

 

 

Reply
Options

4 Posts

07-14-2021

United States of America

3 Signins

15 Page Views

  • Posts: 4
  • Registered: ‎07-14-2021
  • Location: United States of America
  • Views: 15
  • Message 4 of 44

Re:P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-14, 16:15 PM

I completed the same firmware update yesterday, now the external monitor I was running at home on HDMI at 2560x1080 is limited to 1920x1080, and the connection type comes up as DVI in Nvidia control panel.  I have an ultrawide at work connected with displayport on a dock and it is unaffected.  Machine type is 20HKCTO1WW.  I tried flashing an older version, updating video drivers, no luck.  Any help would be appreciated.

Reply
Options

2810 Posts

06-13-2013

United States of America

11389 Signins

61996 Page Views

  • Posts: 2810
  • Registered: ‎06-13-2013
  • Location: United States of America
  • Views: 61996
  • Message 5 of 44

Re:P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-14, 18:37 PM

@ steakfries wrote:

I completed the same firmware update yesterday, now the external monitor I was running at home on HDMI at 2560x1080 is limited to 1920x1080, and the connection type comes up as DVI in Nvidia control panel.  I have an ultrawide at work connected with displayport on a dock and it is unaffected.  Machine type is 20HKCTO1WW.  I tried flashing an older version, updating video drivers, no luck.  Any help would be appreciated.

 

Just in passing, I've not heard of 2560x1080 resolution before. Was this a "custom" non-standard resolution that you previously configured with NVidia Control Panel? Is it no longer possible to configure that?  What kind of monitor is this?  Was 2560x1080 its "native" resolution?

 

Of course the fact that it shows up as DVI (presumably you're looking at the PhysX output of NVidia Control Panel, yes?) is definitely strange.

 

Once again, are you running "hybrid graphics" or "discrete graphics"?

Reply
Options

34 Posts

11-28-2017

United States of America

2091 Signins

4707 Page Views

  • Posts: 34
  • Registered: ‎11-28-2017
  • Location: United States of America
  • Views: 4707
  • Message 6 of 44

Re:P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-14, 19:38 PM

@ DSperber wrote:

@ steakfries wrote:

I completed the same firmware update yesterday, now the external monitor I was running at home on HDMI at 2560x1080 is limited to 1920x1080, and the connection type comes up as DVI in Nvidia control panel.  I have an ultrawide at work connected with displayport on a dock and it is unaffected.  Machine type is 20HKCTO1WW.  I tried flashing an older version, updating video drivers, no luck.  Any help would be appreciated.

 

Just in passing, I' not heard of 2560x1080 resolution before. Was this a "custom" non-standard resolution that you previously configured with NVidia Control Panel? Is it no longer possible to configure that?  What kind of monitor is this?  Was 2560x1080 its "native" resolution?

 

Of course the fact that it shows up as DVI (presumably you' looking at the PhysX output of NVidia Control Panel, yes?) is definitely strange.

 

Once again, are you running "hybrid graphics" or "discrete graphics"?

 

My update also changed output resolution from 2160x3840 to 1080x1920 and also lists the output as DVI

Reply
Options

4 Posts

07-14-2021

United States of America

3 Signins

15 Page Views

  • Posts: 4
  • Registered: ‎07-14-2021
  • Location: United States of America
  • Views: 15
  • Message 7 of 44

Re:P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-14, 21:57 PM

Monitor is an LG 34WL500-B, 2560x1080 native resolution.  It won't let me configure anything above 1920x1080, even as custom.  Yes, shows up in the Nvidia panel as connected to DVI in the system topology.  Running a Quadro P4000, discrete.

Reply
Options

5 Posts

07-15-2021

United States of America

3 Signins

15 Page Views

  • Posts: 5
  • Registered: ‎07-15-2021
  • Location: United States of America
  • Views: 15
  • Message 8 of 44

Re:P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-15, 16:34 PM

Same problem this morning (7/15/2021), called support (1.800.426.7378 option #1, 1, 1) got disconnected from first tech, called back spent 5 minutes with another tech got put on hold for 5-8 minutes before getting dropped.  Call again, got another tech and had to explain it all again, got put on hold for 5 minutes someone from the IBM side picked up like it was a new call!  Got sent back to the Lenovo side to another tech (now I'm not happy).  After explaining the issue for the 4th or 5th time she ask me if I could swap the HDMI cable...this is when I lost my $&17 and explained the monitor and cable work just fine in 4K on the desktop setting next to my laptop and it worked just fine on the laptop this morning before this firmware update.  She then told me since I was out of warranty she could refer me to a local business partner.  I lost it again and just told her she was wasting my time and hung up on her.  Called back (after cooling down) and once I got a human on the line I asked for a manager and explained I was not happy.  Explained the whole issue again, this time I was given a ticket number and told there is no manager available at this time, but she was going to request an escalation and wave the no-warranty issue since the firmware update was the issue.  I am waiting on the call back, it may not happen until tomorrow though.

 

I will keep you posted,  but in the meantime everyone with this issue should call support @ 1.800.426.7378 and open a ticket.

 

 

Reply
Options

34 Posts

11-28-2017

United States of America

2091 Signins

4707 Page Views

  • Posts: 34
  • Registered: ‎11-28-2017
  • Location: United States of America
  • Views: 4707
  • Message 9 of 44

Re:P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-15, 19:28 PM

Called support with similar results but did not escalate yet.

As an possible interim solution, I have the following being delivered tomorrow;

 

https://www.amazon.com/gp/product/B08KXND4Y1/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1

Reply
Options

449 Posts

03-03-2017

Japan

1483 Signins

13368 Page Views

  • Posts: 449
  • Registered: ‎03-03-2017
  • Location: Japan
  • Views: 13368
  • Message 10 of 44

Re:P71 Lost HDMI Audio w/Latest Thunderbolt Firmware

2021-07-16, 2:26 AM

Dear customers,

I'm sorry to trouble you, can you try to roll back the Thunderbolt firmware level back to "43" by applying below package manually

in order to recover previous functionalities?

 

https://download.lenovo.com/pccbbs/mobiles/n1tbd05w.exe

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms