Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

2 Posts

03-18-2019

Canada

4 Signins

73 Page Views

  • Posts: 2
  • Registered: ‎03-18-2019
  • Location: Canada
  • Views: 73
  • Message 1 of 1

[Potential Fix] P72 Linux unable to stay in sleep mode

2021-01-09, 20:23 PM

Sometime late last night, I decided to jump into the BIOS settings to find out if there is an option to control fan speed. I didn't find what I was looking for, but one thing led to the other and I changed a few settings around and then rebooted back to my Linux partition. I put the machine to sleep and went to bed.

 

I woke up this morning to find that my laptop battery was completely drained.

 

Strange!

 

I connected the power adapter and booted the machine. After logging in, I put it to sleep once more and as I watched, about a minute later it was awake!

 

I won't bore you with the details of everything I did to attempt to fix this, but I just wanted to report that the solution was to disable `Kernel DMA Protection` and re-enable `Thunderbolt Bios Assist Mode` in the bios settings. After doing this, everything was back to normal once again.

 

Just wanted to post here in case anyone finds themselves in this same situation. If you feel bad for having to disable `Kernel DMA Protection` from the BIOS, don't worry because since kernel 4.2.1, it has been implemented into the kernel.

 

HTH

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms