Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

1 Posts

12-12-2020

Germany

3 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎12-12-2020
  • Location: Germany
  • Views: 15
  • Message 1 of 1

P73: games (and other apps) are lagging on external displays!

2020-12-13, 13:11 PM

Hi,

I can't use my external display with my P73, because as soon as I close the lid (the notebook screen, to use only the external display), all the games and apps are "slowing down", start lagging. Feels like a really-really bad FPS drop, for like 5 FPS or less. 

When I use only the notebook screen, everything is working fine as it should. But as soon I use only my external display, it's completely unusable.

For a while everything seems to work perfectly, but after a few minutes everything "slows down", starts to lag. It feels like as something would get "fully loaded", so there is no capacity to keep the FPS, and drops to 5 FPS or less. It doesn't matter if I'm using the lowest quality or the ultra. The issue always happens the same way. I have opened resource manager and task manager to see if maybe CPU or memory or storage problem, but no, everything is working fine, no overload. So it's not a hardware issue. At least not this kind.

But as I read, it's a "well known" issue with hybrid graphic solutions (Intel + Nvidia). But if it's well known, how it's not solved by now?? I had the same issue with all of my other Lenovo P series devices: P53, P52, P51... 

I have tried a lot of things to "fix" it:

  • Disable Fast Startup (read somewhere here about it, that it may fix it.) Did not help.
  • Set Discrete Graphics in BIOS (instead of the default Hybrid Graphics). Did not help.

I have Windows 10 20H2, completely reinstalled, of course the latest driver, firmware, BIOS.

Now the best what I can do is to let the notebook screen open, and with Win+P duplicate or extend the display to my external display. In this way it seems to work so-so.

But it's not OK. It's not professional how this device is "working" (not working). I want to let the display settings in BIOS in Hybrid Graphics, and I don't want any of this lagging, unusable behavior.

Please let me know how can I fix this really annoying issue.

Thank you.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All