English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

0 Posts

01-29-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎01-29-2020
  • Location: US
  • Views: 0
  • Message 1 of 3

Thinkpad P53 Hyper-v network slow using

2020-01-29, 16:36 PM

I just bought a ThinkPad P53. It has an Intel WiFi 6 AX200 wireless network adapter.

 

I am using hyper-v with several virtual machines. When I bind the Hyper-V virtual switch to this wireless network adpater, the wireless performance is TERRIBLE. If I plug in a cable and use the ethernet connection, and bind that to the virtual switch, performance is great!

 

I have used hyper-v on other laptops with a wireless connection without any issues. But on this machine it is useless to try to use the wireless connection. This will not be an issue when I am at my home office. But will be when I travel...which I do quite a bit.

 

I'm considering replacing the wireless card with a different model. 

 

Has anybody else had this issue and what did you do to fix it.

Solved! See the solution
Reply
Options

0 Posts

01-29-2020

US

0 Signins

0 Page Views

  • Posts: 0
  • Registered: ‎01-29-2020
  • Location: US
  • Views: 0
  • Message 2 of 3

Re: Thinkpad P53 Hyper-v network slow using

2020-02-03, 15:18 PM

I have a work around. I was using an external virtual switch, linked to the wireless network adapter, in my Hyper-V configuration. I switched to using a NAT switch, wich is an internal network. This basically shares the wireless connection instead of being linked to it. I don't understand all the internals and technical differences...but it fixes my issue.

 

I have used an external switch on my old laptops without this issue. It must be an issue with the drivers for the wireless card in this machine. But, I now have a working environment and can continue working the way I am used to. 

1 person found this solution to be helpful.

This helped me too

Reply
Options

1 Posts

09-01-2020

US

2 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎09-01-2020
  • Location: US
  • Views: 5
  • Message 3 of 3

Re: Thinkpad P53 Hyper-v network slow using

2020-09-01, 22:19 PM
Thanks for the info. To add to the solution, I was trying to install CentOS 7, and originally added an external switch. It killed everything by creating a bridge. So I followed these instructions to create a NAT network: https://docs.microsoft.com/en-us/virtualization/hyper-v-on-windows/user-guide/setup-nat-network Then I went into CentOS 7 to manually add IP, netmask, and gateway. Now my guest speeds are like my host speeds BTW, I'm on a P1 Gen 2
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete