Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Answer
Options

9 Posts

07-04-2012

Cape Town

11 Signins

57 Page Views

  • Posts: 9
  • Registered: ‎07-04-2012
  • Location: Cape Town
  • Views: 57
  • Message 11 of 25

Re: Unable to access camera on W530

2012-08-12, 4:00 AM

After two wasted days trying to analyse this problem i have solved mine:

 

I got tired of tribal dances around funny drivers/bios/magic. So ripped appart my new toy to confirm that loss of "device manager feedack" was not physical and it was. Simple, no magic, as computers work on I's and O's.

 

Removing the bezel, three screws bottom and clips all around (documents available from lenovo) i confirmed what i thought, the camera cable was part plugged in - allowing installtion of drivers, initial continuity feedback to teh "device manger'. Later, the connection diteriorated and so i had a black screen in skype, no camera option in vantage connectivity etc.

 

W530 has two connections, one at the camera lens (in the bezel) and one to the motherboard. The talk of ribbon integrations is obvious bull. So should you have magical disappearance of "Imaging devices" i strongly suggest you check your hardware or return for check-up under warranty.

 

I am a little disappointed that a 2000 dollar machine is asembled like a cheap blender. This is a Lenovo flagship after all.

 

Kind regards and hope this helps someone out there.

 

Should you need photos, doagrams of disassembly - shout.

 

 

0 person found this solution to be helpful.

This helped me too

Reply
Options

1 Posts

08-15-2012

Edmonton, Alberta, Canada

1 Signins

8 Page Views

  • Posts: 1
  • Registered: ‎08-15-2012
  • Location: Edmonton, Alberta, Canada
  • Views: 8
  • Message 12 of 25

Re: Unable to access camera on W530

2012-08-15, 4:05 AM

My camera worked for a couple weeks when I first received the machine, then it stopped working, and wasn't found anywhere on my system.  I called Lenovo Support and they walked me through a variety of steps including the reloading of the drivers.  In the end, the support line was out of ideas, and sent out a technical support person per my warranty.  Turns out the actual wiring connector to power the webcam, behind the monitor frame, had become disconnected.  He plugged it back in, and "ta da"  webcam was back.  

 

The tech support person suggested that it could be that not enough glue was applied at the manufacturing stage to hold the connection in place, or the wires were "just" long enough, but with opening and closing the monitor over time, that's possibly why it became disconnected.

 

I think the Lenovo manufacturing guru's need to take a closer look at this.  If they have to send a technical support person over to my place everytime this becomes disconnected, it will get mighty expensive, as I know, I will void my warranty if I try to do it myself.  

Reply
Options

5 Posts

03-21-2011

Texas

19 Signins

78 Page Views

  • Posts: 5
  • Registered: ‎03-21-2011
  • Location: Texas
  • Views: 78
  • Message 13 of 25

Re: Unable to access camera on W530

2012-08-20, 17:40 PM
Experiencing the same issue - anyone resolved this?
Reply
Options

16 Posts

06-25-2012

Toronto

50 Signins

317 Page Views

  • Posts: 16
  • Registered: ‎06-25-2012
  • Location: Toronto
  • Views: 317
  • Message 14 of 25

Re: Unable to access camera on W530

2012-09-05, 21:16 PM

The camera on my W530 is enabled in BIOS, but cannot be found in device manager and is not working either. I have installed the latest drivers and communication tools, any clues?

Reply
Options

1 Posts

10-25-2012

Amsterdam

1 Signins

13 Page Views

  • Posts: 1
  • Registered: ‎10-25-2012
  • Location: Amsterdam
  • Views: 13
  • Message 15 of 25

Re: Unable to access camera on W530

2012-10-25, 16:37 PM

I am dealing with the same problem. New lenovo w530, camera worked fine, now it does not. Are there any other solutions besides calling the technical support?

P.S. Seeing as I am from Europe this might be a problem...

Reply
Options

1 Posts

10-30-2012

Atlanta, GA

2 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎10-30-2012
  • Location: Atlanta, GA
  • Views: 10
  • Message 16 of 25

Re: Unable to access camera on W530

2012-10-30, 22:46 PM

I have the same issue.  I took off the LCD bezel and found that the camera was disconnected.  I reconnected the cable at the camer but I am still not getting the camera to work.  As I re-read that thread you mentioned that you had to connect the camera at the motherboard.  Can you provide some more detail or pictures of what you did?  Thanks for you help.

 

William

Reply
Options

1 Posts

12-17-2012

Vancouver

1 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎12-17-2012
  • Location: Vancouver
  • Views: 10
  • Message 17 of 25

Re: Unable to access camera on W530

2012-12-17, 21:51 PM

I am having the same problem camera constantly installs and deletes itself.  Computer is only about 2 months old.   I would like to fix it myself but a bit afraid to open a $2000 machine.   
Can anybody help with info or pics if possible.

 

Thanks in advance

Reply
Options

4 Posts

02-12-2013

Germany

7 Signins

36 Page Views

  • Posts: 4
  • Registered: ‎02-12-2013
  • Location: Germany
  • Views: 36
  • Message 18 of 25

Re: Unable to access camera on W530

2013-02-12, 14:26 PM

I'm having the same problem, it's obviously exactly the same thing. I'm not prepared to risk voiding the warranty, I guess I'll have to waste loads more time with technical support to get them to deal with it. Not very happy - as other posters have commented this is not really what you pay 2000 bucks for. Well done Lenovo.

Reply
Options

1 Posts

02-17-2013

Rochester

1 Signins

6 Page Views

  • Posts: 1
  • Registered: ‎02-17-2013
  • Location: Rochester
  • Views: 6
  • Message 19 of 25

Re: Unable to access camera on W530

2013-02-17, 18:28 PM

On my W530 I don't even see a physical camera.   It does not show up in Device manager either.    was I suspose to have one?  When buying I diddn't even think of looking as I thought in today's world the camera would just be there.   Where is the physical camera suppose to be?

Reply
Options

9 Posts

07-04-2012

Cape Town

11 Signins

57 Page Views

  • Posts: 9
  • Registered: ‎07-04-2012
  • Location: Cape Town
  • Views: 57
  • Message 20 of 25

Re: Unable to access camera on W530

2013-07-12, 13:47 PM

I have not been back for a while.

 

if your camera goes missing from the device list it is the problem I have described. Read my earlier posts. Undo the three screws at the bottom of the screen (under the sticky tabs) and remove the plastic bezel and plug in the camera.  About two months after fixing mine it unplugged again and I had to repeat the process. So if you had a camera and suddenly it disappeared as many report - just do what I described. There is no magic with BIOS and Drivers, it is a crappy plug. The plug is right by the camera lens itself.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms