English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

6 Posts

10-20-2016

NL

10 Signins

90 Page Views

  • Posts: 6
  • Registered: ‎10-20-2016
  • Location: NL
  • Views: 90
  • Message 1 of 10

Use ethernet and wifi simultaneously

2016-10-20, 9:57 AM

I am a robot programmer and frequently have a robot connected to the Ethernet port. However, these robots are no wifi antennas and thus I would like to use wifi at the same time for the internet connection. To consult the internet, check my mail, play music, etc. I have to detach the ethernet cable and wait for wifi to work, before I have to plug it in again to write code for the robot. This is very annoying, as you can imagine.

 

So far I have tried many options, none resulting in a solution that worked.

 

So, in detail:

 

Problem

Wifi disconnects when I connect to a robot controller via ethernet cable. 

 

Tried solutions

  1. Switch on the wifi adapter while an ethernet cable is attached, but it switches off again automatically.
  2. Rearranged the network adapters (network adapters>advanced settings) to let wifi have a higher priority. Still switches off wifi though.
  3. Tried changing the advanced settings of the wifi (network adapters>RMB on wifi>Properties>Advanced), see if there was an option to stop it from switching off when ethernet is attached. There was no option like that.
  4. Accessed the BIOS settings to see if there was a possibility to stop the system from shutting down wifi when a cable is attached.
  5. Bought a USB to Ethernet adapter, but this resulted in wifi switching off as well.
  6. Tried to install Lenovo Access Connections, but it is not available anymore for Windows 10 systems.
  7. Tried Intel Wireless PROSet, but this gave some weird errors while installing it. Although it says it finished the install successfully, there was no Intell Wireless PROSet installed anywhere on the laptop.

 

System settings

  • System: ThinkPad W540 with two adjustments
    • Hard drive bay with SSD instead of CD-bay (which has some flaws as well, but that's for another topic)
    • Physical memory upgraded from 8GB to 16GB
  • OS: Microsoft Windows 10 Home
Solved! See the solution
Reply
Options

2361 Posts

04-20-2008

US

19367 Signins

110151 Page Views

  • Posts: 2361
  • Registered: ‎04-20-2008
  • Location: US
  • Views: 110151
  • Message 2 of 10

Re: Use ethernet and wifi simultaneously

2016-10-20, 12:15 PM

You might try a USB->Ethernet host adapter like this:

 

http://www.newegg.com/Product/Product.aspx?Item=N82E16833114094&nm_mc=KNC-GoogleAdwords-PC&cm_mmc=KNC-GoogleAdwords-PC-_-pla-_-Network+-+Interface+Cards-_-N82E16833114094&gclid=CInAxvmt6c8CFQqpaQodBEUGmw&gclsrc=aw.ds


P53 XEON 2276 BIOS 1.23 OLED UHD 4K Multi-touch display, 96GB RAM, RTX5000, RAID 1, 1TB x 2 Samsung PM981, 1TB PM981, WWAN
P70 XEON 1505, BIOS 2.35, 4k Display, 64GB, M3000M NVIDIA GPU, RAID1 1TB Samsung PM981 PCIe-NVMe SSD x 2, 2x Samsung 850 Pro 1TB SSD. EM7455 WWAN
P1. BIOS 1.25,Xeon Processor, 4k UHD IPS multi-touch display, 32GB, PM981 1TB x 2, RAID1

I am not an employee nor an agent of Lenovo.
Reply
Options

8362 Posts

01-13-2008

US

77313 Signins

2195224 Page Views

  • Posts: 8362
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2195224
  • Message 3 of 10

Re: Use ethernet and wifi simultaneously

2016-10-20, 14:30 PM

There's a post here with a set of suggestions:  http://www.tomshardware.com/answers/id-1747662/wifi-ethernet-time.html#r12744343

 

It boils down to making sure your connections use different subnets, and for both adapters turning off "automatic metric" and setting the  interface metric to "1".

 

Haven't tried it.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

6 Posts

10-20-2016

NL

10 Signins

90 Page Views

  • Posts: 6
  • Registered: ‎10-20-2016
  • Location: NL
  • Views: 90
  • Message 4 of 10

Re: Use ethernet and wifi simultaneously

2016-10-20, 18:51 PM

I got the single ethernet adapter from StarTech. That's the one I bought and tried it with.

Reply
Options

2361 Posts

04-20-2008

US

19367 Signins

110151 Page Views

  • Posts: 2361
  • Registered: ‎04-20-2008
  • Location: US
  • Views: 110151
  • Message 5 of 10

Re: Use ethernet and wifi simultaneously

2016-10-21, 0:18 AM

You need to place the USB->Ethernet adapter on a different subnet. Otherwise, only one network adapter will function.


P53 XEON 2276 BIOS 1.23 OLED UHD 4K Multi-touch display, 96GB RAM, RTX5000, RAID 1, 1TB x 2 Samsung PM981, 1TB PM981, WWAN
P70 XEON 1505, BIOS 2.35, 4k Display, 64GB, M3000M NVIDIA GPU, RAID1 1TB Samsung PM981 PCIe-NVMe SSD x 2, 2x Samsung 850 Pro 1TB SSD. EM7455 WWAN
P1. BIOS 1.25,Xeon Processor, 4k UHD IPS multi-touch display, 32GB, PM981 1TB x 2, RAID1

I am not an employee nor an agent of Lenovo.
Reply
Options

6 Posts

10-20-2016

NL

10 Signins

90 Page Views

  • Posts: 6
  • Registered: ‎10-20-2016
  • Location: NL
  • Views: 90
  • Message 6 of 10

Re: Use ethernet and wifi simultaneously

2016-10-21, 6:56 AM

The subnet levels did not interfere anywhere anyway, but this is what I did anyway:

  • Set a static IP for both adapters:
    • Wifi
    • Ethernet 3 (USB to UTP adapter)
  • Unchecked 'Automatic metric' and set the Interface metric to 1.
    • For both adapters
    • For both their IPv4 and IPv6

 

Wifi static IP

Network center>Change adapter settings>RMB on Wifi>Properties>IPv4>Properties

Automatic IP changed to Static IP

 

IP-address: 172.16.22.194 (ipconfig in CMD stated the router's IP was 172.16.22.193)

Subnet mask: 255.255.252.0

Std gateway: 172.16.22.254

 

Then clicked Advanced and unchecked 'Automatic Metric'. I set the Interface metric to 1, as mentioned in the post. For both IPv4 and IPv6.

 

Wifi static IP

Same thing for the Ethernet 3 (the usb-utp device) adapter.

 

IP-address: 192.168.1.6 (ipconfig in CMD stated the robot's IP was 172.16.22.5. Considering it has multiple UTP ports, probably with static IP, I changed it to 6)

Subnet mask: 255.255.255.0

Std gateway: -

 

Then also hit the Advanced button here and unchecked 'Automatic Metric'. The Interface metric is also set to 1 here. For both IPv4 and IPv6.

 

Result

There was no change at all. Inserting the UTP resulted in an automatic shutdown of the wifi adapter. Restarting the wifi adapter from Network center>Change adapter settings resulted in nothing else than the wifi starting, and shutting down in a matter of seconds.

 

Conclusion

My conclusion is that the wifi adapter is somehow programmed in the bios/Windows 10 to automatically shut down when a cable is attached. However, please tell me if I did something wrong.

Reply
Options

6 Posts

10-20-2016

NL

10 Signins

90 Page Views

  • Posts: 6
  • Registered: ‎10-20-2016
  • Location: NL
  • Views: 90
  • Message 7 of 10

Re: Use ethernet and wifi simultaneously

2016-10-21, 12:10 PM

Update: this work-around hasn't been working from the start. One way or another it does not save the quick setup of network priority (network centre>change adapter settings>[Alt]>advanced>advanced settings), neither does it via changing the metric values (1=highest prio).

For more info, see this post, dating back to August 15, 2015.

Reply
Options

180 Posts

10-26-2008

louisburg, nc

1068 Signins

5099 Page Views

  • Posts: 180
  • Registered: ‎10-26-2008
  • Location: louisburg, nc
  • Views: 5099
  • Message 8 of 10

Re: Use ethernet and wifi simultaneously

2016-10-21, 15:23 PM

If your ip address on your robot is fixed you should be able to plug it into your ethernet switch, or router, and connect without disrupting your wifi. If you have a firewall, ie watchguard,etc, you can set up a separate network for the robots and still connect with the ip address.

Reply
Options

6 Posts

10-20-2016

NL

10 Signins

90 Page Views

  • Posts: 6
  • Registered: ‎10-20-2016
  • Location: NL
  • Views: 90
  • Message 9 of 10

Re: Use ethernet and wifi simultaneously

2016-10-26, 6:47 AM

The robot can be connected to a switch, but that doesn't take away the problem that my wifi will still shut down when I do this. For security reasons we only have wifi available to coworkers, so I can neither surf on the internet via a second ethernet port.

 

I accepted that in Windows 10 Home Edition it is impossible to run wifi and ethernet simultaneously. There is an interface for it, but this is bugged/bricked/whatsoever as you can read in my previous post. I think this thread can thus be closed, until further notice from Microsoft.

 

Thanks to all who tried to help!

0 person found this solution to be helpful.

This helped me too

Reply
Options

1 Posts

04-12-2018

CO

1 Signins

37 Page Views

  • Posts: 1
  • Registered: ‎04-12-2018
  • Location: CO
  • Views: 37
  • Message 10 of 10

Re: Use ethernet and wifi simultaneously

2018-04-12, 13:53 PM

Fixed ... What  I did was download the VLAN driver for my intel ethernet addapter Intel(R) Ethernet Connection (4) I219-LM

Search in google something like Intel(R) Ethernet Connection (4) I219-LM vlan driver.

 

Install the driver and go to ethernet properties > configure > click in advanced tab > settings :

Packet Priority & VLAN  

Value : Packet Priority & VLAN  Disabled 

 

 

mosses.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete