Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

146 Posts

05-09-2008

Germany, Stuttgart

367 Signins

2012 Page Views

  • Posts: 146
  • Registered: ‎05-09-2008
  • Location: Germany, Stuttgart
  • Views: 2012
  • Message 1 of 3

W500 PCMCIA & SmartCard slots issue

2015-03-04, 9:21 AM

Hi all,

 

I need to find a solution to my issue: my W500 originally had just the SmartCard slot (the PCMCIA being blocked / disabled by some mechanical / plastic feature). I need to use the slot so after picking up a PCMCIA & SmartCard slot from a disassembled T61 .. I installed in into my W500.

 

However, Windows seems not to find / recognize any device that I insert into my PCMCIA slot .. but it recognizes SmartCard devices.

BIOS has both ports Enabled.

 

Could it be some blacklisting issue or what? In the old T61, the physical slot worked on both ports (PCMCIA & SmartCard).

 

Any suggestion is welcome ...

W500 / T61p / T61 / R60
Reply
Options

2253 Posts

01-02-2011

United States of America

8347 Signins

51782 Page Views

  • Posts: 2253
  • Registered: ‎01-02-2011
  • Location: United States of America
  • Views: 51782
  • Message 2 of 3

Re: W500 PCMCIA & SmartCard slots issue

2015-03-11, 0:15 AM

I believe the part is the same for the W500 and T61 series, at least the pcmcia/express card part is the same. I've never checked if the smart card assembly is the same across this series but should be easy to do if you compare the part numbers in the hardware manual.

 

Also compare the numbers of the original part with the t61 part. If you feel there is something wrong with the part itself, I have several of these t61 parts. 

 

ps. what was wrong with your original part, can it be repaired so you can try it?

ThinkPad W-510 i7-820QM(1.73-3.06GHz) Quad Core... ThinkPad T500, T9900, 8gb SSD...FrankNpad T-60p/61p (X9000 2.8ghz) 8gb SSD ips FlexView...ThinkPad T-61p (T9300 2.5ghz) 8gb ram...Thinkpad X-61 Tablet 8gb ram.
Reply
Options

146 Posts

05-09-2008

Germany, Stuttgart

367 Signins

2012 Page Views

  • Posts: 146
  • Registered: ‎05-09-2008
  • Location: Germany, Stuttgart
  • Views: 2012
  • Message 3 of 3

Re: W500 PCMCIA & SmartCard slots issue

2015-03-11, 14:30 PM

Hi,

 

and appreciate your feedback :)

 

Situation was / is in this way:

 

- my W500 originally came with a sort of PCMCIA/Smartcard assembly that did not allow access to the PCcard slot (it was mechanically blocked). It's true that I did not check the W500 BIOS to see if the PC Card slot is listed as "Enabled" or even listed at all.

- I had access to a working PCCard / Smartcard assembly from an older T60. I installed that one in the W500 and although in the BIOS I clearly see the port as being enabled .. I tested the slot with 2 PC Cards (one card reader and one card which provides 2 x USB2.0 ports). The Win7 64bit which I had installed didn't "pick up" any new hardware - thus my problem. As I write this I'm tempted to quickly boot a linux distro and perform a "lspci" command to see what's recognized and what not.

 

It is worth mentioning that the PCCard / Smartcard extracted from the T60 was working - I had used the eact same card reader in it ....

 

Regards,

W500 / T61p / T61 / R60
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms