Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

4 Posts

11-18-2010

Belgium

4 Signins

21 Page Views

  • Posts: 4
  • Registered: ‎11-18-2010
  • Location: Belgium
  • Views: 21
  • Message 1 of 9

W510 doesn't boot with Logitech MK320 Keyboard combo transceiver, WIndows 7 64-bit

2010-11-18, 20:53 PM

Hello,


I am having a Lenovo W510 Laptop with a 128 GB SSD. When i leave the usb-transceiver of the MK320 inserted into the keyboard, then my Lenovo W510 doesn't boot.  the W510 is stuck at the Thinkpad boot screen and that is it.

When i remove the usb-transceiver the W510 boot fine.


I have disabled booting straight from the SSD and disabled booting from any USB device in BIOS.

This didn't make a difference.


OS: Win7-64bit Enterprise (updated to latest)

Laptop: Lenovo W510

Memory: 4GB

SSD: 128 GB


Anybody exprienced boot issue using a MK320?

Is there a solution that you can leave the transceiver seated (It is fixed on my Docking station)?


Brgds,


Bas.

Reply
Options

288 Posts

04-20-2010

Ottawa

2936 Signins

4886 Page Views

  • Posts: 288
  • Registered: ‎04-20-2010
  • Location: Ottawa
  • Views: 4886
  • Message 2 of 9

Re: W510 doesn't boot with Logitech MK320 Keyboard combo transceiver, WIndows 7 64-bit

2010-11-18, 23:56 PM

This issue is well known and has always existed on the w510.

 

You cannot boot the computer with devices in the USB3 ports.

 

You need to remove everything every time you boot, and there is no patch, update, driver or fix.

 

Given this problem is almost a year old, many here suspect the problem is hardware, and cannot be serviced.

 

 

Reply
Options

119 Posts

10-13-2010

Regina, SK Canada

207 Signins

1139 Page Views

  • Posts: 119
  • Registered: ‎10-13-2010
  • Location: Regina, SK Canada
  • Views: 1139
  • Message 3 of 9

Re: W510 doesn't boot with Logitech MK320 Keyboard combo transceiver, WIndows 7 64-bit

2010-11-21, 23:22 PM

My new Lenovo has the same problem.  Other laptops don't have this problem.  Of course it can be fixed - it is time that Lenovo does this.  There are three serious defects with the W510 - random freezes, the WWAN causing phantom touches on screen, and the inability to boot with the mouse in one of the side USB ports.  I believe that Lenovo better start looking at some of these issues befoire they get a bad rap and lose customers forever after they are known to not fix hardware issues.

Reply
Options

288 Posts

04-20-2010

Ottawa

2936 Signins

4886 Page Views

  • Posts: 288
  • Registered: ‎04-20-2010
  • Location: Ottawa
  • Views: 4886
  • Message 4 of 9

Re: W510 doesn't boot with Logitech MK320 Keyboard combo transceiver, WIndows 7 64-bit

2010-11-22, 14:16 PM
I'm not convinced it can be fixed. Although I do hope for a BIOS update someday that fixes it. Given how long it has existed, I'm beginning to believe it's a hardware issue on the board that is not field serviceable.
Reply
Options

23 Posts

06-24-2010

Taiwan

2915 Signins

2772 Page Views

  • Posts: 23
  • Registered: ‎06-24-2010
  • Location: Taiwan
  • Views: 2772
  • Message 5 of 9

Re: W510 doesn't boot with Logitech MK320 Keyboard combo transceiver, WIndows 7 64-bit

2010-11-23, 0:54 AM
You can try the new BIOS, it fixed in my W510, boot with the unifying receiver plug to USB3 without any problem now.
Reply
Options

5 Posts

12-04-2010

Melbourne

7 Signins

26 Page Views

  • Posts: 5
  • Registered: ‎12-04-2010
  • Location: Melbourne
  • Views: 26
  • Message 6 of 9

Re: W510 doesn't boot with Logitech MK320 Keyboard combo transceiver, WIndows 7 64-bit

2010-12-04, 14:33 PM

Have exactly the same problem on two W510, got a DOA on it the first time and now the new unit does the same thing.

 

Everything seemed fine but after connecting the Logitech keyboard and mouse several hours later it hangs at the ThinkPad screen. Will try removing the transceiver and see if it makes any difference.

 

As the unit was brand new I would have hoped it had the latest BIOS, can someone please point me where I can find the lastest BIOS.

 

Thanks.

Reply
Options

23 Posts

06-24-2010

Taiwan

2915 Signins

2772 Page Views

  • Posts: 23
  • Registered: ‎06-24-2010
  • Location: Taiwan
  • Views: 2772
  • Message 7 of 9

Re: W510 doesn't boot with Logitech MK320 Keyboard combo transceiver, WIndows 7 64-bit

2010-12-04, 14:52 PM
http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-74858
Reply
Options

5 Posts

12-04-2010

Melbourne

7 Signins

26 Page Views

  • Posts: 5
  • Registered: ‎12-04-2010
  • Location: Melbourne
  • Views: 26
  • Message 8 of 9

Re: W510 doesn't boot with Logitech MK320 Keyboard combo transceiver, WIndows 7 64-bit

2010-12-04, 23:33 PM

I can confirm once you take out the transceiver the unit works fine. Also a brand new machine was shipped out with an OLD BIOS very frustrating will see if the upgarded BIOS solves the problem or the client is just going to have use wired mouse/keyboard.

 

Or does any on know of a more compatable brand of wireless mouse/keyboard?

Reply
Options

288 Posts

04-20-2010

Ottawa

2936 Signins

4886 Page Views

  • Posts: 288
  • Registered: ‎04-20-2010
  • Location: Ottawa
  • Views: 4886
  • Message 9 of 9

Re: W510 doesn't boot with Logitech MK320 Keyboard combo transceiver, WIndows 7 64-bit

2010-12-04, 23:54 PM
It turns out it was field servicable. Get the latest bios and it'll work fine.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms