Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

13 Posts

01-13-2013

United States

26 Signins

264 Page Views

  • Posts: 13
  • Registered: ‎01-13-2013
  • Location: United States
  • Views: 264
  • Message 1 of 15

W520 Ultrabay Speed

2013-01-13, 11:53 AM

I am a student at Neumont University; at Neumont we are required to get the same laptop (W520, because neumont can perform warranty repairs). Many students are looking to the ultrabay adaptors to be used with a second hard drive. 

We have found that all of our hard drives (SSD and Plater) are bottlenecked at 80MB/s. What confirms the bottlenecking is that both read and writing speeds are the same (80MB/s). We all have different hard drives, some SATA 3.0, some 2.0, we have tested this on Windows 7-8 and Linux,  but we all have this problem. 

Intel rapid storage is installed on all test computers. It reports the drives are as they are. 

I myself have have tested 2 SATA 2.0 hard drives (5400 and 7200 RPM) with no difference. I have used Crystal diskmark and HD Tune. I have found that when I hook these drives up with USB 3.0 and I get over 100MB/s. I think I can safely assume that this is something with the caddy drive, or its interface. 

The specs for our computer’s board say that the two internal SATA connections are SATA 3.0 (6Gb/s). The drive is connected to port 1 (1, 0 support SATA 3.0).

The only user problem that I can find with the setup is that we did not buy lenovo’s stock HD caddy, but from different third parties. However, all of the third parties report that it is just a pass through connection. They report that the connection should be upto SATA 3.0. 

We want to know, how this is possible, why are our speeds so slow, and is there a way to fix it.

Reply
Answer
Options

2483 Posts

04-08-2011

United States of America

5471 Signins

46460 Page Views

  • Posts: 2483
  • Registered: ‎04-08-2011
  • Location: United States of America
  • Views: 46460

Re: W520 Ultrabay Speed

2013-01-14, 3:59 AM

I don't care much for Crystal.  AS SSD is ok.  I actually prefer ATTO Disk Benchmark.

 

I would suggest putting your fastest SSD in the ultrabay and trying ATTO.

 

I'll run some tests tomorrow and report back.

 

Other than Windows, what other software did you install?  Are you running Intel Rapid Start or any other caching programs?  What are you using for anti virus? 

 

 

 

 

Reply

Replies(14)
Options

2483 Posts

04-08-2011

United States of America

5471 Signins

46460 Page Views

  • Posts: 2483
  • Registered: ‎04-08-2011
  • Location: United States of America
  • Views: 46460
  • Message 2 of 15

Re: W520 Ultrabay Speed

2013-01-13, 17:38 PM

wrote:

The only user problem that I can find with the setup is that we did not buy lenovo’s stock HD caddy, but from different third parties. However, all of the third parties report that it is just a pass through connection. They report that the connection should be upto SATA 3.0. 

We want to know, how this is possible, why are our speeds so slow, and is there a way to fix it.


The logical next step is to purchase the Lenovo branded Ultrabay HDD/SSD adapter and test with it.

 

What third party adapter(s) are you using?

Reply
Options

13 Posts

01-13-2013

United States

26 Signins

264 Page Views

  • Posts: 13
  • Registered: ‎01-13-2013
  • Location: United States
  • Views: 264
  • Message 3 of 15

Re: W520 Ultrabay Speed

2013-01-13, 21:40 PM

wrote:
The logical next step is to purchase the Lenovo branded Ultrabay HDD/SSD adapter and test with it.

 



I know of two brands that we are using, one that just says its from china, and one from newmodeus.com. 

 

Both companies have reported just a pass through connection; so in theory it should be no different than a stock Lenovo one, right?

 


wrote:

 

The logical next step is to purchase the Lenovo branded Ultrabay HDD/SSD adapter and test with it.


I am trying, however Lenovo products are not cheap (I need a refund from newmodeus to afford it).

Reply
Options

2377 Posts

04-20-2008

United States of America

19595 Signins

111306 Page Views

  • Posts: 2377
  • Registered: ‎04-20-2008
  • Location: United States of America
  • Views: 111306
  • Message 4 of 15

Re: W520 Ultrabay Speed

2013-01-13, 23:07 PM

I have SATA-3 speed in both the primary and UltraBay positions on both of my W520s. I'm also using the Newmodeus HDD caddy for both systems. Are the chipset drivers correct for your system? Which OS are you running?


P53 XEON 2276 BIOS 1.31 OLED UHD 4K Multi-touch display, 96GB RAM, RTX5000, RAID 1, 1TB x 2 Samsung PM981, 1TB PM981, WWAN
P70 XEON 1505, BIOS 2.35, 4k Display, 64GB, M3000M NVIDIA GPU, RAID1 1TB Samsung PM981 PCIe-NVMe SSD x 2, 2x Samsung 850 Pro 1TB SSD. EM7455 WWAN
P1. BIOS 1.36,Xeon Processor, 4k UHD IPS multi-touch display, 32GB, PM981 1TB x 2, RAID1

I am not an employee nor an agent of Lenovo.
Reply
Options

2483 Posts

04-08-2011

United States of America

5471 Signins

46460 Page Views

  • Posts: 2483
  • Registered: ‎04-08-2011
  • Location: United States of America
  • Views: 46460
  • Message 5 of 15

Re: W520 Ultrabay Speed

2013-01-14, 3:13 AM

How exactly are you testing the speed?

 

As harrisb inquired, do you have the Intel chipset drivers downloaded and installed from support.lenovo.com?  Did you also install the USB 3.0 drivers?

Reply
Options

13 Posts

01-13-2013

United States

26 Signins

264 Page Views

  • Posts: 13
  • Registered: ‎01-13-2013
  • Location: United States
  • Views: 264
  • Message 6 of 15

Re: W520 Ultrabay Speed

2013-01-14, 3:34 AM

I just spent the day looking for the latest drivers for my computer, I found several that where out dated. I also updated the bios. However, none (that I can see) would affect my hard drive. I re-ran by bechmarks, and they were the same (If not slower).

 

@harrisb>: So I believe now my drivers are uptodate, thanks for the sugestion. I am running Windows 8.

 

@ThorsHammer: I am benchmarking with Crystal Disk and AS SSD Benchmark. Both are giving me around the same numbers: 80MB/s for both read and write (SEQ). USB 3.0 drivers are installed (Windows 8 has native support as well, I believe).

 

Here is a shot of Crystal Disk:

 

Sequential Read : 73.378 MB/s
Sequential Write : 72.146 MB/s
Random Read 512KB : 23.514 MB/s
Random Write 512KB : 39.414 MB/s
Random Read 4KB (QD=1) : 0.280 MB/s [ 68.5 IOPS]
Random Write 4KB (QD=1) : 0.740 MB/s [ 180.6 IOPS]
Random Read 4KB (QD=32) : 0.439 MB/s [ 107.2 IOPS]
Random Write 4KB (QD=32) : 0.848 MB/s [ 207.0 IOPS]

Test : 500 MB [H: 52.7% (157.0/298.0 GB)] (x5)
Date : 2013/01/13 20:27:03
OS : Windows 8 [6.2 Build 9200] (x64)

  

Thanks.

Reply
Answer
Options

2483 Posts

04-08-2011

United States of America

5471 Signins

46460 Page Views

  • Posts: 2483
  • Registered: ‎04-08-2011
  • Location: United States of America
  • Views: 46460
  • Message 7 of 15

Re: W520 Ultrabay Speed

2013-01-14, 3:59 AM

I don't care much for Crystal.  AS SSD is ok.  I actually prefer ATTO Disk Benchmark.

 

I would suggest putting your fastest SSD in the ultrabay and trying ATTO.

 

I'll run some tests tomorrow and report back.

 

Other than Windows, what other software did you install?  Are you running Intel Rapid Start or any other caching programs?  What are you using for anti virus? 

 

 

 

 

0 person found this solution to be helpful.

This helped me too

Reply
Options

13 Posts

01-13-2013

United States

26 Signins

264 Page Views

  • Posts: 13
  • Registered: ‎01-13-2013
  • Location: United States
  • Views: 264
  • Message 8 of 15

Re: W520 Ultrabay Speed

2013-01-14, 4:16 AM

@ThorsHammer: Thanks, I will try switching drives, and benchmarking with ATTO Disk Benchmark.

 

I cannot think of any software that I am running that would be accessing the drive. My anti Virus (ESET) is disabled on all drives that are not the local C:. I do have Intel Rapid Storage, though.

Reply
Options

13 Posts

01-13-2013

United States

26 Signins

264 Page Views

  • Posts: 13
  • Registered: ‎01-13-2013
  • Location: United States
  • Views: 264
  • Message 9 of 15

Re: W520 Ultrabay Speed

2013-01-14, 4:29 AM

Here are the new benchmarks: 

 

 

 

Reply
Options

2483 Posts

04-08-2011

United States of America

5471 Signins

46460 Page Views

  • Posts: 2483
  • Registered: ‎04-08-2011
  • Location: United States of America
  • Views: 46460
  • Message 10 of 15

Re: W520 Ultrabay Speed

2013-01-14, 6:43 AM

What drive is that?  Here's a Intel Series 510 120GB SSD in a ThinkPad W520 Ultrabay.  And this isn't a particularly good result.

 

w520 ultrabay 120gb series 510.PNG

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms