Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

525 Posts

03-11-2009

Chicago, IL

300 Signins

14180 Page Views

  • Posts: 525
  • Registered: ‎03-11-2009
  • Location: Chicago, IL
  • Views: 14180
  • Message 21 of 33

Re: W520 Video Driver Support

2013-03-02, 16:45 PM

You will need to use driver sweeper to cleanup from the NVidia update delivered via Windows update.

Reply
Options

572 Posts

02-13-2008

United States of America

2819 Signins

15228 Page Views

  • Posts: 572
  • Registered: ‎02-13-2008
  • Location: United States of America
  • Views: 15228
  • Message 22 of 33

Re: W520 Video Driver Support

2013-03-02, 17:00 PM
Two (I used to have Five) - T61p 15.4" WS T9300 2.5Ghz units, August 08/08 Builds with FX570M Nvidia Graphics; ... One W520 i7-2860QM w/2000M Nvidia Graphics (most recent acquisition and stupidly fast); .... One - T42 4:3 15" Flexview 1.8GHz with ATI Graphics (still perfect for traveling); ... Two - T500 15.4" units both with ATI HD3650 Graphics.
Reply
Options

572 Posts

02-13-2008

United States of America

2819 Signins

15228 Page Views

  • Posts: 572
  • Registered: ‎02-13-2008
  • Location: United States of America
  • Views: 15228
  • Message 23 of 33

Re: W520 Video Driver Support

2013-03-02, 17:02 PM

wrote:

 

 The drivers have issues both in Optimus mode and using Discrete mode on the W520 and nearly all the versions I have tried since around the 296, 304, 305 days have had one issue or other –

 

Christopher

 

 


 

Disable Optimus mode and disable Switchable Graphics for trouble free performance ..... less fancy stuff is faster and better.  My W520 is trouble free and very fast w/o Optimus and using only the discrete Nvidia 2000M.

_________________________________

 

Two (I used to have Five) - T61p 15.4" WS T9300 2.5Ghz units, August 08/08 Builds with FX570M Nvidia Graphics; ... One W520 i7-2860QM w/2000M Nvidia Graphics (most recent acquisition and stupidly fast); .... One - T42 4:3 15" Flexview 1.8GHz with ATI Graphics (still perfect for traveling); ... Two - T500 15.4" units both with ATI HD3650 Graphics.
Reply
Options

525 Posts

03-11-2009

Chicago, IL

300 Signins

14180 Page Views

  • Posts: 525
  • Registered: ‎03-11-2009
  • Location: Chicago, IL
  • Views: 14180
  • Message 24 of 33

Re: W520 Video Driver Support

2013-03-02, 17:09 PM

What version of drivers are trouble free for you when using discrete mode? (and it was using discrete mode I wrote about btw in addition to mentioning issues when using Optimus)

Reply
Options

572 Posts

02-13-2008

United States of America

2819 Signins

15228 Page Views

  • Posts: 572
  • Registered: ‎02-13-2008
  • Location: United States of America
  • Views: 15228
  • Message 25 of 33

Re: W520 Video Driver Support

2013-03-02, 18:36 PM

Completely remove any Nvidia "website" drivers you many have installed and go back to to the official Lenovo issued Win7 64-bit driver 8.17.12.7658 issued back on 2012/04/19: 

 

http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/83de48ww.txt

 

Keep it simple .... newer is not always better!

___________________________

Two (I used to have Five) - T61p 15.4" WS T9300 2.5Ghz units, August 08/08 Builds with FX570M Nvidia Graphics; ... One W520 i7-2860QM w/2000M Nvidia Graphics (most recent acquisition and stupidly fast); .... One - T42 4:3 15" Flexview 1.8GHz with ATI Graphics (still perfect for traveling); ... Two - T500 15.4" units both with ATI HD3650 Graphics.
Reply
Options

525 Posts

03-11-2009

Chicago, IL

300 Signins

14180 Page Views

  • Posts: 525
  • Registered: ‎03-11-2009
  • Location: Chicago, IL
  • Views: 14180
  • Message 26 of 33

Re: W520 Video Driver Support

2013-03-02, 18:40 PM

Heh heh lol yeah..276.58. I want to get things fixed though and I can't use a set that old anyway (no 3d over displayport in driver sets that old). Just an fyi the 296 versions (from the 295 Release) were not to bad in Optimus mode. The version Lenovo had prior to putting out 311.00 was a 296.nn version I believe.

Reply
Options

572 Posts

02-13-2008

United States of America

2819 Signins

15228 Page Views

  • Posts: 572
  • Registered: ‎02-13-2008
  • Location: United States of America
  • Views: 15228
  • Message 27 of 33

Re: W520 Video Driver Support

2013-03-02, 18:56 PM

Then go back to the Lenovo 296.00 .... Lenovo's 311.00 has bugs FWIW (see page one of this Thread).

 

And dump the Optimus mode if you want to solve your problems.

________________________________

Two (I used to have Five) - T61p 15.4" WS T9300 2.5Ghz units, August 08/08 Builds with FX570M Nvidia Graphics; ... One W520 i7-2860QM w/2000M Nvidia Graphics (most recent acquisition and stupidly fast); .... One - T42 4:3 15" Flexview 1.8GHz with ATI Graphics (still perfect for traveling); ... Two - T500 15.4" units both with ATI HD3650 Graphics.
Reply
Options

525 Posts

03-11-2009

Chicago, IL

300 Signins

14180 Page Views

  • Posts: 525
  • Registered: ‎03-11-2009
  • Location: Chicago, IL
  • Views: 14180
  • Message 28 of 33

Re: W520 Video Driver Support

2013-03-02, 19:27 PM

I've never found downgrading to be much of a solution to anything and if I recall correctly the 296.nn drivers worked ok for me in Optimus mode but not discrete, exactly the opposite of your advice/experience. Both Optimus and Discrete mode each have issues in nearly all of the driver sets I have tried, whether they be Nvidia provided or Lenovo provided. Discrete mode only is no solution or fixall either. I will stick to working with Nvidia on this one and using 311.00 and 314.07 as baselines. Thanks anyway for the advice.

Also the 311.00 ones Lenovo just put out do seem to work ok using Optimus. My issues with this iteration of drivers are when using discrete mode.

 

 

Reply
Options

572 Posts

02-13-2008

United States of America

2819 Signins

15228 Page Views

  • Posts: 572
  • Registered: ‎02-13-2008
  • Location: United States of America
  • Views: 15228
  • Message 29 of 33

Re: W520 Video Driver Support

2013-03-02, 19:33 PM

By chance do you know where Lenovo hides the download links of their previous official drivers? I can't seem to find a link at Lenovo.  Thanks!

______________________________

Two (I used to have Five) - T61p 15.4" WS T9300 2.5Ghz units, August 08/08 Builds with FX570M Nvidia Graphics; ... One W520 i7-2860QM w/2000M Nvidia Graphics (most recent acquisition and stupidly fast); .... One - T42 4:3 15" Flexview 1.8GHz with ATI Graphics (still perfect for traveling); ... Two - T500 15.4" units both with ATI HD3650 Graphics.
Reply
Options

525 Posts

03-11-2009

Chicago, IL

300 Signins

14180 Page Views

  • Posts: 525
  • Registered: ‎03-11-2009
  • Location: Chicago, IL
  • Views: 14180
  • Message 30 of 33

Re: W520 Video Driver Support

2013-03-02, 19:42 PM

No sorry. When ftp access to the pcbbs directory went away (I guess when Lenovo took it from IBM) seems like access to older drivers etc. is no longer available. There were some other web site changes and there was transition doc out there that discussed the changes and how to find stuff/convert links but you will have to search for these and not sure if this will help anyway.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms