Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

7 Posts

05-03-2012

Germany

14 Signins

70 Page Views

  • Posts: 7
  • Registered: ‎05-03-2012
  • Location: Germany
  • Views: 70
  • Message 1 of 9

W520 webcam not working

2012-05-03, 16:53 PM

Hi everyone,

 

i recently bought my W520 and everything works just fine - except for the internal webcam.

 

I installed the drivers (current version) from the Lenovo web site but the webcam won't turn on. The green just wouldn't turn on and when I press Fn+F6 the communication tool shows up without any webcam video. Same thing for skype or any other webcam tool.

 

Sometimes after booting it works for a few seconds but then the image freezes and it won't start again until after several system restarts.

 

As indicated on google I installed the generic Microsoft driver but that does not seem to solve the problem.

 

Does anyone know what to do? Your help is much appreciated!

 

Regards, Phil

 

System Details:

Thinkpad W520 (4276), Core i7-2760QM

Windows 7 64 Bit Professional

Reply
Answer
Options

7 Posts

05-03-2012

Germany

14 Signins

70 Page Views

  • Posts: 7
  • Registered: ‎05-03-2012
  • Location: Germany
  • Views: 70

Re: W520 webcam not working

2012-05-08, 10:28 AM

I tried ubuntu live and the webcam didn't work either.

 

Today I had a remote assistance session with the Lenovo support and they confirmed a hardware fault. Until this morning I was still hoping it was a software error but now I have to get the webcam replaced :( Thank you for all your replies anyway.

 

Regards, Phil

Reply

Replies(8)
Options

958 Posts

01-05-2010

INDIA

981 Signins

6198 Page Views

  • Posts: 958
  • Registered: ‎01-05-2010
  • Location: INDIA
  • Views: 6198
  • Message 2 of 9

Re: W520 webcam not working

2012-05-05, 19:20 PM

Hello ph-klein and welcome to community,

 

Kindly uninstall the installed camera driver and software then restart the laptop, update the BIOS

BIOS Update Bootable CD

README for BIOS Update Bootable CD

 

"OR"

Windows BIOS Update Utility

 

 

 

Then install ThinkVantage Communications Utility and after this install Integrated Camera Driver

 

 

Best Regards,

Tanuj


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Options

7 Posts

05-03-2012

Germany

14 Signins

70 Page Views

  • Posts: 7
  • Registered: ‎05-03-2012
  • Location: Germany
  • Views: 70
  • Message 3 of 9

Re: W520 webcam not working

2012-05-07, 8:51 AM

Tanuj,

 

thank you for the welcome and your reply. I tried to update the BIOS but the Windows tool told me that no update was required. I checked the BIOS screen, installed version is 8BET56WW (1.36) which is the current version on the Lenovo web site. 

 

Attached you find a photo taken during one of the short moments the webcam is actually working. I'm pretty much concerned about the color errors. Might this be a hardware fault?

 

Best regards,

Phil

 

WebcamFault.jpeg

Reply
Options

958 Posts

01-05-2010

INDIA

981 Signins

6198 Page Views

  • Posts: 958
  • Registered: ‎01-05-2010
  • Location: INDIA
  • Views: 6198
  • Message 4 of 9

Re: W520 webcam not working

2012-05-07, 15:05 PM

Hi Phill,

 

Can you reinstall the Windows and check else if the laptop is in warranty then you need to contact the support center.

 

 

Best Regards,

Tanuj


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Reply
Options

9644 Posts

12-27-2009

Canada

3314 Signins

95288 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95288
  • Message 5 of 9

Re: W520 webcam not working

2012-05-07, 20:19 PM
I'd try a bootable Ubuntu CD. If it has drivers for the webcam, then you can confirm whether or not it's a hardware issue.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Answer
Options

7 Posts

05-03-2012

Germany

14 Signins

70 Page Views

  • Posts: 7
  • Registered: ‎05-03-2012
  • Location: Germany
  • Views: 70
  • Message 6 of 9

Re: W520 webcam not working

2012-05-08, 10:28 AM

I tried ubuntu live and the webcam didn't work either.

 

Today I had a remote assistance session with the Lenovo support and they confirmed a hardware fault. Until this morning I was still hoping it was a software error but now I have to get the webcam replaced :( Thank you for all your replies anyway.

 

Regards, Phil

0 person found this solution to be helpful.

This helped me too

Reply
Options

1 Posts

01-31-2013

United States

1 Signins

3 Page Views

  • Posts: 1
  • Registered: ‎01-31-2013
  • Location: United States
  • Views: 3
  • Message 7 of 9

Re: W520 webcam not working

2013-01-31, 6:44 AM

I have tried all of these steps and my computer still refuses to recognize the webcam. 

Reply
Options

2 Posts

11-14-2014

United States of America

2 Signins

21 Page Views

  • Posts: 2
  • Registered: ‎11-14-2014
  • Location: United States of America
  • Views: 21
  • Message 8 of 9

Re: W520 webcam not working

2014-11-14, 3:44 AM

I had similar issue on my w520, the webcam just showed a black screen. After hours of trying to uninstall and reinstall the driver and running diagnostics - which all said that webcam is fine I was about to give up when I stumbled upon this thread: https://forums.lenovo.com/t5/T400-T500-and-newer-T-series/Thinkpad-T530-Integrated-Camera-not-working/td-p/1189275

 

Looks like there is wiring problem on how the web cam is connected. I used the instructions here: http://support.lenovo.com/us/en/documents/migr-76969 to open the lcd panel, adjusted the webcam wire and voila :) Working fine now

Reply
Options

7 Posts

05-03-2012

Germany

14 Signins

70 Page Views

  • Posts: 7
  • Registered: ‎05-03-2012
  • Location: Germany
  • Views: 70
  • Message 9 of 9

Re: W520 webcam not working

2014-11-14, 7:17 AM

That confirms my suspicions. After spending quite a while explaining to the Lenovo support what's wrong they supposed I send in my machine to get it fixed. Since I need it for work (and I have my private MacBook with a perfectly fine webcam) I refused to do so and for the time being I don't use the internal webcam. Maybe I will give opening the display assembly a try once the warranty period is over. Thanks anyway for posting this tip!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms