Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

2 Posts

02-29-2020

South Africa

4 Signins

20 Page Views

  • Posts: 2
  • Registered: ‎02-29-2020
  • Location: South Africa
  • Views: 20
  • Message 1 of 3

W530 display drivers fail to load | system defaults to basic Windows driver

2020-02-29, 13:05 PM

PROBLEM: My Lenovo display driver failed to fire up and so my notebook reverted to using the Microsoft basic display driver instead. My suspicion is that the NVIDIA Quadro K100M display driver from Intel isn't compatible with the latest version of Windows 10 (see below) which I'm unable to undo as I've passed the 10-day/30-day/60-day window period for reverting to an earlier version of Windows 10. The consequence is that default Windows driver doesn't enable me to adjust the screen brightness, (Fn keys are totally unresponsive and the slider meant to display in the bottom right ~~ window display, was originally greyed out and is now completely missing).

 

 

I'm at my wits end and my eyes are screwed from the intensity of my screen (so this is being pecked out on my phone). Can anyone please help? 

 

SYSTEM: Lenovo W530 | Microsoft Windows 10 Pro (64-bit), Version (Build): 1909 (10.0.18363) | Graphics: NVIDIA Quadro K100M h & Video Controller (VGA Compatible)

Reply
Answer
Options

4073 Posts

12-02-2007

United States of America

9110 Signins

194828 Page Views

  • Posts: 4073
  • Registered: ‎12-02-2007
  • Location: United States of America
  • Views: 194828

Re:W530 display drivers fail to load | system defaults to basic Windows driver

2020-03-02, 8:47 AM

Hello,

 


According to Nvidia's support site, the latest device drivers for the Quadro K1000M are release 418, which can be downloaded from https://www.nvidia.com/Download/driverResults.aspx/157253/en-us.  Perhaps these will work with your ThinkPad W530.

 

Regards,

 

Aryeh Goretsky

 



I am a volunteer and neither a Lenovo nor a Microsoft employee.

L380 YogaP72 (20MB-*)P50 (20EN-*)S230u (3347-4HU)T23 (2648-LU7)T42 (2378-R4U)T43p (2678-H7U)T61p (6459-CTO)W510 (4318-CTO)W530 (2441-4R3)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)X220 (4286-CTO)X250 (20CM-*)Yoga 370

  Communities:   English    Deutsche    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Język Polski    Moto English


Need an answer, fast? Try using Browser Search to find it in the Lenovo and Moto Community
Reply

Replies(2)
Answer
Options

4073 Posts

12-02-2007

United States of America

9110 Signins

194828 Page Views

  • Posts: 4073
  • Registered: ‎12-02-2007
  • Location: United States of America
  • Views: 194828
  • Message 2 of 3

Re:W530 display drivers fail to load | system defaults to basic Windows driver

2020-03-02, 8:47 AM

Hello,

 


According to Nvidia's support site, the latest device drivers for the Quadro K1000M are release 418, which can be downloaded from https://www.nvidia.com/Download/driverResults.aspx/157253/en-us.  Perhaps these will work with your ThinkPad W530.

 

Regards,

 

Aryeh Goretsky

 



I am a volunteer and neither a Lenovo nor a Microsoft employee.

L380 YogaP72 (20MB-*)P50 (20EN-*)S230u (3347-4HU)T23 (2648-LU7)T42 (2378-R4U)T43p (2678-H7U)T61p (6459-CTO)W510 (4318-CTO)W530 (2441-4R3)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)X220 (4286-CTO)X250 (20CM-*)Yoga 370

  Communities:   English    Deutsche    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Język Polski    Moto English


Need an answer, fast? Try using Browser Search to find it in the Lenovo and Moto Community

0 person found this solution to be helpful.

This helped me too

Reply
Options

2 Posts

02-29-2020

South Africa

4 Signins

20 Page Views

  • Posts: 2
  • Registered: ‎02-29-2020
  • Location: South Africa
  • Views: 20
  • Message 3 of 3

Re:W530 display drivers fail to load | system defaults to basic Windows driver

2020-03-31, 13:01 PM

The problem - eventually discovered by the team at Swdtech in Swellendam, South Africa -  turned out to be a conflict between the default W10 local user account and some or other software, which the team solved by creating a second user, which became the default account. Since then everything works.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All