Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit our eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

3 Posts

01-23-2014

3 Signins

32 Page Views

  • Posts: 3
  • Registered: ‎01-23-2014
  • Location:
  • Views: 32
  • Message 1 of 5

W530 - unknown device after installing windows 8.1

2014-01-23, 19:33 PM

Hi,

 

W530

Product: 244752U

BIOS: G5ET95WW (2.55 )

Windows 8.1 - Installed from scratch. 

 

I was able to install and configure all drivers but one. I found a tread that suggested installing Lenovo Setting Dependency Package 2.0.0.13 to fix it on a different lenovo model. I tried it without any success. 

 

The driver id of unknown driver is "{48126E0D-4BDD-4D26-8A24-569C7AB522D6}\SettingsDriver"

 

Google did not help.

 

Any help is appreciated. 

 

Eduardo

 

 

 

 

Solved! See the solution
Reply
Options

962 Posts

11-05-2009

United States of America

1291 Signins

17542 Page Views

  • Posts: 962
  • Registered: ‎11-05-2009
  • Location: United States of America
  • Views: 17542
  • Message 2 of 5

Re: W530 - unknown device after installing windows 8.1

2014-01-23, 21:11 PM

Right click it, click uninstall, then scan for hardware changes. I've had a couple of issue where that fixed it.

 


Just a volunteer. Please post your questions in the forum, as I will not reply if they are sent in a personal message.

Yoga 14(20FY): i5-6200U, HD 520 + 940M, 8GB RAM, 256GB SSD, Ubuntu 18.04
Yoga Home 900(27ibu): i7-5500, HD5500 + 940A, 8GB RAM, 500GB HDD, Windows Insider Fast
X1 Tablet (20GH): m7-6Y75, 16GB RAM , 256GB NVMe , Intel® HD Graphics 515
Legion Y530(15ICH): i7-8750H, 32GB RAM, 512GB NVMe + 500GB SSD, UHD 630 + 1050Ti

0 person found this solution to be helpful.

This helped me too

Reply
Options

3 Posts

01-23-2014

3 Signins

32 Page Views

  • Posts: 3
  • Registered: ‎01-23-2014
  • Location:
  • Views: 32
  • Message 3 of 5

Re: W530 - unknown device after installing windows 8.1

2014-01-23, 23:37 PM

Bingo! :smileyvery-happy:

 

"Scan for new hardware" never found the driver again so I guess it wasn't supposed to be there

Reply
Options

962 Posts

11-05-2009

United States of America

1291 Signins

17542 Page Views

  • Posts: 962
  • Registered: ‎11-05-2009
  • Location: United States of America
  • Views: 17542
  • Message 4 of 5

Re: W530 - unknown device after installing windows 8.1

2014-01-24, 16:07 PM

yeah, ive noticed that happens to me sometimes. I keep getting a system/root/0006 device. goes away after uninstall and scan.


Just a volunteer. Please post your questions in the forum, as I will not reply if they are sent in a personal message.

Yoga 14(20FY): i5-6200U, HD 520 + 940M, 8GB RAM, 256GB SSD, Ubuntu 18.04
Yoga Home 900(27ibu): i7-5500, HD5500 + 940A, 8GB RAM, 500GB HDD, Windows Insider Fast
X1 Tablet (20GH): m7-6Y75, 16GB RAM , 256GB NVMe , Intel® HD Graphics 515
Legion Y530(15ICH): i7-8750H, 32GB RAM, 512GB NVMe + 500GB SSD, UHD 630 + 1050Ti
Reply
Options

2 Posts

03-02-2017

United States of America

1 Signins

14 Page Views

  • Posts: 2
  • Registered: ‎03-02-2017
  • Location: United States of America
  • Views: 14
  • Message 5 of 5

Re: W530 - unknown device after installing windows 8.1

2017-03-02, 2:54 AM

 

https://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/g1hd55ww.exe

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms