English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

7 Posts

02-20-2014

Stavanger - Norway

10 Signins

86 Page Views

  • Posts: 7
  • Registered: ‎02-20-2014
  • Location: Stavanger - Norway
  • Views: 86
  • Message 1 of 13

W540 - displays are flickering off and on randomly

2014-02-20, 10:58 AM

I just got me a W540 with docking. It is connected with two Samsung 24inc screens. They are connected with two display ports kables from the docking. I also have a wireless logitech mouse and keybord. And a Jabra headset connected.

I have reinstalled it with windows 8.1 And now I have a serious issue that both screens turns off randomly while I work. They go black for 15 sec. And then re-appear. It seems like the computer looses all USB connection also while this happens. I sometime get an error msg. saying that I connected a USB device that cant be recognized. But most of the time nothing happens.

All 3 of us at work who has a W540 has this issue. So it must be known by Lenovo. I have an ongoing case with the support. But dosnt look like we are getting anywhere. They gave me this to try: https://forums.lenovo.com/t5/T400-T500-and-newer-T-series/T540p-T440p-T440s-X240-Solution-for-flickering-blanking-symptoms/ta-p/1437065

And it looked very much like my issue. But it didnt help any of us.

 

We think it could be a driver issue with the USB or that the computer is swiching between the Intel and the Nvidia gfx card.

I think I have tried about everything, but can not figgure this one out. I have all the latest drivers from Lenovo installed. Tried to use a wired mouse and keyb. no change, tried with a DVI and Displayport to the screen. No change.

 

Here is a link to Lenovos System report on my W540

https://dl.dropboxusercontent.com/u/38244204/Fullreport.html

 

Can someone please help me figure this one out?

Solved! See the solution
Best regards

Joar Guttormsen
Reply
Options

7 Posts

02-20-2014

Stavanger - Norway

10 Signins

86 Page Views

  • Posts: 7
  • Registered: ‎02-20-2014
  • Location: Stavanger - Norway
  • Views: 86
  • Message 2 of 13

Re: W540 - displays are flickering off and on randomly

2014-02-20, 14:37 PM

Have taken the laptop out of the docking. Connected one of the monitors to the laptop with a VGA cable direcly. And useing the screen on the laptop as a secound screen. It is a terrible setup. Connected the LAN cable, and wireless mouse and keyb. No flickering of the screens now. Does that show me that there is something wrong with the docking?

Best regards

Joar Guttormsen
Reply
Options

56 Posts

12-25-2013

Germany

209 Signins

1027 Page Views

  • Posts: 56
  • Registered: ‎12-25-2013
  • Location: Germany
  • Views: 1027
  • Message 3 of 13

Re: W540 - displays are flickering off and on randomly

2014-02-20, 16:35 PM
Did you update the dock's firmware correctly? Powered the dock off afterwards, etc? I had the same problem, flashing the firmware solved it.
Reply
Options

7 Posts

02-20-2014

Stavanger - Norway

10 Signins

86 Page Views

  • Posts: 7
  • Registered: ‎02-20-2014
  • Location: Stavanger - Norway
  • Views: 86
  • Message 4 of 13

Re: W540 - displays are flickering off and on randomly

2014-02-21, 6:57 AM

Yes I did. I was very carefull to do it correct. But did not help. And if I try to update it now, it says I have the latest firmware. My colleges tried to update the firmware too. Did not help them either.

Best regards

Joar Guttormsen
Reply
Options

3 Posts

02-21-2014

Melbourne

5 Signins

59 Page Views

  • Posts: 3
  • Registered: ‎02-21-2014
  • Location: Melbourne
  • Views: 59
  • Message 5 of 13

Re: W540 - displays are flickering off and on randomly

2014-02-21, 8:19 AM

I run multiple monitors including Samsung 24 inch, Wacom Cintiq, Wacom tablet and multiple mice at any time when connected to either of my two docking stations. I have had exactly the same problem when using the 135w power supply. However, the problems disappear with the 170W power supply

0 person found this solution to be helpful.

This helped me too

Reply
Options

7 Posts

02-20-2014

Stavanger - Norway

10 Signins

86 Page Views

  • Posts: 7
  • Registered: ‎02-20-2014
  • Location: Stavanger - Norway
  • Views: 86
  • Message 6 of 13

Re: W540 - displays are flickering off and on randomly

2014-02-21, 8:31 AM

VERY interesting, have now changed powersupply. And testing as we speak.

What are lenovo thinking? Sending a low powered supply with the docking and a high powered supply with the computer? Should have been the oposite. Thanks for your tip!

Best regards

Joar Guttormsen
Reply
Options

7 Posts

02-20-2014

Stavanger - Norway

10 Signins

86 Page Views

  • Posts: 7
  • Registered: ‎02-20-2014
  • Location: Stavanger - Norway
  • Views: 86
  • Message 7 of 13

Re: W540 - displays are flickering off and on randomly

2014-02-21, 9:13 AM
Fantastic!! Have been running for almost an hour without any blackouts! Have shared with my colleagues, this is fantastic news. Thank you so much dvl6! Have uses so many hours troubleshooting this.
Best regards

Joar Guttormsen
Reply
Options

56 Posts

12-25-2013

Germany

209 Signins

1027 Page Views

  • Posts: 56
  • Registered: ‎12-25-2013
  • Location: Germany
  • Views: 1027
  • Message 8 of 13

Re: W540 - displays are flickering off and on randomly

2014-02-23, 15:20 PM

I wonder if that is another bug in dock's firmware. Could be also responsible for throttling that I am experiencing...

Reply
Options

7 Posts

02-20-2014

Stavanger - Norway

10 Signins

86 Page Views

  • Posts: 7
  • Registered: ‎02-20-2014
  • Location: Stavanger - Norway
  • Views: 86
  • Message 9 of 13

Re: W540 - displays are flickering off and on randomly

2014-02-24, 8:40 AM

Im sure, it was too little juice in the powersupply that followed with the docking station. I tried to take the laptop out of the docking station and just connect all the devices directly in the laptop. Bought a minidisplayport to DVI converter so I could use two screens. (One on VGA = (Horrible) and one on DVI) I still used the PSU from the docking. The laptop then dimmed the screen at random times on the laptop, telling me there was a problem with the powersupply, and was going into flight-mode or something. So it was obvious that it had to little power even without the docking. But still, I did not think about the solution that came out in this post. I didn’t know that there where different effect on the PSU's. It solved my problem changing PSU. Never had a blackout since.

Best regards

Joar Guttormsen
Reply
Options

6 Posts

05-29-2014

UK

13 Signins

148 Page Views

  • Posts: 6
  • Registered: ‎05-29-2014
  • Location: UK
  • Views: 148
  • Message 10 of 13

Re: W540 - displays are flickering off and on randomly

2014-05-30, 7:48 AM

Well, well, well!!!

 

This could be the solution to my problem here then!!

 

Once I get my hands on the PSU supplied with the laptop and verify it definitely is a 170w then I'll be swapping them out.

 

Lenovo really should buck up their game and send the correct PSU with the Docking Stations!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete