Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

4 Posts

01-12-2009

New Jersey

21 Signins

132 Page Views

  • Posts: 4
  • Registered: ‎01-12-2009
  • Location: New Jersey
  • Views: 132
  • Message 1 of 4

W700 Great but few problems

2009-01-12, 23:59 PM

New W700 (Core 2 quad Core Extreme QX9300, NVIDIA FX 3700N, RAID 0, Ultimate 64) plus new W700 mini-dock. 

 

I use the machine mainly for Photo & Video editing & slideshow. Great performance and love the calibrated display.

 

Following are the problems I have or had: 

1. Defective keyboard (the right side of the keyboard was flexing making it difficult to type). Lenovo replaced it overnight. The new one is great.

 

2. The DisplayPort does not work on the Mini-dock but is working fine on the Thinkpad (but not recognized by Presentation Director but always recognized by Windows' Mobility Center). Presentation Director gives a message that no External Monitor is connected.

 

Lenovo replaced the mini-dock ... but same problem. I replaced the Display Drivers, change the BIOS from Internal to PCI Express, back to Internal). It just does not work on the mni-dock. Tried on different TV with Different HDMI cables.

 

3. The S/PDIF port on the mini-dock is not working (neither the original nor it's replacement). I set the SPDIF interface as default on the Control Panel Sound setting. The VU meter becomes active, but no sound.  I replaced the Sound Drivers.

 

My system is up to date with Lenovo and Microsoft drivers/updates

 

The reason I bought the mini-dock was to have both HD Video and good audio from the SPDIF. This way I could leave the cables always connected, and just dock the laptop when I make a presentation.

 

Too bad there is no Audio from DisplayPort...

 

Does anybody else has the DisplayPort and SPDIF working on mini-dock?

 

Any suggestions? I have already been on the phone with Lenovo Tech support for 3 hours.

 

This machine is a beast and had absolutely zero problem with all the software I use. More stable than my T60 with XP.

 

Any help would be greatly appreciated

 

Thanks

Jean Pierre

 

 

 

 

 

 

 

 

 

Reply
Options

101 Posts

11-02-2008

California

263 Signins

1610 Page Views

  • Posts: 101
  • Registered: ‎11-02-2008
  • Location: California
  • Views: 1610
  • Message 2 of 4

Re: W700 Great but few problems

2009-01-13, 21:51 PM

I have both the W700 and the mini-dock- I've tested SPDIF output with a BluRay disk to SPDIF--> input into a set of Logitech Z5500 speakers-- and the audio works fine. I have not tested the DisplayPort on the mini-dock.

 

To get audio out make sure you're not muting the SPDIF output, rightclick on the speaker icon in the system tray, choose playback devices, rightclick on SPDIF and set it to Default. Make sure you have the correct audio input selected on whatever device you have connected to the SPDIF port on the W700.

 

It's more than a shame Lenovo disabled digital audio passthrough on their internal audio board while at the same time choosing not to implement audio over DisplayPort-- as a quick review of the Intel whitepaper on same clearly documented how system builders like Lenovo could implement it.  They simply choose not to and also choose not to tell their customers prior to purchase (which is a real omission for those like myself that paid $450 extra for a BluRay drive).

 

A black-mark on what is otherwise an outstanding piece of gear.

Reply
Options

4 Posts

01-12-2009

New Jersey

21 Signins

132 Page Views

  • Posts: 4
  • Registered: ‎01-12-2009
  • Location: New Jersey
  • Views: 132
  • Message 3 of 4

Re: W700 Great but few problems

2009-01-14, 3:16 AM

I am glad that it works for you. I am enabling the SPDIF the same way you described.

 

I have not tried playing a BluRay or DVD disk. I only tried the Windows Media Player. The VU meter next to the SPDIF Interfeace is moving,which indicates that the port should be enabled. I will try it with BluRay disc. I also need to try it with a different pre-amp. The pre-amp port works well with my CD player, but it might have a conflict with the W700 mini-dock. 

 

I agree with you totally. You buy their top of the line Thinkpad and discover that the DisplayPort has been crippled. I also purchased it with the BluRay drive. 

 

Thanks for your help

 

Reply
Options

99 Posts

08-24-2008

Portugal

134 Signins

751 Page Views

  • Posts: 99
  • Registered: ‎08-24-2008
  • Location: Portugal
  • Views: 751
  • Message 4 of 4

Re: W700 Great but few problems

2009-01-22, 11:43 AM

About your second problem, Presentation Director saying no external monitor is connected: in my case, it took me a while to find out that all pre-defined Presentation Director schemes used the analog VGA port, and it kept telling me that I had no external monitor... Then, I discovered I had to define a new scheme to use the digital output.

 

W500 4062-2XG Gentoo Linux 64
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms