Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit our eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 1 of 32

X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-22, 18:48 PM

I've just received a new W540 with the 3K display, and Windows 8 keeps popping up X-Rite to calibrate the display. The tool runs ok, but when the lid is closed to do the calibration it fails with a message about not finding ECCM2SensorData.dat - I've searched online to find out more about this and it's suggestive that I'll need to have the display panel replaced!

 

I've definitely not got the file. So far I've had no response from Lenovo support, so I was wondering if anybody else had the same issue or knows a way to generate this file? I'm considering returning it rather than having the hassle of having parts swapped out, but it's really unclear how to make this happen.

 

Thanks

Antony

 

Reply
Options

764 Posts

04-13-2012

Iceland

1291 Signins

58075 Page Views

  • Posts: 764
  • Registered: ‎04-13-2012
  • Location: Iceland
  • Views: 58075
  • Message 2 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-22, 20:30 PM

Hello, I really doubt that this bug has anything to do with the display. It's more likely just a sofware bug.

 

The ECCM2SensorData.dat file should reside in the C:\ProgramData\X-Rite\ECCM-2 folder. If it's not there

then the Calibration program is not successfully saving the profile.

 

You could try running the Pantone Color Caibrator as Administrator and see if the file gets generated

that way, otherwise, just uninstall and reinstall the software. That should do the trick.

 

Pantone Color Calibrator

 

Cheers. Atli.

ThinkPad P1 - i7-8750H/32GB // ThinkPad P70 - Xeon E3-1505M/64GB
ThinkPad W540 (20BG) - i7-4800MQ/32GB // ThinkPad W520 (4282-W4Q) - i7-2720QM/32GB
ThinkPad T450s (20BW) - i7-5600U/12GB // Yoga 900 - i7-6500U/8GB
ThinkPad T61 (7665-CTO) - T7700/4GB // ThinkPad T60p (8741-C2G) - T7400/4GB
Reply
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 3 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-22, 21:06 PM

Good call re running as admin but no dice.

 

What I get when I close the lid is three beeps and the message that there are no lookup tables, so it tells me to run the Sensor Replacement Utility. I run this as admin, and get Error 22: no ECCMSensorData.dat file, with a clue to restore from backup.

 

This is a brand new machine, so I definitely don't have the file. There no info for the W540, but for the W530 there is this guide: http://support.lenovo.com/en_GB/downloads/detail.page?DocID=PD024421

 

Step 5 worries me, it might not be the same for the W540 but it's telling me to replace the whole display.

 

In C:\ProgramData\X-Rite\ECCM-2 I have:

ECCM2FirstRun (empty file)

RawData.txt

Results (empty folder)

XwriteSingleChannelSensor.txt

XRSSLog.txt

 

I've reinstalled. I could try restoring the whole OS but that might eliminate any chance of finding the missing file if it is hiding somewhere.

 

Thanks

Antony

 

 

 

Reply
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 4 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-22, 21:09 PM
Just as a test, I tried creating an empty file - I now get error 23.
Reply
Options

764 Posts

04-13-2012

Iceland

1291 Signins

58075 Page Views

  • Posts: 764
  • Registered: ‎04-13-2012
  • Location: Iceland
  • Views: 58075
  • Message 5 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-22, 21:23 PM

Restoring the OS is a bit drastic at this moment, but the ECCM2SensorData.dat is not a mission

critical file, as a new one is created when you change your profile in the program. Try uninstalling

the X-rite program and then delete the X-Rite folder from C:\ProgramData if the uninstall process

doesn't do that, reboot the machine, install the program again and run.

ThinkPad P1 - i7-8750H/32GB // ThinkPad P70 - Xeon E3-1505M/64GB
ThinkPad W540 (20BG) - i7-4800MQ/32GB // ThinkPad W520 (4282-W4Q) - i7-2720QM/32GB
ThinkPad T450s (20BW) - i7-5600U/12GB // Yoga 900 - i7-6500U/8GB
ThinkPad T61 (7665-CTO) - T7700/4GB // ThinkPad T60p (8741-C2G) - T7400/4GB
Reply
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 6 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-22, 21:43 PM
Thanks, I've just tried this and still get the same messages. It really does seem to need the .dat file.
Reply
Options

764 Posts

04-13-2012

Iceland

1291 Signins

58075 Page Views

  • Posts: 764
  • Registered: ‎04-13-2012
  • Location: Iceland
  • Views: 58075
  • Message 7 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-22, 22:38 PM

This is a strange issue indeed. Researching this with a coupe of other W- owners. I myself have a W520, running Win8.1, running version 1.1.0.6422 of the calibration software, and there's no ECCMSensorData.dat file on my machine. Everything running smooth and by the numbers.

 

What is the model number of your machine?

ThinkPad P1 - i7-8750H/32GB // ThinkPad P70 - Xeon E3-1505M/64GB
ThinkPad W540 (20BG) - i7-4800MQ/32GB // ThinkPad W520 (4282-W4Q) - i7-2720QM/32GB
ThinkPad T450s (20BW) - i7-5600U/12GB // Yoga 900 - i7-6500U/8GB
ThinkPad T61 (7665-CTO) - T7700/4GB // ThinkPad T60p (8741-C2G) - T7400/4GB
Reply
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 8 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-22, 22:48 PM
I'm also on Win 8.1, but the calibration tool is v1.2 - I'll try the older version and see what happens...

W540 type 20BG-CT01WW
Reply
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 9 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-22, 22:58 PM
Result with v1.1.0.6422: Same, but now the Sensor Replacement Utility gives a message: Missing Parameter File: Couldn't find entry in mapping file for monitor id: '@@@0000'. Please contact Xrite.
Reply
Options

764 Posts

04-13-2012

Iceland

1291 Signins

58075 Page Views

  • Posts: 764
  • Registered: ‎04-13-2012
  • Location: Iceland
  • Views: 58075
  • Message 10 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-23, 13:03 PM

Did you get your machine with the X-Rite software pre-installed?

 

I'm starting to sway toward your sensor being faulty, or disconnected or something like that.

ThinkPad P1 - i7-8750H/32GB // ThinkPad P70 - Xeon E3-1505M/64GB
ThinkPad W540 (20BG) - i7-4800MQ/32GB // ThinkPad W520 (4282-W4Q) - i7-2720QM/32GB
ThinkPad T450s (20BW) - i7-5600U/12GB // Yoga 900 - i7-6500U/8GB
ThinkPad T61 (7665-CTO) - T7700/4GB // ThinkPad T60p (8741-C2G) - T7400/4GB
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms