English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 11 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-23, 18:31 PM
That's an interesting thought. How could I tell? Do you know if it appears in the device manager or some other diagnostic tool that lists if it is connected? I've already run a hardware diagnostic which passed, but if it's not connected or it doesn't cover the sensor then maybe that's normal.

Yes, the tool was preinstalled with Windows 8 Pro.
Reply
Options

763 Posts

04-13-2012

Iceland

1288 Signins

58060 Page Views

  • Posts: 763
  • Registered: ‎04-13-2012
  • Location: Iceland
  • Views: 58060
  • Message 12 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-23, 18:49 PM

My sensor doesn't show in the Device Manager, not even when I show hidden devices, so I'm not sure

how to diagnose its presence.

 

I noted that one W520 user posted that he had upgraded his X-Rite service manager to

get it to work with Windows 8 when it came out, the latest version of it was just released

yesterday.

 

As it's already running on your machine, I don't see a problem with upgrading it, but I have

no clue wether it will work or not.

 

X-Rite Device Service Manager

ThinkPad P1 - i7-8750H/32GB // ThinkPad P70 - Xeon E3-1505M/64GB
ThinkPad W540 (20BG) - i7-4800MQ/32GB // ThinkPad W520 (4282-W4Q) - i7-2720QM/32GB
ThinkPad T450s (20BW) - i7-5600U/12GB // Yoga 900 - i7-6500U/8GB
ThinkPad T61 (7665-CTO) - T7700/4GB // ThinkPad T60p (8741-C2G) - T7400/4GB
Reply
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 13 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-23, 18:52 PM
It doesn't appear in the Lenovo Solution Centre hardware scan log file either. I'll try this download, thanks!
Reply
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 14 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-23, 18:56 PM
I get ' error trying to connect to measurement device' - I think you could be onto something here, it could well be disconnected. Any idea if it's easy / possible to check and reconnect it myself or would that void the warantee?
Reply
Options

763 Posts

04-13-2012

Iceland

1288 Signins

58060 Page Views

  • Posts: 763
  • Registered: ‎04-13-2012
  • Location: Iceland
  • Views: 58060
  • Message 15 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-23, 19:11 PM

The sensor is this little doohickey here:

Color Sensor

 

So to check its presence and connection involves removing the keyboard and the bezel as per

page 73 in the HMM.

W540/T540p HMM

 

I'm fairly certain that you'd void the warranty by doing so, however, but you'd have to

check that out with Lenovo services. Personally, I'd uninstall the color calibration

software to get rid of the pop-ups until you can get your machine serviced.

 

My 2 cents.

ThinkPad P1 - i7-8750H/32GB // ThinkPad P70 - Xeon E3-1505M/64GB
ThinkPad W540 (20BG) - i7-4800MQ/32GB // ThinkPad W520 (4282-W4Q) - i7-2720QM/32GB
ThinkPad T450s (20BW) - i7-5600U/12GB // Yoga 900 - i7-6500U/8GB
ThinkPad T61 (7665-CTO) - T7700/4GB // ThinkPad T60p (8741-C2G) - T7400/4GB
Reply
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 16 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-23, 20:45 PM
Thanks for all the help. It looks as though I'll have to wait for an official response from Lenovo, who have yet to respond to my call for a return/refund/repair.
Reply
Options

763 Posts

04-13-2012

Iceland

1288 Signins

58060 Page Views

  • Posts: 763
  • Registered: ‎04-13-2012
  • Location: Iceland
  • Views: 58060
  • Message 17 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-24, 18:14 PM

My pleasure my good man, please let us know how this turns out. This problem really baffled me.

ThinkPad P1 - i7-8750H/32GB // ThinkPad P70 - Xeon E3-1505M/64GB
ThinkPad W540 (20BG) - i7-4800MQ/32GB // ThinkPad W520 (4282-W4Q) - i7-2720QM/32GB
ThinkPad T450s (20BW) - i7-5600U/12GB // Yoga 900 - i7-6500U/8GB
ThinkPad T61 (7665-CTO) - T7700/4GB // ThinkPad T60p (8741-C2G) - T7400/4GB
Reply
Options

2 Posts

05-28-2014

United States

10 Signins

65 Page Views

  • Posts: 2
  • Registered: ‎05-28-2014
  • Location: United States
  • Views: 65
  • Message 18 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-28, 21:03 PM

Greetings all.  I have also purchased a W530 and out of the box, it has the same error.  Since receiving the laptop 2 days ago, I have spent about 7 hours on the phone with Lenovo and even had a tech come onsite and replace the bezel that contains the integrated components on this brand new laptop.

The issue remains unresolved.

 

LENOVO has been absolutely NO HELP concerning this issue.  The conversations I have had with them have been useless.

The error is indeed software related with the file "ECCM2SensorData.dat" missing.

This is a MANUFACTURING and SYSTEM IMAGE flaw.

LENOVO needs to step up to the plate, escellate and resolve this issue for the W540 and all other 540 models affected.

:manmad: :robotmad::manmad: :robotmad::manmad: :robotmad::manmad: :robotmad:

Reply
Options

17 Posts

05-22-2014

London

16 Signins

197 Page Views

  • Posts: 17
  • Registered: ‎05-22-2014
  • Location: London
  • Views: 197
  • Message 19 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-28, 22:44 PM

This issue shouldn't exist in the first place, and thanks for the heads-up re the telephone support.

 

I'm now trying a factory restore of the disk, which I wanted to do anyway to swap the HDD with an SSD. That doesn't work either but that's a different issue (can't restore to a blank disk, really?)

 

I still have the option of an RMA, which I really don't want to exercise as this seems to be the best machine currently available for my needs. There's nothing wrong with the hardware as far as I can tell, just a missing file that MUST be generated at LCD install time.

 

Update:

Restoring to factory state was a huge waste of time. Exactly the same results after restoring back to Windows 8.0. At least I'm now completely certain that it's not something I've done.

Reply
Options

2 Posts

05-28-2014

United States

10 Signins

65 Page Views

  • Posts: 2
  • Registered: ‎05-28-2014
  • Location: United States
  • Views: 65
  • Message 20 of 32

Re: X-Rite colour calibration: No ECCM2SensorData.dat file on W540?

2014-05-29, 13:19 PM

Re-Imaging is futile.

I'm pretty upset that LENOVO and IBM's support is this limited.

Support actually had a W540 on hand when I talked to them.  I walked them through the process of what I was doing and guess what.... THEIR W540 experienced the same thing.

I told them that if you solve that laptop's issu, you will have solved mine and many other peoples.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms