Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

554 Posts

06-30-2011

Gibraltar

1350 Signins

3952 Page Views

  • Posts: 554
  • Registered: ‎06-30-2011
  • Location: Gibraltar
  • Views: 3952
  • Message 1 of 7

w520 Reboot hangs on HD password, shutdown/startup works.

2012-03-12, 10:36 AM

I put the bios and HD passwords on in the BOIS about 3 months ago, and they worked perfectly in conjunction with the FPR.  i.e. you switch the machine on, scan your finger, it shows:

1: Bios tick

2: HD tick

Then boots windows without having to enter the password.

 

In the last 3 weeks, reboot always fails. It passes the initial fingerprint scan (big green tick), passes he 1: bios check, then fails the HD password.  It then sits at a prompt to put in the HD password.  However, if I enter the corrrect HD password, it gives a X to show it was not correct.  If I reboot at this point, it all works.

 

So the upshot is I cant reboot any more, I have to shut down (power off) first as it always hangs at the HD password part. 

 

Anyone else have this problem?  Nothing has changed between it working always, and it working never (eg. no SW updates, no new SW installed, no new HW etc).

 

Im booting in the dock, with no external HDs or similar devices attached.

 

Any ideas?

 

I could not live without the BIOS HD Password, as if my machine got stolen, there are a lot of production passwords etc on it.

Reply
Options

584 Posts

11-04-2010

Canada

811 Signins

5452 Page Views

  • Posts: 584
  • Registered: ‎11-04-2010
  • Location: Canada
  • Views: 5452
  • Message 2 of 7

Re: w520 Reboot hangs on HD password, shutdown/startup works.

2012-03-12, 10:51 AM

First, I'll go House on you...everybody lies.

 

"  Nothing has changed between it working always, and it working never "

 

Something has changed, just a matter of whether you know of it or not.

 

Try the following sequence of actions:

1. Disable BIOS password.

2. Disable HD password.

3. Boot into Windows.

4. Remove fingerprints settings.

5. Shutdown windows.

6. Enable BIOS password.

7. Enable HD password.

8. Boot into Windows.

9. Enable and scan your fingers again.

 

See if it now work as expected.

Reply
Options

9644 Posts

12-27-2009

Canada

3313 Signins

95283 Page Views

  • Posts: 9644
  • Registered: ‎12-27-2009
  • Location: Canada
  • Views: 95283
  • Message 3 of 7

Re: w520 Reboot hangs on HD password, shutdown/startup works.

2012-03-12, 14:26 PM
Yeah I would try removing all passwords, resetting the BIOS, and then add the passwords again.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
Reply
Options

2483 Posts

04-08-2011

United States of America

5471 Signins

46460 Page Views

  • Posts: 2483
  • Registered: ‎04-08-2011
  • Location: United States of America
  • Views: 46460
  • Message 4 of 7

Re: w520 Reboot hangs on HD password, shutdown/startup works.

2012-03-12, 14:35 PM

FrankenW520

Reply
Options

1 Posts

06-22-2012

Canada

1 Signins

14 Page Views

  • Posts: 1
  • Registered: ‎06-22-2012
  • Location: Canada
  • Views: 14
  • Message 5 of 7

Re: w520 Reboot hangs on HD password, shutdown/startup works.

2012-06-22, 20:12 PM

I have the same problem too with T430s and Intel 520 SSD.  Anyone has any luck resolving this please?

Reply
Options

1 Posts

06-23-2012

United States of America

2 Signins

22 Page Views

  • Posts: 1
  • Registered: ‎06-23-2012
  • Location: United States of America
  • Views: 22
  • Message 6 of 7

Re: w520 Reboot hangs on HD password, shutdown/startup works.

2012-06-23, 1:44 AM

I also have the exact same problem with a W520 and Intel 520 SSD.

 

It works fine with an Intel 320. It also works fine with Samsung 830 and Crucial M4 (although those drives themselves do not support AES).

 

For what it's worth, I just noticed that Intel has updated the specs on the 520 downgrading the 520 to AES-128 vs AES-256.

 

Intel 520 AES-128 vs 256

 

wk

Reply
Options

554 Posts

06-30-2011

Gibraltar

1350 Signins

3952 Page Views

  • Posts: 554
  • Registered: ‎06-30-2011
  • Location: Gibraltar
  • Views: 3952
  • Message 7 of 7

Re: w520 Reboot hangs on HD password, shutdown/startup works.

2012-06-23, 20:01 PM

Very interesting - it could be HD dependent.  now I think about it, I changed from the stock 320 GB WD to the identical model but 750GB around the time reboot fails.  So perhaps HD password and reboot only works with stock drives.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms