Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

46 Posts

12-07-2008

Australia

142 Signins

832 Page Views

  • Posts: 46
  • Registered: ‎12-07-2008
  • Location: Australia
  • Views: 832
  • Message 1 of 2

x64 Vista - Bluetooth Mouse Lag, Cant open Catalyst Control Center, Switchable graphics not working?

2008-12-07, 2:29 AM

Greatings,

 

I have just received my W500 and have spent a couple of days getting it setup as my new "productive" machine.

 

Specs: 

  W500 4058 CTO

  T9600

  4GB RAM

  OS HDD: 32GB MTRON SSD SATA3525

  Storage HDD: 320GB Seagate Momentus 7200.3

  Vista x64 Ultimate

 

I have installed all of the drivers as per Lenovo's website and updated BIOS 1.19

 

I have spent quite a few days working through x64 app compat issues wasnt expecting I would have to do the same for the h/w.

 

Everything in the system seems to be ok except for these two issues:

 

  • Bluetooth Mouse Lag

 

I have the old Logitech DiNovo keyboard/mouse combo and it worked well on my previous HP machine, I would very rarely experience lag on the mouse and if I did it was because the machine was completely bogged down.

 

However on this W500 I am experiencing lag issues with mouse, get the slow motion effect going on all the time and also it feels like the keyboard is lagging too.

 

It is not interface as if I boot my HP up in same location mouse/keyboard have no issues. 

 

I have the spare HDD that the W500 shipped with so I am going to do a clean install on it with x64 Vista and just install minimum drivers to see if it is a h/w issue or applications.

 

  • Catalyst Control Center doesnt open anymore

 

Not sure when but at some stage the CCC stopped working, no ATI icon in systray and right click then selecting CCC does nothing?

 

CCC.exe *32, MOM.exe *32 are running?

 

I have tried going to new drivers and also changing to discrete only but no go?

 

I am suspecting some other software I have installed maybe?

 

  • Switchable graphics not working

 

Major reason for selecting the W500 was the switchable graphics option, my old HP was good in the office but in the field it didnt last the distance. So when I heard about switchable I was excited to get good performance in office and battery life in the field.  Until it stopped working that is?

 

 

Ok here are some things that might make my install different from others:

  • Dual HDD install, user profiles have been moved to D:\Users using Folderlocations in AutoUnattend.
  • I had to run "C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Ldr64.exe setwow" to enable legacy 32-bit .net apps to run
  • Applications:
    • MS Office Enterprise
    • MS VS2005
    • MS PB CE 5.0
    • MS PB CE 6.0
    • SW 2008
    • VMware workstation 6.5

 

Thanks in advance to anyone who has advice

 

Jordan.

Reply
Answer
Options

46 Posts

12-07-2008

Australia

142 Signins

832 Page Views

  • Posts: 46
  • Registered: ‎12-07-2008
  • Location: Australia
  • Views: 832

Re: x64 Vista - Bluetooth Mouse Lag, Cant open Catalyst Control Center, Switchable graphics not work

2008-12-07, 4:12 AM

Solved my Catalyst not opening issue, the fix that makes some of my 32-bit .net apps breaks x64 .net apps hmmm.

 

ldr64 setwow - All of my development tools work, breaks most of the 64-bit .net apps

ldr64 set64 - Catalyst /Fingerprint and other 64-bit compiled .net apps work.

 

Argghh **bleep** application compat issues!  I guess it is too much to ask to have everything working at once.

 

 

After more research on Bluetooth, so many forums telling people its your hardware, its interferance however I know the cause of this issue Vista! my bluetooth headset's, mice, keyboard work fine if I roll back to XP but x86 and x64 both have large issues with Bluetooth.

 

So still looking for the technical answers to why vista and bluetooth dont get along?

 

I will try enabling switchable and see what I get now, hopefully not more BSOD's when I attach my monitor, have to say BSOD look cooler in x64 more digits :)

 

 

Reply

Replies(1)
Answer
Options

46 Posts

12-07-2008

Australia

142 Signins

832 Page Views

  • Posts: 46
  • Registered: ‎12-07-2008
  • Location: Australia
  • Views: 832
  • Message 2 of 2

Re: x64 Vista - Bluetooth Mouse Lag, Cant open Catalyst Control Center, Switchable graphics not work

2008-12-07, 4:12 AM

Solved my Catalyst not opening issue, the fix that makes some of my 32-bit .net apps breaks x64 .net apps hmmm.

 

ldr64 setwow - All of my development tools work, breaks most of the 64-bit .net apps

ldr64 set64 - Catalyst /Fingerprint and other 64-bit compiled .net apps work.

 

Argghh **bleep** application compat issues!  I guess it is too much to ask to have everything working at once.

 

 

After more research on Bluetooth, so many forums telling people its your hardware, its interferance however I know the cause of this issue Vista! my bluetooth headset's, mice, keyboard work fine if I roll back to XP but x86 and x64 both have large issues with Bluetooth.

 

So still looking for the technical answers to why vista and bluetooth dont get along?

 

I will try enabling switchable and see what I get now, hopefully not more BSOD's when I attach my monitor, have to say BSOD look cooler in x64 more digits :)

 

 

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms