cancel
Showing results for 
Search instead for 
Did you mean: 
Views: 81,499

Question

 

 

Just upgraded to Windows 8.1 on my W520 and now my display doesn't look right at all. Resolution seems to be set to 1920x1080... which I belive is correct, but text, icons and windows seem bigger than they were before.

 

Also the display is lacking sharpness around text.

 

Do I need to upgrade some drivers or something?

Answer

  

Microsoft has released a tech article about this.  

 

When using Windows 8.1 on a computer with a display featuring a high number of dots per inch (high-DPI), some desktop applications may appear somewhat blurry as compared to other applications on the screen.

 

In order to provide an optimal experience on high-DPI displays, desktop applications need to detect the DPI of the display which is in use, and scale their graphical elements, text, and screen layout appropriately. Some applications do not implement this; thus they may not look as sharp.

 

 

If there is not an updated DPI-aware version of the application available, you may be able to alter the appearance of the application by using one of the following methods. Note that this may result in less desirable results, depending on the application.

  • Disable DPI virtualization for the application. To do this, right-click the application’s shortcut and then click Properties. On the Compatibility tab, select "Disable Display Scaling On High DPI Settings", and then click OK. This will cause the text in the application to appear clearer, but if the application does not properly handle high DPI settings, it may have adverse side effects such as truncated text or incorrectly sized graphical elements.

 

  • Lower the overall Windows DPI setting. To do this, open the desktop Display control panel (or search for "dpiscaling" from the Start Screen) and adjust the slider under "Change the size of all items". You may need to select the checkbox for "Let me choose one scaling level for all my displays" and change the scale to 100%.

    Note that on very high-DPI displays, this may make screen elements very small, and some text may become difficult to read.

Was this information helpful?

Comments
newcust13

Have there been any developments on this? Setting the scale to 100% makes my Y510P's screen elements painfully small, and other options seem to stretch parts of the screen.

babyskill

it look bad Smiley Sad

sneuby

Similarly on my new t440s.  The font is blurry despite taking these steps.  Really horrible!

TAudio

If you just upgraded to 8.1 and now your fonts look weird, text is harder to read, or tray icons look fuzzy/blurry then this should fix it:

Right click desktop, choose "Screen resolution"
Click "Make text and other items larger or smaller"
Check the box "Let me choose one scaling level for all of my displays"
Click the "Apply" buttin below the above setting

Log out

It worked for me!

draguzet

Same problems, even more...

 

http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/T440s-blurred-display-after-connecting-external-monitor/m-p/1777309#M104715

matkring1

I had a similar problem when upgrading to windows 10.

Solution was simple: enter "dpiscaling" in search. Then i went for the set a custom scaling level. Then i chose 100% instead of 125% which was chosen.

sIgnature

In my lenovo z50-70 also same issue...feels soo irritated...i tried all the settings mentioned in net but still no proper resoultion. Its a great fault. The main thing is the issue is with my most used apps like autocad and photoshop...