cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ChuckTribolet
Fanfold Paper
Posts: 11
Registered: ‎07-25-2009
Location: Silicon Valley
Views: 46,986
Message 11 of 52

Re: Can't remove HDD password

I'm seeing the same symptom on a drive that was in three different T61p machines, all the same model.

I did some homework, and it looks like
the hard drive is in "Device Frozen Mode" because something is issuing a

Set Max Freeze Lock command.  But that's only supposed to last until the next power cycle.

Dunno where I go from here.  I'd really like to fix this.  I got myself into a box
the next time I powered cycled the box (about a month later, away from home)
and had trouble remembering the disk password.

 

There's another thread on this at

http://forum.lenovo.com/t5/T61-and-prior-T-series-ThinkPad/t61p-change-hard-drive-password/td-p/1397...

 

 

Chuck

Community SeniorMod
Community SeniorMod
Posts: 9,865
Registered: ‎01-01-2010
Location: US
Views: 46,940
Message 12 of 52

Re: Can't remove HDD password

Frozen has nothing to do with passwords. It relates to hot-swapping in the ultrabay.

Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
danielthaler
Fanfold Paper
Posts: 7
Registered: ‎06-18-2010
Location: Germany
Views: 46,933
Message 13 of 52

Re: Can't remove HDD password

In my opinion you're both confused :-)

SET MAX FREEZE LOCK is a command related to the "protected area" feature. It allows one to artificially make the disk appear smaller than it really is to reserve part of it for special use.

SECURITY FREEZE LOCK on the other hand is very relevant. To clear up the confusion, this is how it works:
A password protected drive is locked, but not frozen after power-on. This means that it will reject all data access commands but accept most others.
The BIOS will then ask you for a password and send it to the drive in a SECURITY UNLOCK command. This puts the drive into unlocked, non-frozen mode, where it accepts all commands.
That mode is generally not available to you though, because the BIOS also sends as SECURITY FREEZE LOCK command to the drive before it hands over to the boot loader. The drive is then in frozen unlocked mode, where no further security-related commands are accepted. Apparently this is due to an agreement between Microsoft and PC-makers that people need to be protected from having their drives maliciously locked by viruses. I don't entirely disagree.

So whenever you examine a drive with software it will generally be in the unlocked, frozen mode. You can get around this: power cycling puts the drive back into locked, non-frozen mode. Since SATA drives are hotpluggable, you can simply insert your disk into the running machine after the BIOS has done it's thing. The Ultrabay HDD adapter is good for this.

On Linux you can then manually trigger disk discovery to get a device node for your disk and start talking to it with hdparm - you won't be able to actually read any data, because the disk is of course still locked.

In theory you should be able to unlock it with the following command:
hdparm --user-master u --security-unlock "mypassword" /dev/sdX
followed by some invocation involving --security-disable
This doesn't actually work: It seems that the ThinkPad BIOS somehow mangles the password before sending it to the drive, so my password doesn't actually work when used via hdparm. I've also managed to verify that I haven't just gotten my commands wrong or something: I've found that I can't unlock my drive in an HP notebook either.

And that is where my investigations have basically stopped, as I have no other ideas to try.

Documents of interest:
Page 42 and following in http://www.hitachigst.com/tech/techlib.nsf/techdocs/6B469785408D94EF86256FA2005B2E74/$file/C4K60_PC_...
also Page 38 (internal) here http://www.t13.org/Documents/UploadedDocuments/project/d1410r3b-ATA-ATAPI-6.pdf

Myron999
Punch Card
Posts: 10
Registered: ‎02-23-2010
Location: Az
Views: 46,868
Message 14 of 52

Re: Can't remove HDD password

I am having the same problem. The hd password works properly with the original drive I got with my T510, a samsung ssd, however after replacing it with a Crucial M225 (big mistake - Crucial is crap) once the hd password is set, the bios will not let me change or remove it. What model drive do you have in your system? Have you tried to see if the hd password functions properly with a different drive?

danielthaler
Fanfold Paper
Posts: 7
Registered: ‎06-18-2010
Location: Germany
Views: 46,858
Message 15 of 52

Re: Can't remove HDD password

Interesting. I have a Crucial RealSSD C300. I have not tested setting a password on any other drive via the TP BIOS. I did not want to risk being unable to freely swap another drive.
Myron999
Punch Card
Posts: 10
Registered: ‎02-23-2010
Location: Az
Views: 46,843
Message 16 of 52

Re: Can't remove HDD password

stumpy99
What's DOS?
Posts: 2
Registered: ‎11-05-2010
Location: England
Views: 46,800
Message 17 of 52

Re: Can't remove HDD password

I have the same problem with the c300 on my T510 thinkpad. This isn't the only problem i've had with this drive, see

 

http://forums.crucial.com/t5/Solid-State-Drives-SSD/c300-firmware-002-fails-to-execute-SMART-self-te...

 

 

Hope this get resolved soon.

Highlighted
geoffsh
What's DOS?
Posts: 3
Registered: ‎11-22-2010
Location: Arizona
Views: 46,917
Message 18 of 52

Resolved this issue

I resolved this exact issue on an X201, and I hope this helps others with other Lenovo models.  The problem is related to the format in which the password is saved in the drive.  On the X201, there is a "Use Passphrase" option under passwords which may either be enabled or disabled.  If it is enabled, it causes all passwords, including the hard-drive password, to be saved in a more secure format.  If this setting is shows as disabled and the HD password was saved with it enabled, then you will run into this issue.  I believe this problem is caused by removing the drive and then toggling the "Use Passphrase setting," and then re-inserting the drive.  In a nutshell, that is what caused it for me.

 

In addition to a greyed-out "User" HD password, the "Use Passphrase was also greyed-out. 

Without further ado, here is the solution:

 

1. Remove the drive from the laptop

2. Power up the laptop and go into the bios

3. If there are any other bios related passwords set, remove them.

4. Now, you should be able to toggle the "Use Passphrase" setting.  If it is enabled then disable it, and if it is disabled, then enable it. 

5. Save changes and exit.

6. Power down, re-insert the drive, and go back into the bios.  You should now be able to make whatever changes you want to the HD password setting. 

 

Let me know how it goes. 

mjhuff73
Paper Tape
Posts: 2
Registered: ‎11-29-2010
Location: United States
Views: 46,636
Message 19 of 52

Re: Resolved this issue

Geoffsh

 

Thank you! Thank you! and Thank you!  If you worked by me I'd buy you lunch.  Your fix worked like a charm.

 

Crucial M225 64GB SSD

Lenovo T61

 

Password was mangled apparently by the "use passphrase" setting, and after I disabled the setting without the SSD in the bay, I was able to get back in and remove the password.  Strange thing is, I don't recall ever playing with that setting.  It makes me nervous to even bother with the ATA password, since I'm using PGP Whole Disk Encryption anyway, I'll probably just set a BIOS (not HD) password to slow down casual thievery, then rely on PGP WDE for the real security of the drive.  After all, it's the data we care about, not the hardware.

 

I'll pass your fix around, starting with the post on the Crucial site.

 

Matt

swifta
What's DOS?
Posts: 1
Registered: ‎12-14-2010
Views: 46,484
Message 20 of 52

Re: Resolved this issue

Another HUGE thank you!  Solved my issue with a T61.  Five stars to you!!

Check out current deals!


Shop current deals

Top Kudoed Authors