cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
adante
SCSI Port
Posts: 94
Registered: ‎06-29-2008
Location: AU
Views: 6,873
Message 1 of 7

Disable middle click scroll mode

I would like to use the trackpoint as a proper middle click instead of the (also useful) proprietary scroll mode. Basically same problem as discussed here:

 

http://superuser.com/questions/91074/thinkpad-trackpoint-scrolling-and-middle-click-possible

 

However that article seems a little old. The synaptics control panel on the W540 seems to be markedly different and I cannot for the life of me find out where to disable that or set the middle  click to be a regular middle click. Could someone please advise?

 

 

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 6,866
Message 2 of 7

Re: Disable middle click scroll mode

Yeah it seems they removed it (WHY.) from the newer model's drivers.

It looks like the registry key is HKCU\Software\Synaptics\SynTP\StickPS2

It also looks like the entry you have to change is Gestures to 0 from 0x80 (128).

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
ibmthink
Bit Torrent
Posts: 638
Registered: ‎10-21-2011
Location: DE
Views: 6,835
Message 3 of 7

Betreff: Disable middle click scroll mode

@adante,

I would advise you to use TPMiddle: http://files.yummysoup.com/tpmiddle/tpmiddle.html Works perfectly on my T440s.

 

With the newest divers, you only have the option to disable the Middle button completely if you want to. 

Guru
Posts: 9,598
Registered: ‎12-26-2009
Location: CA
Views: 6,814
Message 4 of 7

Betreff: Disable middle click scroll mode

That tool is awesome.

W520: 2960XM, Q2000M @ 1091/1380, 32GB RAM, 500GB&750GB HDD & 500GB SSD, FHD&MB168B+
X61T: L7500, 4GB RAM, 500GB HDD, XGA screen, Ultrabase
W550s: 5600U, K620M at 1164/1281, 16GB RAM, 512GB SSD, 3K touchscreen
X200s: SL9400, 6GB RAM, 64GB SD card, WXGA+ screen
TPT1: 1839-23U
adante
SCSI Port
Posts: 94
Registered: ‎06-29-2008
Location: AU
Views: 6,788
Message 5 of 7

Betreff: Disable middle click scroll mode

Yes thanks ibmthink that tool is amazing and needs more exposure!

netdragon
Fanfold Paper
Posts: 11
Registered: ‎09-07-2014
Location: Atlanta
Views: 5,913
Message 6 of 7

Betreff: Disable middle click scroll mode

This works below (ignore my accidental mark of the other one as the solution)

 

Also, add this to the Startup programs by going to the search textbox in Windows 8.1 menu and then typing shell:startup as described here: http://support.microsoft.com/kb/2806079

Then you can create a shortcut for the app and put the shortcut in startup


@ibmthink wrote:

@adante,

I would advise you to use TPMiddle: http://files.yummysoup.com/tpmiddle/tpmiddle.html Works perfectly on my T440s.

 

With the newest divers, you only have the option to disable the Middle button completely if you want to. 


 

DrDanielJackson
Paper Tape
Posts: 3
Registered: ‎05-06-2016
Location: US
Views: 3,719
Message 7 of 7

Re: Disable middle click scroll mode

Looks like the registry key/value to fix this behavior is

HKCU\Software\Synaptics\SynTPEnh\UltraNavPS2\TrackPointMode  00001214 -> 00002214

 

http://techne.alaya.net/?p=12008

http://johnbruer.com/2013/05/18/middle-click-thinkpad-synaptics-touchpad

 

Log in to windows again, or just disable/re-enable TrackPoint. Tried it on my t520, worked for me (yay!).

Check out current deals!


Shop current deals

Top Kudoed Authors