cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rohitjthomas
Paper Tape
Posts: 4
Registered: ‎04-08-2015
Location: Boyds, MD
Views: 411
Message 1 of 8

Display issue with dual monitors via DVI on ThinkPad W510 with 4338 dock

Hello everyone,

 

I have a Thinkpad W510 laptop connected to two monitors using a 4338 dock with DVI connections from the dock to the monitors. I have this same configuration at my home office and work office locations. At both locations, there is no output from the second display, even though the second monitor is being detected by the OS (Win7 Enterprise SP1, 64-bit).

 

Under Device Manager, I have uninstalled both monitors and the NVIDIA Quadro FX 880M display card and reinstalled them which did not resolve the issue. This configuration was working without issue for over a year. This is a laptop provided by my company so I not sure if one of their software updates caused this issue.

 

Any assistance the community can provide in troubleshooting this issue would be appreciated.

 

Thanks!

Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 387
Message 2 of 8

Re: Display issue with dual monitors via DVI on ThinkPad W510 with 4338 dock

Hi Rohitjthomas,

 

Welcome to Lenovo Community!

 

Can you provide us the current Nvidia graphic driver version which is installed in your system?

In device manager under display adapter what all adapters it is showing, if possible send the screen shot of DM?

 

Best regards,

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

rohitjthomas
Paper Tape
Posts: 4
Registered: ‎04-08-2015
Location: Boyds, MD
Views: 378
Message 3 of 8

Re: Display issue with dual monitors via DVI on ThinkPad W510 with 4338 dock

Hello,

 

The graphic driver version is 9.18.13.1254. As previously mentioned, both montiors are detected by the OS, but there is no output from montior #2.

 

Regards,

Rohit

 

 Display Issue #1.jpgDisplay Issue #2.jpg

 

 

Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 353
Message 4 of 8

Re: Display issue with dual monitors via DVI on ThinkPad W510 with 4338 dock

Hi Rohitjthomas,

 

Thank you for the reply!

 

The graphic driver which are installed in your system is outdated, hence suggest you to uninstall the current driver and restart the system, download the latest driver from the below link and run the setup file.

 

http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-w-series-laptops/thinkpad-w51...

 

Hope this helps.

 

Best regards,

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

rohitjthomas
Paper Tape
Posts: 4
Registered: ‎04-08-2015
Location: Boyds, MD
Views: 301
Message 5 of 8

Re: Display issue with dual monitors via DVI on ThinkPad W510 with 4338 dock

I followed the instructions below to update the graphics driver (now at v9.8.13.1269) however that did not resolve the issue. Are there any other troubleshooting steps that I can attempt to resolve the issue?

 

Regards,

Rohit

Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 291
Message 6 of 8

Re: Display issue with dual monitors via DVI on ThinkPad W510 with 4338 dock

Hi Rohitjthomas,

 

Can you confirm is the “Graphic device” is set to “Nvidia optimus” in BIOS – Config – Display option.

 

Hope this helps.

 

Best regards,

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

rohitjthomas
Paper Tape
Posts: 4
Registered: ‎04-08-2015
Location: Boyds, MD
Views: 282
Message 7 of 8

Re: Display issue with dual monitors via DVI on ThinkPad W510 with 4338 dock

Hello,

 

I have BIOS v1.34 (6NET74WW) dated 2010-10-27. The only option I have under Config > Display is Boot Display Device which is currently set to ThinkPad LCD. I also have the following options - Analog (VGA), Digital on ThinkPad, Digital 1 on Dock and Digital 2 on dock.

 

Thanks,

Rohit

 

Highlighted
Retired Support Specialist
Posts: 3,015
Registered: ‎03-14-2014
Location: Bangalore
Views: 271
Message 8 of 8

Re: Display issue with dual monitors via DVI on ThinkPad W510 with 4338 dock

Hi Rohitjthomas,

 

  • Did you check changing those settings on BIOS (Digital on ThinkPad, Digital 1 on Dock and Digital 2 on dock)?
  • Also check updating the BIOS, there is a latest release Ver 1.45. Use thinkvantage system update utility to update the drivers and BIOS.

http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-w-series-laptops/thinkpad-w51...

 

Hope this helps!

 

Best regards,

Hemanth Kumar



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Check out current deals!


Shop current deals

Top Kudoed Authors