Showing results for 
Search instead for 
Did you mean: 
Views: 14,991


How do I disable the beeping that happens when I type too fast on my keyboard?


When multiple keys are depressed on a ThinkPad keyboard at the same time this may cause the laptop to beep. This is a symptom of a condition Lenovo refers to as "Unmanageable Key Combinations". It occurs because there are too many inputs coming in from the keyboard at the same time.


Here is a procedure to disable keyboard beeps in BIOS:


1. Reboot the ThinkPad while pressing F1 repeatedly to enter into BIOS.

IMG_0034 v2.jpg






















2. Tap the right arrow key to highlight the Config tab and hit enter.


IMG_0035 v2.jpg

3. Use the down arrow key to highlight Beep and Alarm and hit enter.


IMG_0036 v2.jpg


4. Tap the down arrow key to highlight Keyboard Beep and hit enter.


IMG_0037 v2.jpg


5. In the pop-up window, tap the up arrow key to highlight Disabled and hit enter.


IMG_0038 v2.jpg


6. Tap the F10 key to Save and Exit.



IMG_0039 v2.jpg

    Keyboard beeping is now disabled.

Was this information helpful?