Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 16,565



I have a 2 months old W520 factory settings. It has been acting up lately when powering up but after holding down the power button for 10 sec or so it would always start. However, that is not even working today.


I took out the battery and plugged it in AC and tried to no avail. I also tried powering it up with battery alone and neither seems to work. 


A few of our communtiy users found the following method works for them:


  1. Unplug machine from Power Supply
  2. Remove battery
  3. Hold down power button for 20 seconds
  4. Press the power button 5 times
  5. Install battery by re-plug it in
  6. Press power button to turn it on again

The process drains capacitors on the motherboard that might be charged

Was this information helpful?


dear Mark or Serene at Lenovo,

I have a W701 Thinkpad since 2012 with W7 64b, but since 2 weeks it refuses to start and shows no display and keeps spinning disk. what to do now? how start BIOS or do other recovery?

thank you, Huub (from reliable x220....)