English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

10 Posts

02-07-2016

Berlin, Germany

14 Signins

57 Page Views

  • Posts: 10
  • Registered: ‎02-07-2016
  • Location: Berlin, Germany
  • Views: 57
  • Message 1 of 299

Lenovo P50 - HDMI not working

2016-02-07, 12:28 PM

Hi,

 

I just got my new Lenovo P50 a few days ago, and so far it was a great experience.

The only thing that doesn't work is the HDMI connector. I understand the HDML is connected directly to the NVIDIA GPU. I assumed it will work when setting the BIOS to discrete graphics, but that didn't help as well.

Steps I took  (The HDMI cable is, of course, connected, and "Project" settings (Fn F7 or Windows-P) is set to "extend")

1) Update NVIDIA drivers

2) Use NVIDIA drivers recommended by lenovo

3) Reduce resolution to HD and Full HD (the projector I am connecting supports both resolutions)

4) many many restarts :)

 

I have noticed another thing - In the BIOS there is a way to configue the device to which the boot screen will be sent to. The options are "ThinkPad Display", "DisplayPort" and "Display On Dock". But the documentation on the right side is also saying there SHOULD be an Option "HDMI". Which is not there.

 

When looking into the NVIDIA native system information, it shows 1 native output (the laptop's screen) which is "connected". Other than that ttere are 3 (!) display ports, all 3 not connected (thou the projector is on, and the cable is connected). To me it seems like the HDMI port is disabled, but I can't find any way to enable it!

 

Any help will be appreciated.

 

 

Solved! See the solution
Reply
Options

77 Posts

05-21-2011

US

104 Signins

642 Page Views

  • Posts: 77
  • Registered: ‎05-21-2011
  • Location: US
  • Views: 642
  • Message 2 of 299

Re: Lenovo P50 - HDMI not working

2016-02-07, 12:42 PM

RaananW wrote:

The only thing that doesn't work is the HDMI connector. I understand the HDML is connected directly to the NVIDIA GPU. I assumed it will work when setting the BIOS to discrete graphics, but that didn't help as well.

Steps I took  (The HDMI cable is, of course, connected, and "Project" settings (Fn F7 or Windows-P) is set to "extend")

1) Update NVIDIA drivers

2) Use NVIDIA drivers recommended by lenovo

3) Reduce resolution to HD and Full HD (the projector I am connecting supports both resolutions)

4) many many restarts :)

 

 

When looking into the NVIDIA native system information, it shows 1 native output (the laptop's screen) which is "connected". Other than that ttere are 3 (!) display ports, all 3 not connected (thou the projector is on, and the cable is connected). To me it seems like the HDMI port is disabled, but I can't find any way to enable it!

 

 


 

don't know about HDMI port, i have seen similar problem with the miniDisplayPort->HDMI display.

 

i got it work in mirror mode (1920x1080) once when i first connect a monitor.

 

the next time i connect, somehow it thinks there are 2 displays mirrored to the internal P530 graphics, but limited to 1280x720, cannot change that.  the external display (connected to the M2000) shows nothing.

 

windows resolution, intel graphics control panel, nvidia control panel, none can fix it.

 

the only way i got it to work is switch to extended, the internal shows 4K option again and the external works as is.

 

if you look at the audio, it is kind of wonky also, sometimes it will say all 3 digital output are disconnected.  i have to reboot, then the mDP-HDMI audio works again, show #1 is connected.

 

i think the driver is just buggy like the previous intel+nvidia configurations.

 

also got some problem with Adobe Photoshop, can't get it to use auto GPU (Ps just disable it) or discreet, it keeps switch back to integrated, once that got selected, nvidia control panel won't change to anything else.

 

and some benchmarks, it just bombed

my running test note at

 

http://users.wfu.edu/yipcw/lenovo/2016/p50/

 

 

 

 

 

Reply
Options

10 Posts

02-07-2016

Berlin, Germany

14 Signins

57 Page Views

  • Posts: 10
  • Registered: ‎02-07-2016
  • Location: Berlin, Germany
  • Views: 57
  • Message 3 of 299

Re: Lenovo P50 - HDMI not working

2016-02-07, 13:22 PM

Wanted to add one more thing - 

The cable is working - I use it with a different computer and with a Rasp-PI - both detect the projector with no problem.

Another reason I believe the HDMI is deactivated is Audio - Windows usually detects the projector as an audio output device, but with the P50 (and windows 10) it doesn't.

Reply
Options

77 Posts

05-21-2011

US

104 Signins

642 Page Views

  • Posts: 77
  • Registered: ‎05-21-2011
  • Location: US
  • Views: 642
  • Message 4 of 299

Re: Lenovo P50 - HDMI not working

2016-02-07, 13:36 PM

wrote:

Wanted to add one more thing - 

The cable is working - I use it with a different computer and with a Rasp-PI - both detect the projector with no problem.

Another reason I believe the HDMI is deactivated is Audio - Windows usually detects the projector as an audio output device, but with the P50 (and windows 10) it doesn't.


haven't trued Windows 10, I only use the OEM Windows 7 it came with so far.

 

Have you tried to control it with NVIDIA control panel?  I got it to work there sometimes better than Windows native control.  I think the three (plus Intel) all try to control the hardware, but not exactly communicating properly.  Sometimes I can't Windows-P to switch mode, it has no effect, have to use NVIDIA (I suspect nvidia is not writing everything back to registry control set, so Windows doesn't know what is being changed) 

Reply
Options

10 Posts

02-07-2016

Berlin, Germany

14 Signins

57 Page Views

  • Posts: 10
  • Registered: ‎02-07-2016
  • Location: Berlin, Germany
  • Views: 57
  • Message 5 of 299

Re: Lenovo P50 - HDMI not working

2016-02-07, 13:43 PM

The problem is that the projector is not even recognized by the NVIDIA card as connected. Nothing is shown, even in the nvidia control panel (there is a "setup multiple devices" section tat shows all connected devices.)

I am not able to check with any other display at the moment, but I can really say that the projector is working correctly. This is an issue with the P50. Either software or hardware, but something's wrong (Maybe with my setup, but I really tried everything I could)

Reply
Options

10 Posts

02-07-2016

Berlin, Germany

14 Signins

57 Page Views

  • Posts: 10
  • Registered: ‎02-07-2016
  • Location: Berlin, Germany
  • Views: 57
  • Message 6 of 299

Re: Lenovo P50 - HDMI not working

2016-02-07, 13:47 PM

This is how the NVIDIA's control panel looks like - 

http://imgur.com/a/RgIJW

No HDMI, just 3 display ports.

Reply
Options

130 Posts

05-03-2009

USA

262 Signins

1868 Page Views

  • Posts: 130
  • Registered: ‎05-03-2009
  • Location: USA
  • Views: 1868
  • Message 7 of 299

Re: Lenovo P50 - HDMI not working

2016-02-08, 17:38 PM

@RaananW:

 

Try to load the BIOS default and see if it fixes the problem?

 

Reply
Options

10 Posts

02-07-2016

Berlin, Germany

14 Signins

57 Page Views

  • Posts: 10
  • Registered: ‎02-07-2016
  • Location: Berlin, Germany
  • Views: 57
  • Message 8 of 299

Re: Lenovo P50 - HDMI not working

2016-02-08, 20:46 PM

Didn't work, but I will surely try again.

 

I tried today with a different screen. Result - HDMI is simply not working. Connecting the screen using the DP connector worked in a second (with hybrid mode in the bios). 

Reply
Options

1 Posts

02-11-2016

Netherlands

3 Signins

22 Page Views

  • Posts: 1
  • Registered: ‎02-11-2016
  • Location: Netherlands
  • Views: 22
  • Message 9 of 299

Re: Lenovo P50 - HDMI not working

2016-02-11, 8:25 AM

I just received my Lenovo P50. It is incredible that when you receive an new mega expensive laptop that not all ports are working!! HDMI come on. I can't even extend my display. Hope someone comes with a solution. Should be Lenovo!! Deliver a laptop that does not work out of the box.

Reply
Options

10 Posts

02-07-2016

Berlin, Germany

14 Signins

57 Page Views

  • Posts: 10
  • Registered: ‎02-07-2016
  • Location: Berlin, Germany
  • Views: 57
  • Message 10 of 299

Re: Lenovo P50 - HDMI not working

2016-02-11, 8:44 AM

So I understand I am not the only one with this problem :)

Would be great to know what lenovo has to say about this.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save