cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jackbee
Paper Tape
Posts: 1
Registered: ‎04-27-2016
Location: US
Views: 172
Message 1 of 1

Lenovo w450 does not boot after upgrade BIOS

Yesterday, After the "Lenovo solution center" told me that , I should upgrade the BIOS, I ran the BIOS upgrade and my Lenovo w450 doesn't boot anymore!

 

The total black scary screen appears whaterver I press the power button many times, many long presses (actually the screen was not started) ?! The laptop do nothing. It seems to be that nothing happen. I tried to remove battery, wait...follow the instructrion , do everything but it doesnot boot. I brroght the laptop to the local Lenovo service authorizer. After 2 hours later, they told me that the laptop BIOS is broken down, and then I have to pay 100$ to order the new one!!!! although my quaranty date is still valid until 2017 (according to "Lenovo auto detecting" service said that). It's a shame.

I don't even sure that the issue is cause by the BIOS or not. Besides, The Lenovo solution center "told" me that: I have to run the BIOS upgrade and now it break down the laptop. Now I have to wait at least a week to get the new BIOS shipping (I'm from VN) all my works are now pospond, and I loose the customers every day. For me. from now on, I'll keep away from Lenovo products and tell my friend do so.

 

Enough the complaination. My questions are:

- Before the BIOS is died for upgrade, the Laptop still boot very slow. The time to enter the BIOS before go to OS startup is very loooong, There are many people have the same issue like me on Google but there are no truely answer for it. Is there any Lenovo thinkpad expert can help me anwser it ?

- Is replacing the New BIOS make my  lenovo w540 alive and resolve the issue (slooowwwing boot) above? I cost 100$ for this but there is no quaranty for me that it will work.

 

I'm very glad if someone help me answer two questions above.

Have a good day.

 

 

 

 

Check out current deals!


Shop current deals

Top Kudoed Authors