cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
blgaarder
Paper Tape
Posts: 13
Registered: ‎10-15-2012
Location: Saint Paul, MN
Views: 865
Message 1 of 4

No audio on P50 when duplicate display over HDMI

I have connected my P50 with duplicated display over HDMI.

 

I have audio on the HDMI device, but none on the P50.

 

Is there a setting that I have missed?

 

Thanks

SeniorGuru
Posts: 2,131
Registered: ‎06-13-2013
Location: US
Views: 836
Message 2 of 4

Re: No audio on P50 when duplicate display over HDMI

Sound comes out of whatever device you specify as DEFAULT in the "playback devices".  When connecting through HDMI to an audio-enabled display, typically that display device gets set to be the default.

 

But you can change it to be whatever you want... PC speakers, external receiver audio system, HDMI monitor with speakers, or whatever.

 

Right-click on the speaker icon in the notification area, select "playback devices" from popup menu, scroll to see the device you'd like to make the default, select it, and then push SET DEFAULT button.

 

You can then also push the Configure and Properties buttons to further establish things like the audio formats you'd like to support, what to do with multi-channel audio delivered to an external audio system, etc.

 

blgaarder
Paper Tape
Posts: 13
Registered: ‎10-15-2012
Location: Saint Paul, MN
Views: 794
Message 3 of 4

Re: No audio on P50 when duplicate display over HDMI

I guess that my post wasn't clear.

 

I meant to ask how to make audio come from the HDMI port and the PC speakers at the same time.

SeniorGuru
Posts: 2,131
Registered: ‎06-13-2013
Location: US
Views: 784
Message 4 of 4

Re: No audio on P50 when duplicate display over HDMI

Found this recipe on the Internet, but I've not tried it myself.  See if this works for you:

 

  1. Right-click on the speaker icon in System Tray and select Playback Devices
  2. Select Speakers as the default playback device
  3. Click on the "Recording" tab
  4. Right click and enable "Show Disabled Devices"
  5. A recording device called "Wave Out Mix", "Mono Mix" or "Stereo Mix" (this was my case) should appear
  6. Right click on the new device and click "Enable"
  7. Right click on the new device and click "Set as Default Device"
  8. Double click on the new device to open the Properties window
  9. Go to the "Listen" tab
  10. Click on the "Listen to this device" checkbox
  11. Select your HDMI device from the "Playback through this device" list

And you're done.  The drawback is that you won't have a microphone selected as default recording device, but for what concerns you this shouldn't matter.

Check out current deals!


Shop current deals