cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
paa55112
Punch Card
Posts: 59
Registered: ‎01-11-2010
Location: US
Views: 4,078
Message 1 of 4

P50 Display Driver Problem

Does anybody have a recipe to fix: ??

"display driver nvlddmkm has stopped responding and ......."

System uses 6700CPU, M1000M graphics, 32GB, SSD

 

Bios 1.24, graphics driver 10.18.13.5474

 

Thanks

P50 20ENCTO1WW | 6700HQ | 32 GB RAM |M1000M |512 SSD
JDGillis
Bit Torrent
Posts: 3,183
Registered: ‎12-11-2015
Location: US
Views: 4,043
Message 2 of 4

Re: P50 Display Driver Problem

You might try turning off the Windows Fast Startup/Hybrid Boot feature and see if that helps.    

 

  • Open Control Panel.
  • Select "Power Options"
  • Select "What the power buttons do"
  • Select "Change settings that are currently unavailable"
  • Scroll down to Shutdown settings and uncheck "Turn on fast startup"
  • Save changes and reboot to test

Some drivers do not like being resumed, and some have reported that disabling fast startup resolved their issues.

 

If disabling Fast Startup does not work, and the error only occurs when your system is under heavy load, you might try following the steps below that I posed in another thread, which seemed to help somewhat in resolving the error. .

--------------------------

 

The "Display driver stopped responding and has recovered" message is displayed when Windows detects response problems from a graphics card, and recovers to the desktop by resetting the card.  

 

By default, if Windows does not get a response from the graphics card within 2 seconds, it resets the adapter and displays the message.    This could be caused by the system being very busy, low resources or a bad driver,  but you can adjust the "Timeout Detection and Recovery (TDR)" timeout by editing the registry and increasing the TDR timeout to see if doing so will resolve your issue.

 

To Change the TDR for the Graphic adapter, follow the steps below.

 

  • Right click on Start, select Run and in the "Run window", type:  regedit  and press return
  • Double Click to open the hive:   HKEY_LOCAL_MACHINE
  • Double click to open the subkey:   SYSTEM
  • Double click on its subkey:   CurrentControlSet
  • Double click on its subkey:  Control
  • Double click on its subkey:    GraphicsDrivers

The full path being:    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers

 

  • Right Click on Graphic Adapters subkey and select Export, give the file a name such as DefaultGraphicsTDR and save somewhere you can find it.    

Note:  This is just a backup of the current settings that you can import should you make a mistake or want to revert back to the default.     To import, just double click the saved file and follow the prompts, ignoring any "in use" warnings.  

  

  • Now highlight the GraphicsDrivers subkey and in the right pane, look for an existing value called TdrDelay (most likely it will not already exist if still set to default)

If it does exist, Double click on it and change the value to 8  making sure that the Base is set to Decimal

 

If it does not exist, you will have to create the key manually using the steps below

 

  • Right click in a blank area in the right pane and select  New > DWORD (32-bit) Value
  • In the name field in the left pane, type:   TdrDelay    and press enter
  • Now double click on the newly created TdrDelay key, and in the resulting window, enter the value of 8, change the Base from Hexadecimal to Decimal and then press OK

The change will take affect after a reboot.

 

Note:   I created and attached a Set TdrDelay to 8.reg  file that you can import to create the key, and set it to 8 for you if you are not comfortable editing the registry.    I appended.txt to the end of the file within the zipfile to prevent accidental importing, and to allow you to view/edit the contents in notepad before doing so..

If you want to import the file, just edit the filename to remove the .txt, and then double click on Set TdrDelay to 8.reg and follow the prompts to import.

 

Note: you can edit the attached .reg file and change the value to 2 (default) by changing the 8 to a 2 in the line shown below, or just delete the TdrDelay key entirely via regeit.   You can also set a TdrDelay of your choice by editing the line below,  just make sure that the dword value does not exceed 8 characters in length.

 

"TdrDelay"=dword:00000008  

 

paa55112
Punch Card
Posts: 59
Registered: ‎01-11-2010
Location: US
Views: 3,987
Message 3 of 4

Re: P50 Display Driver Problem

Thanks JDGillis,

Didn't work, either one.

I also rolled back the driver to 10.18.13.5445 (Lenovo) from 10.18.13.5474 (NVidia direct) and that didn't help.

It seems to happen consistently after overnight sleep.

P50 20ENCTO1WW | 6700HQ | 32 GB RAM |M1000M |512 SSD
paa55112
Punch Card
Posts: 59
Registered: ‎01-11-2010
Location: US
Views: 3,948
Message 4 of 4

Re: P50 Display Driver Problem

After further searching, this worked for me so far:

 

set NVidia 3D settings power management mode to

"Prefer maximum performance"

P50 20ENCTO1WW | 6700HQ | 32 GB RAM |M1000M |512 SSD

Check out current deals!


Shop current deals

Top Kudoed Authors