Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit our eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

337 Posts

11-13-2010

United States of America

542 Signins

4968 Page Views

  • Posts: 337
  • Registered: ‎11-13-2010
  • Location: United States of America
  • Views: 4968
  • Message 1 of 20

P50 MiniDisplay port is not working consistently on Windows 10

2016-05-06, 0:10 AM

It has been very strange that the DP-port canot recognize my external monitor on Windows 10 after the BIOS upgrade to 1.24 (may be unrelated). It was working before. I am using a DP-VGA adapter, and I was suspecting there is a problem with the adapter. But when I switch to Ubuntu, it works. In Windows 10, the computer screen flashes to black and back when I connect the external monitor to it. But in the display setting, it cannot detect the second monitor. Anyone experiencing similar problem? How can fix this problem? Thanks.

Solved! See the solution
-----------------------------------------------------------------------------
TPs own: X31 (2003), X61T, X200T, Tablet 2, P50 (2016); Win XP-10, Ubuntu8.04-16.04.
Reply
Options

337 Posts

11-13-2010

United States of America

542 Signins

4968 Page Views

  • Posts: 337
  • Registered: ‎11-13-2010
  • Location: United States of America
  • Views: 4968
  • Message 2 of 20

Re: P50 MiniDisplay port is not working consistently on Windows 10

2016-05-07, 22:43 PM

Can anyone who has upgraded to BIOS 1.24 verify that if their DP ports still work to connect to a second monitor? Mine stopped working with a miniDP to VGA adapter on Win 10, but it works in LInux/Ubuntu.

-----------------------------------------------------------------------------
TPs own: X31 (2003), X61T, X200T, Tablet 2, P50 (2016); Win XP-10, Ubuntu8.04-16.04.
Reply
Options

2571 Posts

06-13-2013

United States of America

11142 Signins

60071 Page Views

  • Posts: 2571
  • Registered: ‎06-13-2013
  • Location: United States of America
  • Views: 60071
  • Message 3 of 20

Re: P50 MiniDisplay port is not working consistently on Windows 10

2016-05-08, 1:22 AM

Using "discrete graphics" or "hybrid graphics" in BIOS?

Reply
Options

337 Posts

11-13-2010

United States of America

542 Signins

4968 Page Views

  • Posts: 337
  • Registered: ‎11-13-2010
  • Location: United States of America
  • Views: 4968
  • Message 4 of 20

Re: P50 MiniDisplay port is not working consistently on Windows 10

2016-05-08, 1:27 AM

Hybrid Mode.

-----------------------------------------------------------------------------
TPs own: X31 (2003), X61T, X200T, Tablet 2, P50 (2016); Win XP-10, Ubuntu8.04-16.04.
Reply
Options

2571 Posts

06-13-2013

United States of America

11142 Signins

60071 Page Views

  • Posts: 2571
  • Registered: ‎06-13-2013
  • Location: United States of America
  • Views: 60071
  • Message 5 of 20

Re: P50 MiniDisplay port is not working consistently on Windows 10

2016-05-08, 2:11 AM

Change that to "discrete graphics", and see if that improves things.

Reply
Options

337 Posts

11-13-2010

United States of America

542 Signins

4968 Page Views

  • Posts: 337
  • Registered: ‎11-13-2010
  • Location: United States of America
  • Views: 4968
  • Message 6 of 20

Re: P50 MiniDisplay port is not working consistently on Windows 10

2016-05-08, 10:19 AM

Inspired by you, I have tried a few set of BIOS configurations. Seems Turning Off CSM make the miniDP port work again! I don't understand why though... I will restart and report back if it doesn't persist. Thanks.

-----------------------------------------------------------------------------
TPs own: X31 (2003), X61T, X200T, Tablet 2, P50 (2016); Win XP-10, Ubuntu8.04-16.04.
Reply
Options

337 Posts

11-13-2010

United States of America

542 Signins

4968 Page Views

  • Posts: 337
  • Registered: ‎11-13-2010
  • Location: United States of America
  • Views: 4968
  • Message 7 of 20

Re: P50 MiniDisplay port is not working consistently on Windows 10

2016-05-08, 10:42 AM

I just restarted with the external monitor turned on. The second monitor still works. However, there is one very strange issue:

One software (Docear from http://docear.org)  window becomes pure black when I move the window onto the second monitor. When I tried to make a snapshot to the window, it appears normal in the snapshot picture. It is still black outside of the snapshot region...

 

The fan runs a little noisier in this mode. I hope someone can explain this. Thanks.

-----------------------------------------------------------------------------
TPs own: X31 (2003), X61T, X200T, Tablet 2, P50 (2016); Win XP-10, Ubuntu8.04-16.04.
Reply
Options

2571 Posts

06-13-2013

United States of America

11142 Signins

60071 Page Views

  • Posts: 2571
  • Registered: ‎06-13-2013
  • Location: United States of America
  • Views: 60071
  • Message 8 of 20

Re: P50 MiniDisplay port is not working consistently on Windows 10

2016-05-08, 11:13 AM

Have you tried "discrete graphics" yet? If not, that one really holds the most promise for addressing assorted graphics anomalies.

Reply
Options

2366 Posts

04-20-2008

United States of America

19456 Signins

110626 Page Views

  • Posts: 2366
  • Registered: ‎04-20-2008
  • Location: United States of America
  • Views: 110626
  • Message 9 of 20

Re: P50 MiniDisplay port is not working consistently on Windows 10

2016-05-08, 12:59 PM

CSM is only required if you are booting legacy systems. It is not required for Windows 10. There is a new NVIDIA optimus driver posted as of 4/21/16 which may affect your issue. Have you installed that version as of yet?

 

Update: Corrected the posting date of the Optimus driver.


P53 XEON 2276 BIOS 1.25 OLED UHD 4K Multi-touch display, 96GB RAM, RTX5000, RAID 1, 1TB x 2 Samsung PM981, 1TB PM981, WWAN
P70 XEON 1505, BIOS 2.35, 4k Display, 64GB, M3000M NVIDIA GPU, RAID1 1TB Samsung PM981 PCIe-NVMe SSD x 2, 2x Samsung 850 Pro 1TB SSD. EM7455 WWAN
P1. BIOS 1.25,Xeon Processor, 4k UHD IPS multi-touch display, 32GB, PM981 1TB x 2, RAID1

I am not an employee nor an agent of Lenovo.
Reply
Options

337 Posts

11-13-2010

United States of America

542 Signins

4968 Page Views

  • Posts: 337
  • Registered: ‎11-13-2010
  • Location: United States of America
  • Views: 4968
  • Message 10 of 20

Re: P50 MiniDisplay port is not working consistently on Windows 10

2016-05-08, 20:05 PM

wrote:

Have you tried "discrete graphics" yet? If not, that one really holds the most promise for addressing assorted graphics anomalies.


Yes, I have tried the "discrete graphics" option alone. It works in general, but when the computer wakes up from sleep it cannot recognize the second monitor. So, I tried other combined options. 

 

This morning, I tested again with CSM off and hybrid graphics. The computer wakes up from sleep and it couldn't recognize the second monitor as well. So, CSM is not the cause to fix it. Seems the driver just got weird sometimes. I don't understand why.

-----------------------------------------------------------------------------
TPs own: X31 (2003), X61T, X200T, Tablet 2, P50 (2016); Win XP-10, Ubuntu8.04-16.04.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms