cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
microfishd1
Token Ring
Posts: 265
Registered: ‎02-19-2015
Location: US
Views: 1,042
Message 1 of 2

P50 USB 3.0 Port bug report

Hi all!

I have discovered a problem on/in my P50 with (possibly--more info on why, later)--or at least when connected to--one of the right-hand side USB (3.0) ports. 

I am running a P50 with Win7Pro, BIOS 1.30, 16GB ram, i7-6820hq, etc.  I have not run Lenovo update, so some things are as they came when my laptop was built in mid-October.

 

I plugged an old (2012) USB 3 portable HDD ("Seagate Backup Plus Portable Drive 1TB/TO USB 3.0", Model Number: "STBU1000102" ©2012) in to one of these two ports (not sure just which one because I forgot to look, but one of the ones pictured here).  After a few minutes of copying files off of said external HDD (to the internal drive), my P50 disconnected the drive--while actively transferring files(!), automatically reconnected it, and popped up the autoplay dialog and an error, which I ignored and started copying those files again. 

The problem duplicated itself two more times before I checked it out. (I duplicated the errors with the external HDD in different positions--starting with it lying on the USB cord and changing to laying it completely flat and again with it on end). 

 

Event viewer showed an Event ID 51 code (all three times) stating:

Event ID: 51
Event Type: Warning
Event Source: Disk
Description: An error was detected on device \Device\Harddisk#\DR# during a paging operation

In this case I have forgotten what the Harddisk and DR numbers were and I don't have my P50 handy to check them out.  However, these numbers checked in Disk Management to be my 1TB external HDD.

 

After reading a bit online (where everyone seemed to say "run full chkdsk on it immediately, if not before!!!"), I ran chkdsk (both options selected), and it failed about 5 minutes in (again, Event ID 51 and the generic "Chkdsk failed!" error).  I tried again, with the same results. 

 

This had me worried, so I safely-removed that drive, changed to a new (but supposedly identical) Seagate USB HDD USB3 cable (August 2016), and took the drive to another PC (our H215 tower running Win7 Home Premium--USB 2 ports only).  Once there, I backed up (not moved) about 290GB of data on it (the external HDD) to another external drive, then ran chkdsk on it (both options selected), and it reported that the external HDD was completely and totally fine!

 

>>This is a similar problem to this one, and from what I have read online in various places, it is caused by either the drive or the cable failing or overheating (due to transfer speeds?) despite being rated as USB 3.0, the motherboard, USB (internal) hub, or the drivers.

 

I use this drive every couple of weeks for an hour or so.  It is also where I store most of my pictures (thus the worry mentioned earlier).

The really odd thing is that a couple of weeks before, I had used this drive and P50 to store my Macrium Reflect initial-boot system image and recovery disk ISOs (of this P50 and my brother's P50), and it worked perfectly at the time.  Minutes before, I had backed up our H215 onto it (50 to 100 GB of new data, filling nearly 800GB of the ~960GB total available storage).  I have never had problems before with that external HDD (or since, though I have only used it since on a different PC).

 

My brother also has an identical HDD (black, not blue) and experienced the same problem (only his was while  transferring Macrium files to his external HDD, not files from it) with his a day or two earlier (again, on the side USB 3.0 ports).  He, however, was able to (successfully) use chkdsk when he was plugged into one of the rear ports of his P50 (without swapping cables).  As when I later had the problem, chkdsk reported no errors.

Possibly, this problem happened for us on the P50/USB 3.0 port while transfering large files or large groupings of the same (not small individual files a couple at a time).  However, I transfered the aforementioned 290GB in ~80GB folders (on that H215's USB 2.0 ports).

 

PS: I just (while writing this post) read this thread, which states:

What is happening is that usb3.0 has some power saving mode that lets the hard drive power down.
Here is the fix.
control panel/power options/change plan settings/change advanced power settings/USB settings /USB selective suspend setting
The[n] set the plugged in option to disabled.

 

If that is the problem, it is a relatively simple fix in the Power Manager.  However, Lenovo SHOULD be aware of it and come up with a way to prevent the USB ports from powering down when plugged in--especially when actively transfering files/data!

 

Hopefully some of you fine people can help me narrow down what my problem is, or at least this post can be a help to someone else.

 

Thank you.

-----------IBM T40: XP PRO SP3, 14.1" 4:3 display, 512MB DDR RAM, 40GB HDD, ThinkLight, DVD.
Lenovo Ideacentre H215: AMD Athlon II X2 215, 500GB HDD, 4GB DDR3 RAM, 64-bit Win7, AMD 760G.
P50 i7, M2000M, 1x16GB RAM, 1080p non-touch, 512GB SSD, 500GB HDD, Backlight, No WWAN, No PWM, No Raid.
bmnbmn
Serial Port
Posts: 72
Registered: ‎03-02-2015
Location: US
Views: 987
Message 2 of 2

Re: P50 USB 3.0 Port bug report

microfishd1,

 

I think the problem is much more serious!
Read this my topic on the forum.

I am sure that in the P50 is extremely unsuccessful implementation of the electric power supply to the USB on the motherboard. And it hardly can be corrected in software.

Check out current deals!


Shop current deals

Top Kudoed Authors