cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lwarley
Punch Card
Posts: 13
Registered: ‎05-08-2011
Location: US
Views: 1,324
Message 1 of 7

P50 USB 3.0 side ports don't work

The usb ports on the side of my P50 (not the ones in the back) won't keep contact with any usb device that I plug into them. I've tried external drives, card readers with and without cables, flash drives, different cables, 3.0 and 2.0 devices, etc.

 

I sent it to Lenovo for repair, and they sent it back saying everything was working properly, even though everything is not. Lenovo's tests must not include use cases of actually plugging devices into those drives. 

 

When I plug a device into the side ports, Windows 10 finds it, then loses it, then maybe finds it again, and always loses it again. Sometimes Windows doesn't find it at all. I have plenty of memory and storage, and an i7 processor.

 

Does anyone know of a video on how to replace the side usb's? I can't find one. Any other suggestions? Thanks.

Community SeniorMod
Community SeniorMod
Posts: 9,242
Registered: ‎01-01-2010
Location: US
Views: 1,298
Message 2 of 7

Re: P50 USB 3.0 side ports don't work

In this kind of situation, I prefer to carry the machine into a dealer who does warranty service.  You can then discuss the problem while you are both looking at the same machine.  Any time I send or take a machine for service, I do a full backup in case the OS needs to be reloaded


Rich


I do not respond to requests for private, one-on-one help. Your questions should be posted in the appropriate forum where they may help others as well.

If a response answers your question, please mark it as the accepted solution.

I am not an employee or agent of Lenovo.
SeniorGuru
Posts: 2,239
Registered: ‎06-13-2013
Location: US
Views: 1,275
Message 3 of 7

Re: P50 USB 3.0 side ports don't work


@lwarley wrote:

The usb ports on the side of my P50 (not the ones in the back) won't keep contact with any usb device that I plug into them. I've tried external drives, card readers with and without cables, flash drives, different cables, 3.0 and 2.0 devices, etc.


When I plug a device into the side ports, Windows 10 finds it, then loses it, then maybe finds it again, and always loses it again. Sometimes Windows doesn't find it at all. I have plenty of memory and storage, and an i7 processor.

 

Does anyone know of a video on how to replace the side usb's? I can't find one. Any other suggestions? Thanks.


Have you tried un-checking "allow the computer to turn off this device to save power" on the Device Manager -> Universal Serial Bus Controllers -> USB Root Hub, right-click -> Properties, -> power management tab?  I don't know if this might be related to your symptom, but it might have some effect.

lwarley
Punch Card
Posts: 13
Registered: ‎05-08-2011
Location: US
Views: 1,248
Message 4 of 7

Re: P50 USB 3.0 side ports don't work

Thanks but that didn't help.

lwarley
Punch Card
Posts: 13
Registered: ‎05-08-2011
Location: US
Views: 1,235
Message 5 of 7

Re: P50 USB 3.0 side ports don't work

Here's a workaround: Insert the device only part-way. Worked for me.

 

 https://forums.lenovo.com/t5/ThinkPad-P-and-W-Series-Mobile/P50-USB-Ports-and-External-Hard-Drives/m...

mdamda
Punch Card
Posts: 22
Registered: ‎11-18-2016
Location: PH
Views: 1,193
Message 6 of 7

Re: P50 USB 3.0 side ports don't work

Glad I was able to help someone.

 

It may differ with your case, but I noticed that inserting the drives only halfway would stunt the transfer speeds. I was worried at this point that I'd get data corruption as well.

 

Eventually had to send the machine in for service. I got back a new system board wherein one out of two right side ports would work reliably with USB 3.0 devices without having to plug the drives in halfway.

 

The other port would always work with USB 3.0 devices immediately after a reboot but would stop recognizing them after a few hours of uptime.

 

I was generally accepting of this 'compromise' until the rear USB port gave out...

mdamda
Punch Card
Posts: 22
Registered: ‎11-18-2016
Location: PH
Views: 880
Message 7 of 7

Re: P50 USB 3.0 side ports don't work

Hello all.

 

Just a quick update from 2018.

 

I'm already on my 4th or 5th motherboard (frankly, I can no longer remember), and still running into problems with my USB side ports and ALL usb 3.0 devices tested. ALL USB 2.0 devices have no problems on these ports.

 

I would have lived with this problem if USB3 drives will only run at USB2 speed in the 2 side ports, but the problem is they do not detect at all! Rear ports, as always, have always worked fine.

 

I can't keep going back to the service center, waiting weeks, and having the board replaced only to come up with the same issue again. Is there any way to escalate this?

 

The service center can only do so much, and the phone and chat support just tell me to go to the service center.

 

It's a great machine and all, but 1000+++$ for a laptop whose features are half working is crazy in 2016.

Check out current deals!


Shop current deals

Top Kudoed Authors