English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

7 Posts

05-09-2017

GB

16 Signins

61 Page Views

  • Posts: 7
  • Registered: ‎05-09-2017
  • Location: GB
  • Views: 61
  • Message 1 of 16

P51 legacy boot issues

2017-05-09, 9:14 AM

We've got a couple of P51s delivered and having issues using legacy boot mode with Windows 10.

 

They both have NVME drives and Windows 10 installer refuses to install to the drive as it says the BIOS doesn't support them.

 

Any ideas or is it an issue with the particular NVME drives?

Reply
Options

699 Posts

01-14-2014

US

1919 Signins

13419 Page Views

  • Posts: 699
  • Registered: ‎01-14-2014
  • Location: US
  • Views: 13419
  • Message 2 of 16

Re: P51 legacy boot issues

2017-05-09, 13:24 PM

Did you happen to change the system BIOS to Legacy mode? 

 

To do so, go into BIOS F1 setup -> tab over to the "Restart" menu tab option at the top -> scroll down to "OS Optimized Defaults" and set that option to "Disabled". Then, select F9 to setup defaults and F10 to save and exit. 

Reply
Options

7 Posts

05-09-2017

GB

16 Signins

61 Page Views

  • Posts: 7
  • Registered: ‎05-09-2017
  • Location: GB
  • Views: 61
  • Message 3 of 16

Re: P51 legacy boot issues

2017-05-09, 14:50 PM
Yes, I have tried changing all of those settings.
Reply
Options

699 Posts

01-14-2014

US

1919 Signins

13419 Page Views

  • Posts: 699
  • Registered: ‎01-14-2014
  • Location: US
  • Views: 13419
  • Message 4 of 16

Re: P51 legacy boot issues

2017-05-09, 15:24 PM

I think I'm seeing what you're seeing when I try to install Windows 10 in "Legacy only" mode.  

 

Here's what you can do: 

 

1. Go into BIOS F1 setup -> "Restart" menu tab -> Set "OS Optimized Defaults" to "Disabled.

2. Press F9 to Setup Defaults. 

3. Tab over to the "Startup" menu tab and verify the following settings:

- "UEFI/Legacy Boot" set to [Both]

- "UEFI/Legacy Boot Priority" set to [UEFI First]

- "CSM Support" set to [Yes]

4. Press F10 to Save and Exit the BIOS. 

5. Boot to the Windows 10 installation media. In my case, I'm using a CD/DVD to USB. 

6. Windows 10 should then see your NVMe drive and be able to install the OS cleanly. 

 

 

Reply
Options

7 Posts

05-09-2017

GB

16 Signins

61 Page Views

  • Posts: 7
  • Registered: ‎05-09-2017
  • Location: GB
  • Views: 61
  • Message 5 of 16

Re: P51 legacy boot issues

2017-05-09, 15:33 PM

I think the point I'm trying to make is that the legacy boot mode is broken. You can't install Windows 7 (not that I'd expect that to work) or Windows 10 (via MDT or USB install) with legacy mode enabled.

Reply
Options

699 Posts

01-14-2014

US

1919 Signins

13419 Page Views

  • Posts: 699
  • Registered: ‎01-14-2014
  • Location: US
  • Views: 13419
  • Message 6 of 16

Re: P51 legacy boot issues

2017-05-09, 15:55 PM

For NVMe drives, Windows (7 or 10) needs to create a GPT partition on the drive.  You should still be able to boot a GPT partition in Legacy boot mode once the installation is completed.  

Reply
Options

7 Posts

05-09-2017

GB

16 Signins

61 Page Views

  • Posts: 7
  • Registered: ‎05-09-2017
  • Location: GB
  • Views: 61
  • Message 7 of 16

Re: P51 legacy boot issues

2017-05-10, 14:32 PM
IT doesn't work either way, regardless of partition type. With a GPT partition it says it can't be installed to a GPT partition and that the BIOS doesn't support it, and with MBR you just get the BIOS error.
Reply
Options

699 Posts

01-14-2014

US

1919 Signins

13419 Page Views

  • Posts: 699
  • Registered: ‎01-14-2014
  • Location: US
  • Views: 13419
  • Message 8 of 16

Re: P51 legacy boot issues

2017-05-10, 15:47 PM

If you follow these steps (highlighted above), then you CAN get a Windows 10 retail image to load on an NVMe drive on the P51 laptop.  

 

Here's what you can do: 

 

1. Go into BIOS F1 setup -> "Restart" menu tab -> Set "OS Optimized Defaults" to "Disabled.

2. Press F9 to Setup Defaults. 

3. Tab over to the "Startup" menu tab and verify the following settings:

- "UEFI/Legacy Boot" set to [Both]

- "UEFI/Legacy Boot Priority" set to [UEFI First]

- "CSM Support" set to [Yes]

4. Press F10 to Save and Exit the BIOS. 

5. Boot to the Windows 10 installation media. In my case, I'm using a CD/DVD to USB. 

6. Windows 10 should then see your NVMe drive and be able to install the OS cleanly. 

Reply
Options

7 Posts

05-09-2017

GB

16 Signins

61 Page Views

  • Posts: 7
  • Registered: ‎05-09-2017
  • Location: GB
  • Views: 61
  • Message 9 of 16

Re: P51 legacy boot issues

2017-05-11, 10:09 AM
We need to use legacy boot though, not uefi mode. All previous models (including the P50) worked fine like this. If this doesn't work then it begs the question what use (if any) having the legacy mode in the bios actually is?
Reply
Options

7 Posts

05-09-2017

GB

16 Signins

61 Page Views

  • Posts: 7
  • Registered: ‎05-09-2017
  • Location: GB
  • Views: 61
  • Message 10 of 16

Re: P51 legacy boot issues

2017-05-15, 8:35 AM
So is there no solution to this? Maybe the BIOS needs sorting?
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete