English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

63 Posts

12-10-2018

SG

779 Signins

3597 Page Views

  • Posts: 63
  • Registered: ‎12-10-2018
  • Location: SG
  • Views: 3597
  • Message 1 of 19

P53 not working with ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but works fine on my X1E

2019-12-21, 15:16 PM

Hi,

My recently bought P53 can't seem to connect with my ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but when the dock is connected to my X1E everything works fine, I've double checked all the connections and nothing is wrong and had also updated the dock firmware to the latest version but still no go when connected to my P53, has anyone faced similar issues?

 

1) Connecting my monitor directly to the P53 thunderbolt 3 port via USB-C works, so that rules out the possibility a faulty thunderbolt port on my P53.

 

2) Connecting my dock to the X1E works so that rules out the possibility of a faulty dock.

 

Any help would be appreciated.

 

Rdgs

Reply
Options

25 Posts

10-05-2019

DK

52 Signins

394 Page Views

  • Posts: 25
  • Registered: ‎10-05-2019
  • Location: DK
  • Views: 394
  • Message 2 of 19

Re: P53 not working with ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but works fine on my X1

2019-12-23, 23:24 PM

Did you by any change install Nvidia drivers from Nvidias website, selecting the full package?

 

Uninstall all of you Nvidia programs, and see how it goes. Let the P53 boot up only with the monitors connected, make sure you have the dock connected in the thunderbolt control center, and connect the usb devices aftewards.

 

ONLY install the display drivers from Nvidias website, if you wish a more recent version than the one from Lenovo (not old though, but it's missing some settings).

Reply
Options

63 Posts

12-10-2018

SG

779 Signins

3597 Page Views

  • Posts: 63
  • Registered: ‎12-10-2018
  • Location: SG
  • Views: 3597
  • Message 3 of 19

Re: P53 not working with ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but works fine on my X1

2019-12-26, 15:24 PM

Just an update, managed to narrow down to the issue being the display output on the dock itself, not sure if this is a bug or what, hopefully there would be a firmware update coming up.

 

Reply
Options

25 Posts

10-05-2019

DK

52 Signins

394 Page Views

  • Posts: 25
  • Registered: ‎10-05-2019
  • Location: DK
  • Views: 394
  • Message 4 of 19

Re: P53 not working with ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but works fine on my X1

2019-12-27, 1:27 AM

I'm having so many issues with my TB3 Workstation dock. Is so unstable both with my USB and very much my monitors.

 

I just swapped monitor from an Asus 144hz to a LG 27GL850 144hz, but it can only do 120hz through the dock. I've tried different DP 8K cables and HDMI 2.1.

When I connect it directly I get 144hz.

 

Also my secondary monitor - an Eizo 2730CG has lost its connection completly through the dock. The laptop sees it, but I get NO picture - it simply goes to sleep. It happend after I turned the monitor off one night, as I only needed the LG.

 

This dock needs a seriously firmware upgrade ASAP!

 

I'm on a P53, i9, RTX4000.

Reply
Options

25 Posts

10-05-2019

DK

52 Signins

394 Page Views

  • Posts: 25
  • Registered: ‎10-05-2019
  • Location: DK
  • Views: 394
  • Message 5 of 19

Re: P53 not working with ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but works fine on my X1

2019-12-27, 12:53 PM

Post 1 from Reddit:

I got my new LG 27GL850 yesterday, and have since tried to get it running at 144hz. But it will only do 120 hz.

 

Running 144 hz just makes it go 'out of syn' with a picture you cant use at all.

 

\- I used the DP cable that came with the monitor

 

\- I used the HDMI cable that came with the monitor

 

\- I tried another 8K 1.4 displayport cabel

 

\- I installed the LG OnScreen Control version 4.43 and updated the monitor to 3.0.7. It now says there's a version 3.13, but when I press update it says "Current version is latest software". 

 

\- I installed the Windows driver from the website LG (06/11/2019,1.0)

 

I'm on Windows 10, 1909. Using a Quadro RTX 4000 (driver 26.21.14.3140).

 

Post 2 from Reddit:

I installed the latest Nvidia 441.66 ODE (2019.12.10) which was actually newer than the QNF driver version 436.30 (2019.9.10). But this really killed my Lenovo P53 and I had no image on any of my monitors, the laptop started to lag and I lost connection to all USB devices.

I'm connected through a Lenovo Thunderbolt 3 Workstation dock.

I had to do a 'revert to previous state' on my Windows to get the monitors up'n'running. Or at least this was my approach to try and return to something that was compatible with the dock.

Lesson to be learned; ONLY install the Display drivers, and leave everything else OFF.

As I still couldn’t get 144 hz running, I used the DDU tool as advice. I both swiped Intel and Nvidia drivers, though I have only enabled the RTX4000 in the BIOS.

I afterwards added the monitor drivers to the laptop, LG and Eizo monitors. After a reboot I was back at the Nvidia 26.21.14.3140 “from Lenovo”. Still no image on 144 hz.

So I went for another try, and installed the Nvidia 441.66 but only the display drivers this time. It seems I have more settings now in the Nvidia control panel (setting depth and dynamic range), but no matter what settings i use on the LG 27GL850, the maximum is still only 120 hz.

Just to clarify - I can select 144 hz, but the image is all teared apart.

So:
- firmware done
- clean nvidia drivers done
- 4 cables tried (both DP and HDMI)
- dp 1.4 enabled in the OSD settings

 

....... As I wrote above, all of the issues fall back to the unstable dock

Reply
Options

2361 Posts

04-20-2008

US

19363 Signins

110121 Page Views

  • Posts: 2361
  • Registered: ‎04-20-2008
  • Location: US
  • Views: 110121
  • Message 6 of 19

Re: P53 not working with ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but works fine on my X1

2019-12-28, 14:12 PM

Just a thought here, but the dock supports a refresh rate of 60Hz x the resolution of the monitor. It's possible that 144hz x monitor resolution exceeds the pixel rate of the dock ports. There is a support matrix in the workstation dock documentation for the monitor configurations allowed. All of the permissible configurations show no more than 60Hz / monitor for 1.


P53 XEON 2276 BIOS 1.23 OLED UHD 4K Multi-touch display, 96GB RAM, RTX5000, RAID 1, 1TB x 2 Samsung PM981, 1TB PM981, WWAN
P70 XEON 1505, BIOS 2.35, 4k Display, 64GB, M3000M NVIDIA GPU, RAID1 1TB Samsung PM981 PCIe-NVMe SSD x 2, 2x Samsung 850 Pro 1TB SSD. EM7455 WWAN
P1. BIOS 1.25,Xeon Processor, 4k UHD IPS multi-touch display, 32GB, PM981 1TB x 2, RAID1

I am not an employee nor an agent of Lenovo.
Reply
Options

25 Posts

10-05-2019

DK

52 Signins

394 Page Views

  • Posts: 25
  • Registered: ‎10-05-2019
  • Location: DK
  • Views: 394
  • Message 7 of 19

Re: P53 not working with ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but works fine on my X1

2019-12-28, 17:28 PM

I'll dive into the that aspect, thanks. The Asus was a 1080p/144hz (did work at 144hz) as the new LG is a 1440p/144hz.

 

This however doesn't explain the monitors not getting any signal, and simply just powers off. This at the same time, as the P53 shows them connected.

 

My Eizo monitor is a professional 1440p/60hz photographer monitor.

Reply
Options

412 Posts

07-08-2019

CA

559 Signins

7303 Page Views

  • Posts: 412
  • Registered: ‎07-08-2019
  • Location: CA
  • Views: 7303
  • Message 8 of 19

Re: P53 not working with ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but works fine on my X1

2019-12-28, 19:44 PM
Hi!
You should get the monitor support department involved. Nowadays, a monitor is a mini computer shuffling bits around, unlike the CRT era where everything was analog.

In those days, the micro-controller was only for OSD, not much else!

If you search this forum, you will find that some monitors have issues, and since they have firmware, the issue could be a mis-behaving monitor, not dock. The best option is to have both Lenovo and the monitor manufacturer talking to each other.

It SHOULD work, but in the end, they should fix it. You didn't design the devices after all...

Of course, that's only my humble opinion,
Martin

Using Browser Search to find your answers in Lenovo and Moto Community

I'm a volunteer, NOT a Lenovo employee.
If I solved your issue, please click Accept as a Solution.
If my post helped, consider giving me a Thumbs Up.

Main: P52 (I7-8750H P1000 FHD 16GB 2TB-SSD 1TB-HDD)
Also, 2x M820z, 1x P520c, 1x ideaCentre 300S-11IBR

Reply
Options

25 Posts

10-05-2019

DK

52 Signins

394 Page Views

  • Posts: 25
  • Registered: ‎10-05-2019
  • Location: DK
  • Views: 394
  • Message 9 of 19

Re: P53 not working with ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but works fine on my X1

2019-12-30, 9:38 AM

For some reason my last post didn't go through.

I get a MCU version reading fail when I try to update with this firmware:

https://pcsupport.lenovo.com/us/en/downloads/DS505188

 

Thinkpad Thunderbolt 3 dock FW utility V2019.11.20.2
Firmware package version: 3.1.65.0
===================================================================
Date: 2019/12/30
Time: 10:36:42
Initializing...

MAC Address = 3C-E1-A1-BA-3E-65

Firmware package version: 3.1.65.0
Reading version from chip...

MCU version reading fail
MCU version reading retry times =1
MCU version reading fail
MCU version reading retry times =2
MCU version reading fail
MCU version retry fail!
Check version fail, error code=0x8002

 

------------------------------------------------------------------------------------

 

Heres is the debug log of my fw update:

https://pastebin.com/PvNgEWTH

 

More links to Lenovo docks: https://support.lenovo.com/ng/da/solutions/migr-4tpjf4

 

------------------------------------------------------------------------------------

Pixel counts

 

The dock supports

3840 x 2160 x 60 = 497.664.000

2 x 497.664.000 = 995.328.000

I have

2560 x 1440 x 144 = 530.841.600

2560 x 1440 x 60 = 221.184.000

In total 752.025.600

 

So the dock shouldn’t be limited by pixel count.

 

My biggest issues is that, when I have a monitor connected to the P53’s HDMI (directly into the laptop) I get NO output from any of the DP ports in the dock.

Reply
Options

63 Posts

12-10-2018

SG

779 Signins

3597 Page Views

  • Posts: 63
  • Registered: ‎12-10-2018
  • Location: SG
  • Views: 3597
  • Message 10 of 19

Re: P53 not working with ThinkPad Thunderbolt 3 Workstation Dock (Type 40AN) but works fine on my X1

2019-12-30, 12:33 PM

You need to disconnect all peripherals from the dock and keep it connected to the notebook/pc during updating.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete