cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sibi
Paper Tape
Posts: 4
Registered: ‎06-16-2009
Location: Germany
Views: 5,885
Message 1 of 15

Problem with numeric keypad when holding down keys

Hello,

 

I am having the following problem with my new W700DS:

The numeric keypad (numpad) works fine except for the fact that it only accepts a total of four (4) keystrokes when pressing down a key. This behaviour may be wanted when using it with numlock=on, so that you dont enter the same number too often by mistake, but when having numlock=off, i do not want the arrow keys or home/end/pgup/pgdn/ins/del to just work 4 times when pressing them down and holding them, but as long as i do so. Especially the cursor keys on the numpad are useless when they stop working after being pressed long enough so that four keystrokes were sent to the OS. After that, you have to release the key, and press it down again, which is annoying.

 This problem (or is it intended behaviour even?) occurs under Windows 7 as well as Windows Vista on two different W700DS notebooks.

All drivers were installed, no unknown devices in the device manager listed.

All the other keys on the keyboard work fine, just the ones on the numpad are affected.

 

Can anyone confirm this behaviour (keystrokes on numpad not being repeated after 4th time) or even know a solution ?

 

Thanks in advance

 

Simon 

 

 

barrywohl
Punch Card
Posts: 31
Registered: ‎11-15-2008
Location: Sheridan, WY
Views: 5,866
Message 2 of 15

Re: Problem with numeric keypad when holding down keys

I never would have noticed, but mine does something similar.  Holding down a number key on the number pad, I get three of the same character and then nothing more.

 

W700 Vista Ultimate x64

 

Barry

PanEuropean
RAID Mirror
Posts: 488
Registered: ‎02-17-2009
Location: Vancouver Island
Views: 5,854
Message 3 of 15

Re: Problem with numeric keypad when holding down keys

Hi Simon:

 

I think that the unwanted behaviour that you are encountering is a "feature" of the operating system that is intended to make the computer easier to use for disabled people. 

 

It is called "Sticky Keys", and you can turn this "feature" (this PITA) off by doing the following:

 

1) Go to the Control Panel and then select "Ease of Access Center".

 

2) Select the choice entitled "Make the Keyboard Easier to Use" (there is a certain amount of irony in that title).

 

3) Make sure that the box "Turn on Sticky Keys" is NOT checked.

 

You are not the first person to get caught by this "feature", so don't feel bad.  There is nothing wrong with your computer, it sounds like you have just accidentally activated the sticky key feature - perhaps by holding the shift key depressed for a long period of time.

 

Michael

W520 (4270 CTO), which replaced a W500 (4062-27U), which replaced a T42P, which replaced an A21P...
barrywohl
Punch Card
Posts: 31
Registered: ‎11-15-2008
Location: Sheridan, WY
Views: 5,851
Message 4 of 15

Re: Problem with numeric keypad when holding down keys

Michael, thank you for posting here, but that doesn't work, at least on my W700 with Vista Ultimate x64.  I went to keyboard ease of use as you suggested and sticky keys was unchecked.

 

Although I never noticed it before, the Numlock toggle on the ScrLk/NumLk key toggles the Numlock light on and off but does not affect the function of the number keypad on the main keyboard.  That is to say, the U, I O, J K.L, and M keys keep their alpha functions no matter what the NumLock toggle status.  That is fine with me, and I'm glad to have a generic keyboard replacement for the W700 when I need one, but it does mean that those keys are "mislabeled" as far as their W700 use.

 

Barry

PanEuropean
RAID Mirror
Posts: 488
Registered: ‎02-17-2009
Location: Vancouver Island
Views: 5,836
Message 5 of 15

Re: Problem with numeric keypad when holding down keys

Hi Barry:

 

There is a setting in the BIOS that addresses the issue of converting numberlock settings across reboots when you are using an external keyboard and when you are using the built-in keyboard.  I think one of the possibilities is disabling the number lock key, but I am not totally sure about that.

 

You could go in there and hunt that setting down yourself, but probably the easiest way to see if this is where the fix lies would be to reset the BIOS to the factory defaults and see if that solves the problems.

 

Michael

W520 (4270 CTO), which replaced a W500 (4062-27U), which replaced a T42P, which replaced an A21P...
barrywohl
Punch Card
Posts: 31
Registered: ‎11-15-2008
Location: Sheridan, WY
Views: 5,831
Message 6 of 15

Re: Problem with numeric keypad when holding down keys

I looked in the W700 BIOS and found a setting for the keyboard of "independent" vs "synchronized."   "Independent" is the default but if you choose "synchronized," you get a new menu for "auto" or "on" or "off" for whether or not to permit the local keyboard "numlock."

 

However, none of these settings seem to do anything for my W700 numlock.  Here's how it works.  The "Numlock" on the number pad toggles the number pad between numbers and arrows.  It also toggles on and off the "numlock" indicator below the screen.

 

The "numlock" that shares the "scroll lock" key does nothing.  The letter/number keys  never switch to numbers.  None of the BIOS settings affect these behaviors.  

 

This is interesting, and probably the best choice possible.  I wonder what would happen if I left the number pad disconnected from the computer's mother board.

 

By the way, none of these are problems for me.

Highlighted
sibi
Paper Tape
Posts: 4
Registered: ‎06-16-2009
Location: Germany
Views: 5,805
Message 7 of 15

Re: Problem with numeric keypad when holding down keys

Thanks for all the suggestions so far, but none has helped with my specific "problem".

The "sticky-keys" feature was interesting to find, I had not know there were that many different settings.

They are named differently in my german version of Windows 7, but none of them seemed to related especially to the numpad.

Noteworthy may be the time it takes an up-to-date System with a quadcore CPU to change a simple keyboard setting - way to long Smiley Happy

 

I havent tried any BIOS settings yet, but I somehow doubt it will work.

oliver_71
Paper Tape
Posts: 20
Registered: ‎06-07-2009
Location: Germany
Views: 5,597
Message 8 of 15

Re: Problem with numeric keypad when holding down keys

Hi there,

 

we have the same "repeat problem" with the W700 (with XP professional, also with vista). Any solutions yet?

 

 

 

sibi
Paper Tape
Posts: 4
Registered: ‎06-16-2009
Location: Germany
Views: 5,340
Message 9 of 15

Re: Problem with numeric keypad when holding down keys

I submitted a support request to the official support a few days ago and it turns out that the "bug" is a "feature" instead and they can not (or do not want to ?) do anything about it.

 

My support ticket has been closed as "successfully solved".

 

After this encouraging encounter with the service hotline I decided to fix it myself and came up with the following small tool:

 

http://www.cosy-systeme.com/tools/NumpadFix.zip

 

Feel free to try it if you are as annoyed with this "feature" as I am.

dvlpr
Paper Tape
Posts: 2
Registered: ‎11-11-2009
Location: Melbourne, Australia
Views: 4,980
Message 10 of 15

Re: Problem with numeric keypad when holding down keys

Thanks for the tool - makes life a bit easier Smiley Happy Of course ideally Lenovo should fix this stupid bug on their side.

Check out current deals!


Shop current deals

Top Kudoed Authors