Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

52 Posts

09-22-2012

Greece

78 Signins

638 Page Views

  • Posts: 52
  • Registered: ‎09-22-2012
  • Location: Greece
  • Views: 638
  • Message 1 of 4

Problems on Windows 8 boot logo & Grub-EFI boot loader & BIOS ACCESS

2013-09-03, 10:29 AM

Hello everyone,

 

I have a problem with Lenovo Thinkpad W520 (4270CTO). My laptop has a maximum screen resolution of 1920x1080.

 

 

When I first installed Windows 8 Pro (64bit) (UEFI installation) the boot logo screen during the very first run was in 1920x1080 for a couple of seconds later though it changed in very low resolution.I can't tell how much,but it is very low.

Almost the same thing happened when I instaled Ubuntu and I started using the GRUB-EFI loader instead of the Windows 8 bootloader.The resolution on GRUB-EFI is very low.I tried to change the settings in /etc/default/grub file and after that I ran sudo update-grub, but nothing happened.

 

Another problem is that although my installation is a UEFI installation there is no option to access the BIOS from Windows 8.I am referring to the option which appears when you go to "Change PC Settings" -> "General" on the section which says: "Advanced Startup" below that title it has a button which says "Restart now". Press that and a blue screen will show.The press the "Advanced setup" option and you will be transferred in another submenu.In this submenu there should be an 6 options and one of the should be about accessing the BIOS.

 

Please mind that I have the latest BIOS version which I think is the 1.42.

 

Any help is appreciated.

 

Here are few screenshots.

 

I hope they are helpful.(Sorry for the bad image quality)

 

php3EfOHUAM.jpgphpekXXT0AM.jpgphpWIf2IQAM.jpg

 

php1v1U46AM.jpg

 

 

Lenovo ThinkPad W520 (4270 CTO)
Reply
Options

6915 Posts

10-29-2009

United States of America

17805 Signins

165914 Page Views

  • Posts: 6915
  • Registered: ‎10-29-2009
  • Location: United States of America
  • Views: 165914
  • Message 2 of 4

Re: Problems on Windows 8 boot logo & Grub-EFI boot loader & BIOS ACCESS

2013-09-03, 19:28 PM

Although W520 has UEFI capability, it is UEFI spec version 2.0

Windows 8 requires UEFI 2.3.1, for advanced UEFI features like rebooting into firmware/BIOS setup.  There is no possibility to retrofit UEFI 2.3.1 onto W520.  Keep in mind that W520 is 2011 system and Windows 8 came later.

 

I have no idea about boot loader resolution problem.

Reply
Options

52 Posts

09-22-2012

Greece

78 Signins

638 Page Views

  • Posts: 52
  • Registered: ‎09-22-2012
  • Location: Greece
  • Views: 638
  • Message 3 of 4

Re: Problems on Windows 8 boot logo & Grub-EFI boot loader & BIOS ACCESS

2013-09-03, 19:40 PM

Thank you very much for your reply.

 

 

So I guess UEFI is pretty much useless on W520 right?

Lenovo ThinkPad W520 (4270 CTO)
Reply
Options

6915 Posts

10-29-2009

United States of America

17805 Signins

165914 Page Views

  • Posts: 6915
  • Registered: ‎10-29-2009
  • Location: United States of America
  • Views: 165914
  • Message 4 of 4

Re: Problems on Windows 8 boot logo & Grub-EFI boot loader & BIOS ACCESS

2013-09-04, 0:36 AM

fasdf78 wrote: 

So I guess UEFI is pretty much useless on W520 right?


That's my personal opinion about it.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms