cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Guru
Posts: 1,802
Registered: ‎04-20-2008
Location: US
Views: 3,007
Message 1 of 3

SIM card size for P70 WWAN (EM7455)

I am installing an EM7455 WWAN card in my P70. The User Guide states that the SIM used by the system is a Micro-card. When I called Verizon Wireless to obtain a 4G-LTE card, they could not find the P70 in their database. However, they said they knew the size and shipped me a SIM card. Unfortunately, it was the incorrect SIM-card size (apparently there are multiple) so I have to obtain the correct card from a Verizon store when the WWAN arrives from China. The model number of the card needs to end in 3FF-A. It would have been really convenient if the Verizon SIM card was orderable on the Lenovo website at the same time as I ordered the EM7455 from the Accessories storefront.

 

 


P70 XEON 1505, BIOS 2.30, UHD 4k Display, 64GB non-ECC RAM, M3000M NVIDIA GPU, RAID 1 512GB Samsung 951 PCIe-NVMe SSD x 2, 2x Samsung 850 Pro 1TB SSD. EM7455 WWAN
P1. BIOS 1.22,Xeon Processor, 32GB, PM981 1TB x 2, RAID 1
T470s, 16GB RAM, BIOS 1.10, i7-7500, WQHD display, 512GB PM961 PCIe NVMe SSD
Tresuno
Punch Card
Posts: 40
Registered: ‎11-09-2015
Location: AT
Views: 2,896
Message 2 of 3

Betreff: SIM card size for P70 WWAN (EM7455)

I own an W541 with WWAN and this omputer uses Standard SIM card size.

Just check the slot when you remove the battery of your device, here you can see the size - you dont have to wait for the module, because the card is placed into the ThinkPad.

Mybe Verizon did a mistake, because there exists also a Lenovo P70 smartphone.

Lenovo W541, Samsung SSD 850 EVO 1 TB, Sierra Wireless EM7345
Guru
Posts: 1,802
Registered: ‎04-20-2008
Location: US
Views: 2,871
Message 3 of 3

Re: SIM card size for P70 WWAN (EM7455)

Update: The correct SIM size is a Micro-SIM card which I've now installed in the P70.

 

I've also received the EM7455 card and installed it into the P70 as well.  However, I've been unable to attach the AUX antenna wire to the card (the MAIN antenna attached fine). I've received a replacement card, but the issue persists. I have an on-site service call scheduled, but there are no parts available to replace the card so I will have to wait before activation. I think that the issue is that the connector on the AUX wire is too tight and I just can't get it to snap onto the WWAN card terminal.


P70 XEON 1505, BIOS 2.30, UHD 4k Display, 64GB non-ECC RAM, M3000M NVIDIA GPU, RAID 1 512GB Samsung 951 PCIe-NVMe SSD x 2, 2x Samsung 850 Pro 1TB SSD. EM7455 WWAN
P1. BIOS 1.22,Xeon Processor, 32GB, PM981 1TB x 2, RAID 1
T470s, 16GB RAM, BIOS 1.10, i7-7500, WQHD display, 512GB PM961 PCIe NVMe SSD

Check out current deals!


Shop current deals

Top Kudoed Authors