Showing results for 
Search instead for 
Do you mean 

Solutions for CapsLock / NumLock indicator always show on the screen when enabled

Helpful? Click ►
Started ‎04-09-2012 by
Modified ‎04-09-2012 by

Solutions for CapsLock / NumLock indicator always show on the screen when enabled

by on ‎04-09-2012 05:32 AM (60,463 Views)


Some of my friends using ThinkPads and realize when the numeric lock or caps lock is ON and the indicator would just stay there for a long time. Is there anyway to have the indicators display for a few seconds instead of staying there for a long time?


May apply to most ThinkPad with newer version of On-screen display.


For those who wants to prevent the indicator to always show on the screen when CapLock / NumLock is On or Off, at the Desktop, right-click and go to Screen Resolution, click Advanced Settings, go to the On Screen Display tab, ensure Show the indicator for a few seconds are selected for both While the numeric lock or the caps lock is ON / OFF.


Fanfold Paper

I do not get the CapsLock indication on screen. I tried this solution, but I do not have the onscreen display option itself. My laptop is E430 operating on Windows 7 Pro. Please advise

What's DOS?
w540 - working like a charm

How are the indicators controlled indepenently?


I want to have caps lock icon ON when caps lock is activated, but the lum lock icon OFF when num lock is activated.

What's DOS?

Same qustion as above: How to handle the caps lock and num lock independently?


On my E431, I need Caps Lock visible when Caps Lock is ON (and does not show it when it is OFF). I don't want this feature for Num Lock since this lap does not have Number Keyboard. Unfortunately when I do this for getting Caps Lock ON displayed always, the Num Lock HID is also getting displayed permanently. Smiley Indifferent


Paper Tape

This saved me so much heartache on our like a charm!

Token Ring
Ya, right, . . . but maybe there should be a light under the CapsLock and NumLock keys like the one under the Fn key.... Which is a waste, as it's on all the time when in the NORMAL F1-12 function. Ummm??? In fact the light should be on, when using the special Lenovo assigned functions. It's reverse thinking. Another workaround for a workstation,
Punch Card

I just did an update that defaulted the numlock indicator on, all the time.

In all the things I have to do this morning, I had to fix it.

Please, stop it!


I am starting to think that the computer user experience has past its prime.