Showing results for 
Search instead for 
Do you mean 
Serial Port
Posts: 35
Registered: ‎03-30-2009
Location: St Johns, FL
Message 1 of 3 (1,628 Views)

Suddenly OS can't see fingerprint reader (w500)

[ Edited ]

I've got a a w500 with three OS' installed: Windows 7 x64 (native, bare metal), Windows 2008 R2 (native, bare metal) and Windows 7 x64 (boot to VHD). All have had the latest drivers installed (via System Manager v4)... all have had the fingerprint software installed and I've had fingerprints enrolled and working for login and password manager purposes for months.


Last night I logged into the Win7 VHD for the first time in a while and ran a Windows Update which updated it to the latest AuthenTec driver (which the other two OS' have been running for months... v8.1.2.56 dated 7/7/2009). After rebooting to either of the other OS', I can no longer login using my fingerprint... I get an error about "Computer name is invalid." After logging in with my AD domain password, I see no fingerprints enrolled. WHen I try to enroll, it says it can't communicate with the device. When I try to login to the password manager, it says it can't communicate with the device. I can't even import fingerprints (from my x200s that is working just fine with the same drivers).


Looking in the error logs, I can't see anything that reports an error. Device manager shows all devices working properly... not sure how I can go about troubleshooting this. If all OS's were working and now suddenly all aren't when one was updated, I'm wondering if the actual device had some hardware reset (like a biometric firmware update hidden in the AuthenTec update?).



ThinkPad w520 | Intel i7 2.5Ghz | 2x 512GB Crucial SSD | 16GB | NVIDIA GeForce Quadro 2000M 2GB | 6.9 Windows Exp Index
Ultrabay DVD + modular Ultrabay 256GB Crucial SSD SATA
Win7 Ultimate x64 | Windows Server 2008 R2 | Win8 Release Preview

ThinkPad x200s | Core2 Duo 1.86 | 256GB Crucial SSD | 4GB | Intel Mobile Chipset Video | 3.4 Windows Exp. Index
Win7 Ultimate x64 | Windows Server 2008 R2
Posts: 9
Registered: ‎05-27-2009
Location: cyprus
Message 2 of 3 (1,095 Views)

Re: Suddenly OS can't see fingerprint reader (w500)

I have the same problem .. Can anyone assist?


I have my W500 running windows 7 32 bit . Suddenly the sensor stop working , and  in control panel when i tried to check fingerprint i get the message can not communicate with sensor ?


is that a hardware or software problem?


I have uninstall and reinstall driver (first time with download and second time with drivers update from toolbox) .. the problem continues to exist!!


Please assist!


Posts: 165
Registered: ‎06-26-2008
Location: Warszawa, Poland
Message 3 of 3 (1,085 Views)

Re: Suddenly OS can't see fingerprint reader (w500)

[ Edited ]

The "computer name is invalid" error seem to be related with you changing the computer name. I had this once or twice when I've change my systems name or when I've changed the password. Seems that the fingerprint software's way of working is that it enters a password associated with a system. This might also have something to do with you having multiple systems. I've used the software to "clear all fingerprint data" and new enrolled fingerprints worked again.


On the other hand side the "cannot communicate with the sensor" error indicate that the sensor is dead. I've also had it once and, as well, device manager showed it as working properly. That might be because the sensor is connected with the palmrest part and there is only one cable for both touchpad and the sensor. No matter how it works I've had mine replaced.

T540 i7 4700MQ, GT 730M, 8GB RAM, Win7
Top kudoed Authors