English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics

5 Posts



15 Signins

128 Page Views

  • Posts: 5
  • Registered: ‎02-21-2015
  • Location: US
  • Views: 128
  • Message 1 of 1

ThinkPad W541 - Intel Quick Sync will not work and internal mic(s) will NOT mute either

2018-05-27, 12:13 PM

Hi there,


I own a ThinkPad W541 in basically stock condition (only alteration has been to add a second 8GB Samsung DDR3 stick, same part number, and a 1TB Hitachi internal 2.5" hard drive in the Ultra Bay since I don't need the optical drive). I am running Windows 7 Professional x64 with the latest drivers for all devices as provided by Lenovo System Update. My issue is that I'm attempting to make use of the Intel Quick Sync video encoding capability that's part of the Intel Core i7-4810MQ CPU in this laptop (it's actually provided by the Intel HD 4600 GPU) and I'm not having any luck whatsoever.

As noted, the drivers currently in use for the Intel HD 4600 GPU are the ones provided by Lenovo itself:  (NVIDIA Graphics Driver)             (NVIDIA HD Audio Driver)  (Intel Graphics Driver)    (Intel HD Audio Driver)

 and so far as noted I've had zero success with getting Quick Sync to function. I'm attempting to use the standalone x264 encoder, and I've also attempted to use HandBrake which does see that the Quick Sync encoder IS there and IS available (this snippet of the HandBrake encoding log is offered as proof):


[05:22:57] CPU: Intel(R) Core(TM) i7-4810MQ CPU @ 2.80GHz
[05:22:57] - Intel microarchitecture Haswell
[05:22:57] - logical processor count: 8
[05:22:57] Intel Quick Sync Video support: yes
[05:22:57] - Intel Media SDK hardware: API 1.17 (minimum: 1.3)
[05:22:57] - H.264 encoder: yes
[05:22:57] - preferred implementation: hardware (any) via D3D11
[05:22:57] - capabilities (hardware): breftype vsinfo opt1 opt2+mbbrc+extbrc+trellis+ib_adapt+nmpslice
[05:22:57] - H.265 encoder: no


but again whenever I call upon it to actually do the encoding, there's almost zero use of the GPU (as measured by GPU-Z) during the encode process - it's all pure CPU encoding and it's getting frustrating trying to figure out why this is *NOT* working as designed. I'm guessing the Nvidia Optimus crap and this device being set up without an actual discrete GPU (the K2100M is basically nothing more than a 3D accelerator just as the original 3dfx Monster I and II cards were). It was a poor decision on Intel and Nvidia and even Lenovo's part to make this hardware work in this manner.

This laptop is still under warranty, actually, so I'd really love to get some kind of explanation about why this isn't working as it's designed to work but I can't be sure any actual Lenovo tech support or engineers might be around this community forum to help me understand what it's not working the way it's supposed to.


If anyone has any tips - and believe me I've spent hours attempting to get this working, I've attached external monitors as some forum posts at other websites offered, and disconnected them, and changed the Windows display options to "Extend the displays" and still nothing ever works.


As a side issue, the internal mic(s) will NOT mute even when using the Lenovo - Microphone Mute applet, nor using the hardware key combo (Fn + F4 and yes the orange light comes on to signify it's "working"). No matter what I do the internal mic(s) will never ever actually mute for any reason and I end up having to disable the device entirely in the Recording mixer of Windows 7 to make it not pick anything up. This is not something that should be happening, and again I'm using the latest Realtek HD audio drivers as pulled down with Lenovo System Update ( dated 03/27/18).

It's highly frustrating to own a high end piece of hardware (even if it's approaching 3 years of age) that can't do what it's built to do.

Thanks for any information or suggestions that can actually help me resolve this.

Have fun, always...



Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop