cancel
Showing results for 
Search instead for 
Did you mean: 
Lenovo Staff
Views: 8,187

Question

I have ThinkPad W540 and was trying to re-image my operating system to a new drive, however, 2 out of 2 of my machines just stuck at the "ThinkPad" or "Lenovo" logo screen. Pressing F1 or F2 have no effect. It is not possible to enter the BIOS setup at all.

 

Same result even with Windows 7 and Windows 8.

Answer

A new BIOS should fix this issue. Please see below on the BIOS verison and its link to support site for download.

 

W540 BIOS 2.08 and above WinFlash package (flash from Windows):

http://support.lenovo.com/en_US/downloads/detail.page?&DocID=DS039077

 

W540 BIOS 2.08 and above ISO package (flash from CDROM):

http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS039078

 

T540p BIOS 2.07 and above WinFlash package (flash from Windows):

http://support.lenovo.com/en_US/downloads/detail.page?&DocID=DS038147

 

T540p BIOS 2.07 and above ISO package (flash from CDROM):

http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS038148

 

BIOS updates for other affected systems will come later.

 

To be clear, if you encounter this problem where the system cannot get past POST, your system board needs to be replaced under warranty.  After the system board is replaced, but before re-installing the SSD, the BIOS must be updated to the above version.

Was this information helpful?

Comments
Mateenn

Hi,

My lenovo thinkpad e460 is stuck or Hang at Lenovo logo screen. Unable to go in BIOS or no keystroke is working. 

It is just still stucked.

What should I do?

JoeP3

Hi,

I had similar problem. Lenovo logo comes on then laptop resets and starts again. Lenovo replaced the mother board. Now, that problem is solved but the wireless range is too low. I have to be within 5 ft of the router to connect. I went through all suggested setups without success. Router is confirmed good on Cellphone and another Laptop. My new motherboard could be defective? If anyone knows a fix, please reply.