cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
iL1fe
Blue Screen Again
Posts: 1
Registered: ‎10-12-2016
Location: US
Views: 2,625
Message 1 of 7

Thinkpad P50 USB 3.0 UASP issue

Greetings.

 

Been running into issue with a P50 when using external USB 3.0 enclosures that support UASP.  The enclosures are Vantec (different encloure models) with WD RE drives installed.

 

The drives don't respond properly and hang the entire system when USAP driver is used.  Event logs filled with:

 

Event 129, UASPStor

Reset to device, \Device\RaidPort#

 

Issue with UASP is happening when using workstation dock or directly attached to P50 USB3 port.

 

2 months ago I tried many things to resolve this error including contacting Lenovo about potential issues with drivers or firmware problems.  All lenovo did is transfer me to Microsoft 800 # :-/  So then I found a temp solution to force system to use traditional USB3.0 driver by renaming  uaspstor.sys with usbstor.sys.  

Details here:  http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_devices/using-scsi-attached-s...

 

As soon as UASP is disabled the both enclosures / drives behaved correctly.  No timeouts and full throughput on disks.

 

So this client recently received Win10 Pro anniversary upgrade which happened to undo my hack restoring UASPstor.sys.  USB disks hanging system again.  I re-did this hack and he is working but hoping to resolve this correctly.

 

Has anyone ran into this or any ideas what is causing it?

 

Thanks.

Community SeniorMod
Community SeniorMod
Posts: 3,466
Registered: ‎12-01-2007
Location: US
Views: 2,488
Message 2 of 7

Re: Thinkpad P50 USB 3.0 UASP issue

Hello,

 

I haven't heard of this myself, but I'm curious if the problem is specific to the combination of ThinkPad P50 + Vantec external USB 3.0 enclosure and Western Digital RE (enterprise) drives.  I have used a variety of generic external USB enclosures with the ASMedia USB to SATA bridge chipset and various 2.5" HDDs and SSDs and never noticed this behavior before.

 

Regards,

 

Aryeh Goretsky

 



I am a volunteer and neither a Lenovo nor a Microsoft employee.

L380 YogaP72 (20MB-*)P50 (20EN-*)S230u (3347-4HU)T23 (2648-LU7)T42 (2378-R4U)T43p (2678-H7U)T61p (6459-CTO)W510 (4318-CTO)W530 (2441-4R3)W530 (2441-4R3)X100e (3508-CTO)X120e (0596-CTO)X220 (4286-CTO)X250 (20CM-*)Yoga 370

  Communities:   English    Deutsche    Español    Português    Русскоязычное    Česká    Slovenská    Українська   Język Polski    Moto English

cyberspyder
Fanfold Paper
Posts: 6
Registered: ‎12-12-2016
Location: US
Views: 1,866
Message 3 of 7

Re: Thinkpad P50 USB 3.0 UASP issue

Hello all,


I have a U32 shadow SCSI external disk drive, and am using LENOVO Laptop, and am getting the same problems with RANDOM disconnecting and reconnecting.


So, I tried the suggerted FIX, and it didn't work. So I proceded to find an UPDATED uaspstor.sys file and DL'd one and went through the entire process as laid out by a previous user to no avail.


So, I TROUBLE SHOT the problem and found at least 7,000 errors! (as shown in the included screenshot/s)


I then proceded to replace the uaspstor.sys with a newer version created on Thursday, ‎July ‎26, ‎2012, ‏‎1:00:58 AM

and I'm still getting the RANDOM dis/reconnects although SLIGHTLY less often. Only when I move the cable which in turn moves the USB plug from the USB 3.0 slot.


Does anybody have a FIX for this issue which has/had become very annoying?


I use the U32 shadow SCSI external disk drive as a media server and have about 400+ movies already on it and the drive constantly disappering during a normal READ/WRITE is very much a disappointment!


I sure hope that someone has a FIX or some kind of a WORKAROUND!

Screenshot_61.png
Sincerly,

Ron Freda

 

 

Moderator comment: Email address(es) removed to defeat spambots.

cyberspyder
Fanfold Paper
Posts: 6
Registered: ‎12-12-2016
Location: US
Views: 1,840
Message 4 of 7

Re: Thinkpad P50 USB 3.0 UASP issue

Well I found a temporary FIX for this problem (temporary because I must give it a few days to see if it really works and holds up)

This was way too easy, and hopefully solves this problem for most/all of you.

I went to this site https://www.online-tech-tips.com/computer-tips/usb-device-not-recognized/ and followed the FIRST solution and my device OYEN U32 shadow SCSI external disk drive FINALLY connected and showed up and has been stable for at least the past 30 minutes now and counting.......

Yes, I found it very hard to believe that it was as simple as that.

So, I will post any changes to this forum if anything goes south......

Ron Freda

 

Moderator comment: Email address(es) removed to defeat spambots.

cyberspyder
Fanfold Paper
Posts: 6
Registered: ‎12-12-2016
Location: US
Views: 1,831
Message 5 of 7

Re: Thinkpad P50 USB 3.0 UASP issue

Well, it has again started to crap out AGAIN!!! But it has been very easy to come right back on by slightly wiggling the USB plug (which makes me think that it might be a DEFECTIVE cable or plug.

I will however keep the group informed one way or another.
cyberspyder
Fanfold Paper
Posts: 6
Registered: ‎12-12-2016
Location: US
Views: 1,801
Message 6 of 7

Re: Thinkpad P50 USB 3.0 UASP issue

Well it is happening quite often now BUT it just makes the disconnect SOUND but it stays connected? Go figure.......:-(
idbirch
Paper Tape
Posts: 4
Registered: ‎08-11-2018
Location: GB
Views: 1,328
Message 7 of 7

Re: Thinkpad P50 USB 3.0 UASP issue

I've registered just to say thanks to iL1fe for posting this thread and a link to the USBStor workaround, hopefully you're still around to see this.

 

My problem was the same as yours in that a USB 3.0 SATA dock would disconnect when writing large amounts of data to it.  This is a newly built PC with a Gigabyte Aorus Gaming 7 motherboard running Windows 10 Pro 1803 64-bit, fully patched.  The dock in question is a Fideco dual drive dock, seen here: Amazon product page

 

At first I bought new USB 3.0 shielded cables, tried newer AsMedia drivers and even bought a PCI-e USB3 card thinking it was a problem with either Gigabyte or AsMedia drivers.  Even with the PCI-e card though, the problem remained. Until I switched out uaspstor.sys for usbstor.sys.  I could only write to a drive in the dock for a few minutes before but it's been writing solidly for the past hour with no drops!  All my hard disks are Western Digital greens by the way, if that's relevant.

 

I did find a slightly slicker way to replace usbstor.sys that doesn't involve command prompt usage, just open regedit and navigate to the folowing key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UASPStor

 

Change the 'ImagePath' value to '\SystemRoot\System32\drivers\usbstor.sys' and reboot.  Same fix logically but with a slightly easier way of applying, plus as it's registry based it could easily be applied remotely if necessary, or with a script.

 

 

 

And we're back...

Move delayed but still coming

Learn More

Check out current deals!


Shop current deals

Top Kudoed Authors