Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: P and W Series Mobile Workstations
All Forum Topics
Options

54 Posts

05-04-2011

United States

230 Signins

897 Page Views

  • Posts: 54
  • Registered: ‎05-04-2011
  • Location: United States
  • Views: 897
  • Message 1 of 20

UEFI-only Won't Boot Windows Installation DVD

2011-05-19, 12:45 PM

As you can see from my topic subject, my W520 laptop won't boot from my Windows 7 Installation DVD when it is set to UEFI-only mode. I don't get any errors or anything, the screen just goes black for a second and returns to the Boot Menu, when I select the DVD drive. For what it's worth, my hard drive is already GPT partitioned, and I need to repair the installation.

 

Before I ask for help, I just want to mention that I created this particular Windows 7 Installation DVD using the All-in-One tutorial so that I could have 32-bit and 64-bit options all on the same disc. The disc booted fine in "Legacy/UEFI" boot mode, so I'm not sure what the problem is. Does anyone have insight into this?

 

EDIT: I've been following this tutorial: http://www.insanelymac.com/forum/index.php?showtopic=186440 and am at Step 14.

Reply
Answer
Options

54 Posts

05-04-2011

United States

230 Signins

897 Page Views

  • Posts: 54
  • Registered: ‎05-04-2011
  • Location: United States
  • Views: 897

Re: UEFI-only Won't Boot Windows Installation DVD

2011-05-20, 1:47 AM

Thanks for verifying! I'll burn a copy of the original Digital River ISO and edit this post with the results.

 

EDIT: Strangely enough, the original Digital River installation DVD I just created (and Verified through ImgBurn) yielded the same disappointing results.

 

As luck would have it, I found a different Windows 7 installation DVD that my former professor downloaded from MSDN awhile back. It worked!. It's a Windows 7 Enterprise x64 disc, no SP1. The Volume label (google it) is GRMCENXVOL_EN_DVD. I don't know if it's available anywhere to the public, and I'm frankly too tired to google it. Good luck.

 

After inserting the DVD and clicking Repair Windows, it  gave me the prompt "Windows found problems with your computer's startup options. Do you want to apply repairs and restart?" I clicked Repair and Restart, and the system restarted. Windows ran a chkdsk operation and restarted. It went to the Welcome screen within 1-2 seconds (UEFI, finally), but froze. I suspect that this is because of the Fingerprint Reader that a couple users have been having problems with after doing UEFI-only. I'll save that for another thread, perhaps.

 

Sadly, I'm still unsure as to what the difference between the Enterprise Windows 7 DVD and  the ISO download I got from Digital River. To anyone looking at this for a solution, I'd recommend searching for the ISO download of the disc in bold above, even if it's trial-only. Remember, we just need something that'll boot so you can repair your installation after formatting it for GPT.

 

For what it's worth, here's the media that was used:

Enterprise disc --> Sony DVD-R

Home Premium & Others --> Staples DVD+R

 

EDIT 2: BSOD on startup can be fixed by putting this driver for your Fingerprint reader on a flash drive and installing it in Safe Mode (thanks to sompops from forum.thinkpads.com for the heads-up): http://www.upek.com/support/downloads/windows7/legacy/

Reply

Replies(19)
Options

395 Posts

08-03-2009

UK

1342 Signins

9464 Page Views

  • Posts: 395
  • Registered: ‎08-03-2009
  • Location: UK
  • Views: 9464
  • Message 2 of 20

Re: UEFI-only Won't Boot Windows Installation DVD

2011-05-19, 15:50 PM

I heard that UEFI-only boot is supported by the Windows 7 SP1 installation media but not the RTM one.

Reply
Options

54 Posts

05-04-2011

United States

230 Signins

897 Page Views

  • Posts: 54
  • Registered: ‎05-04-2011
  • Location: United States
  • Views: 897
  • Message 3 of 20

Re: UEFI-only Won't Boot Windows Installation DVD

2011-05-19, 21:46 PM

Thanks for the suggestion, hazart. Unfortunately, I burned a new Windows 7 Home Premium SP1 x64-only disc (not RTM), and I got the same result after trying to boot from the DVD drive. Could this be a firmware issue on Lenovo's end?

ThinkPads and SSDs: Part 1 Part 2 Part 3
Reply
Options

921 Posts

11-26-2008

Norway

8089 Signins

59129 Page Views

  • Posts: 921
  • Registered: ‎11-26-2008
  • Location: Norway
  • Views: 59129
  • Message 4 of 20

Re: UEFI-only Won't Boot Windows Installation DVD

2011-05-19, 22:33 PM

 

I installed Windows 7 SP1 Enterprise x64 with the computer set to UEFI only. What is the UEFI/BIOS version of your computer?

 

The UEFI/BIOS version 1.21 contains this fix: "(Fix) Fixed an issue where OS boot might fail from the CD.".

 

So in case you got an older version you could try a upgrade to the latest version and see if that helps.

 

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-77033

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-77034

 

-gan

Reply
Options

54 Posts

05-04-2011

United States

230 Signins

897 Page Views

  • Posts: 54
  • Registered: ‎05-04-2011
  • Location: United States
  • Views: 897
  • Message 5 of 20

Re: UEFI-only Won't Boot Windows Installation DVD

2011-05-19, 22:59 PM

The UEFI/BIOS is the first thing I updated on the computer, so mine's 1.22. I wish it were that easy, though :) Could 1.22 have re-introduced the problem?

 

EDIT: Holy smokes! There's another version of the UEFI-BIOS already :O Unfortunately, my hard drive is stuck in limbo! It's now partitioned in GPT and needs to be repaired. I'll use the bootable BIOS cd and report back if the new version works

ThinkPads and SSDs: Part 1 Part 2 Part 3
Reply
Options

921 Posts

11-26-2008

Norway

8089 Signins

59129 Page Views

  • Posts: 921
  • Registered: ‎11-26-2008
  • Location: Norway
  • Views: 59129
  • Message 6 of 20

Re: UEFI-only Won't Boot Windows Installation DVD

2011-05-19, 23:19 PM

Well i did the installation of Windows before i did a upgrade to UEFI/BIOS 1.25, but i believe i used version 1.21.

 

To be updated with new drivers, bios and software releases for the W520 you can subscribe to this RSS feed:

http://download.lenovo.com/rss/ThinkPad_W520.rss

 

With new Thinkpad models the updates are normally released pretty frequently.

 

-gan

Reply
Options

54 Posts

05-04-2011

United States

230 Signins

897 Page Views

  • Posts: 54
  • Registered: ‎05-04-2011
  • Location: United States
  • Views: 897
  • Message 7 of 20

Re: UEFI-only Won't Boot Windows Installation DVD

2011-05-19, 23:23 PM

Strangely enough, after using the BIOS bootable CD to update my BIOS, my UEFI BIOS Version is 1.24, not 1.25.

 

Gah! The problem is still there! My installation DVD won't boot in UEFI-only mode :(

ThinkPads and SSDs: Part 1 Part 2 Part 3
Reply
Options

921 Posts

11-26-2008

Norway

8089 Signins

59129 Page Views

  • Posts: 921
  • Registered: ‎11-26-2008
  • Location: Norway
  • Views: 59129
  • Message 8 of 20

Re: UEFI-only Won't Boot Windows Installation DVD

2011-05-19, 23:32 PM

Yes, i forgot to mention. Same with my computer.

 

C:\>wmic bios list brief
Manufacturer  Name                 SerialNumber  SMBIOSBIOSVersion  Version
LENOVO        Default System BIOS  XXXXXXX       8BET44WW (1.24 )   LENOVO - 1240

 

If you try to change the boot order with the CD/DVD first does it make a difference or same problem?

For the record i downloaded and used the original Windows 7 Enterprise x64 with SP1 ISO from MSDN.

 

Where did you get your Windows 7 installation media?

 

-gan

Reply
Options

54 Posts

05-04-2011

United States

230 Signins

897 Page Views

  • Posts: 54
  • Registered: ‎05-04-2011
  • Location: United States
  • Views: 897
  • Message 9 of 20

Re: UEFI-only Won't Boot Windows Installation DVD

2011-05-19, 23:51 PM

I just tried moving the ATAPI CD0 to the first spot on the >Boot list with the correct HDD right underneath. Unfortunately, that did nothing.

 

The image I'm using I slipstreamed SP1  into myself (using RT Seven Lite), and the original ISO is "X15-65733.iso" from Digital River.

 

 

EDIT: By the way, could it be a problem with the volume label on the DVD? My label is "Win7_HomePrex64SP1" (too long?)

 

 

Thanks for all the help so far, gan :)

ThinkPads and SSDs: Part 1 Part 2 Part 3
Reply
Options

921 Posts

11-26-2008

Norway

8089 Signins

59129 Page Views

  • Posts: 921
  • Registered: ‎11-26-2008
  • Location: Norway
  • Views: 59129
  • Message 10 of 20

Re: UEFI-only Won't Boot Windows Installation DVD

2011-05-20, 0:00 AM

I doubt that the label should have anything to say. If you burn the original ISO will it work to boot from that media? Maybe something during the slipstream process is the reason why it doesn't work.

 

I really don't know why it doesn't work. I installed Windows 7 starting out with UEFI and didn't try to change it afterwards. If i understand this correctly you are actually trying a switch to UEFI without having to reinstall since you originally installed Windows with legacy mode?

 

-gan

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms