cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
fcampano
Ctrl-Alt-Del
Posts: 8
Registered: ‎12-05-2014
Location: New Smyrna Beach, FL
Views: 3,015
Message 6 of 64

UltraNav Trackpad stops working after newest BIOS update 12-05-2014

Dear Community,

 

Both me and a friend of mine have Lenovo W540s.  Everything was working perfectly fine with all of our hardware, until today.  A BIOS update came out and installed correctly on both of our machines.  After this update both of our UltraNAV features on the trackpad are all dead.  After that first restart a message appeared "finding new hardware" and it found a generic mouse on the laptop.  Now when I try to re-install the UltraNav drivers, it says no hardware found.  I tried both the drivers on Lenovo.com and the manufacture's website all with no luck.

 

Does anyone have any ideas on how to fix our UltraNav pads?   Thank you!

-Frank

-Frank C.

W540 | i7-4930MX | 16GB RAM | Quadro K2100M | RAID 0 Dual 512 SSD
Xentrax
Punch Card
Posts: 21
Registered: ‎07-06-2011
Location: Russia, Moscow
Views: 3,378
Message 1 of 64

W540 touchpad not working (bios bug?)

Hi, for some reason Touchpad and Trackpad stop working suddenly.

It looks like this:

1. First all works fine.

2. Then only mouse movement works. Taps and clicks do not work.

3. Later on move movement stops working too.

 

Reboot does not help. Removing battery does not help.

 

But.

If I disable Trackpad and Tachpad in BIOS.

Then Save BIOS Settings

Reboot into BIOS again.

Enable Trackpad and Tachpad in BIOS back.

Boot to Windows. Touchpad works ok.

 

 

This laptop is new - in period when different defects not detected at the factory - start to appear, so I am not really surprised. But couple weeks ago I updated BIOS via Lenovo System Update. And I kind of remember the problem did not manifest before BIOS update. Today I've updated BIOS from file without checking aht version I was running. Now it's 2.16 and problem is there.

 

I personally think it is just faulty hardware and BIOS update was just a coinsidence.

Now more details.

Both Windows 8.1 and Linux are affected.

Just reinstalled W8.1 with update.

'PS/2 Mouse driver' is present in Device Manager and Windows does not show any problems.

(Same if UltraNav driver is installed).

Problem is still there if I remove Microsoft wireless mouse receiver from USB.

All Windows Update updates.

Nearly all Lenovo updates, even tried to install FIngerPrint software.

 

 

Is it a known issue? Is the only way is to go to Lenovo service for physical repair?

 

Maybe I just need to revert to some older BIOS version???

 

 

Faxe
Fanfold Paper
Posts: 7
Registered: ‎11-27-2014
Location: Germany, Hamburg
Views: 3,318
Message 2 of 64

Betreff: W540 touchpad not working (bios bug?)

If you go back to older version there is a restriction in the release notes of 2.16:

 

NOTES
- If the UEFI BIOS has been updated to version 2.15 or higher, it is no longer
  able to roll back to the version before 2.15 for security improvement.
W540, I7-4910MQ, 32 GB, 1 TB SSD, 3K IPS, K2100M, EM7345 4G
T500, T9600, 4GB, 320GB HD, 1680x1050, Radeon 3650, UMTS
mengxiangyue
Fanfold Paper
Posts: 10
Registered: ‎12-03-2014
Location: Australia
Views: 3,271
Message 3 of 64

Re: W540 touchpad not working (bios bug?)

Exactly the same for me. Wait for next BIOS update?

Faxe
Fanfold Paper
Posts: 7
Registered: ‎11-27-2014
Location: Germany, Hamburg
Views: 3,249
Message 4 of 64

Re: W540 touchpad not working (bios bug?)

I updated to BIOS 2.16 yesterday, no problems.

So waiting for the next BIOS maybe will not help you, it looks like an other reason, maybe hardware?

W540, I7-4910MQ, 32 GB, 1 TB SSD, 3K IPS, K2100M, EM7345 4G
T500, T9600, 4GB, 320GB HD, 1680x1050, Radeon 3650, UMTS
Xentrax
Punch Card
Posts: 21
Registered: ‎07-06-2011
Location: Russia, Moscow
Views: 3,238
Message 5 of 64

Re: W540 touchpad not working (bios bug?)

For me it looks like a hardware issue. Mine has 2014/07 manufacture date.

 

I'm yet to visit Lenovo service for diagnostics.

 

Bauden
Token Ring
Posts: 527
Registered: ‎02-24-2014
Location: AF
Views: 2,978
Message 7 of 64

Re: UltraNav Trackpad stops working after newest BIOS update 12-05-2014

Dunno, I do not use the trackpad, but it is active for minor surfing.  After the update to v2.16 (on W540), mousing the mouse cursor and tapping to enter still worked.  However, I never tested the other functions, as I gave up on this elite mouse pad.

 

So, just to let you know, the simple functions are still there after the BIOS update.

Faxe
Fanfold Paper
Posts: 7
Registered: ‎11-27-2014
Location: Germany, Hamburg
Views: 2,954
Message 8 of 64

Re: UltraNav Trackpad stops working after newest BIOS update 12-05-2014

The problem is not new, maybe you want to have a look here:

http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/W540-touchpad-not-working-bios-bug/m-p/1801898...

 

W540, I7-4910MQ, 32 GB, 1 TB SSD, 3K IPS, K2100M, EM7345 4G
T500, T9600, 4GB, 320GB HD, 1680x1050, Radeon 3650, UMTS
fcampano
Ctrl-Alt-Del
Posts: 8
Registered: ‎12-05-2014
Location: New Smyrna Beach, FL
Views: 2,945
Message 9 of 64

Re: UltraNav Trackpad stops working after newest BIOS update 12-05-2014

Thank you! 

 

I will deffiently give this a try.  I did try to look around first before I posted, apparently I did not look hard enough.

 

-Frank

-Frank C.

W540 | i7-4930MX | 16GB RAM | Quadro K2100M | RAID 0 Dual 512 SSD
fcampano
Ctrl-Alt-Del
Posts: 8
Registered: ‎12-05-2014
Location: New Smyrna Beach, FL
Views: 2,942
Message 10 of 64

Re: UltraNav Trackpad stops working after newest BIOS update 12-05-2014

I rarely use the tracktap myself, just now the palms of my hand hit it as I am typing and it messes everything up. lol

 

-Frank

-Frank C.

W540 | i7-4930MX | 16GB RAM | Quadro K2100M | RAID 0 Dual 512 SSD

Check out current deals!


Shop current deals

Top Kudoed Authors